summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-04-25 20:00:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-04-25 20:00:41 +0000
commitdca58d82183da890ba428b67a8b799ad2cf3fd22 (patch)
treee5eaf26ca28f123f828abd38e3afa9ae53f21d3d /sys-libs/libcap/files
parentarm KEYWORD (diff)
downloadhistorical-dca58d82183da890ba428b67a8b799ad2cf3fd22.tar.gz
historical-dca58d82183da890ba428b67a8b799ad2cf3fd22.tar.bz2
historical-dca58d82183da890ba428b67a8b799ad2cf3fd22.zip
finally finish static support from bug #22495, slight cleanup and latest debian patch.
Diffstat (limited to 'sys-libs/libcap/files')
-rw-r--r--sys-libs/libcap/files/digest-libcap-1.10-r42
-rw-r--r--sys-libs/libcap/files/libcap-1.10-r4-staticfix.diff55
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-libs/libcap/files/digest-libcap-1.10-r4 b/sys-libs/libcap/files/digest-libcap-1.10-r4
new file mode 100644
index 000000000000..ec126de2271e
--- /dev/null
+++ b/sys-libs/libcap/files/digest-libcap-1.10-r4
@@ -0,0 +1,2 @@
+MD5 4426a413128142cab89eb2e6f13d8571 libcap-1.10.tar.bz2 26686
+MD5 b867a0c1db9e8ff568415bbcd1fa65dc libcap_1.10-14.diff.gz 12928
diff --git a/sys-libs/libcap/files/libcap-1.10-r4-staticfix.diff b/sys-libs/libcap/files/libcap-1.10-r4-staticfix.diff
new file mode 100644
index 000000000000..2e8d7e0a5835
--- /dev/null
+++ b/sys-libs/libcap/files/libcap-1.10-r4-staticfix.diff
@@ -0,0 +1,55 @@
+diff -ur libcap-1.10.orig/libcap/Makefile libcap-1.10/libcap/Makefile
+--- libcap-1.10.orig/libcap/Makefile 2004-04-25 12:15:02.000000000 -0700
++++ libcap-1.10/libcap/Makefile 2004-04-25 12:40:47.000000000 -0700
+@@ -34,6 +34,7 @@
+ #
+ LIBNAME=libcap
+ PYTHONMODNAME=libcapmodule.so
++STATLIBNAME=$(LIBNAME).a
+ #
+
+ FILES=cap_alloc cap_proc cap_extint cap_flag cap_text cap_sys
+@@ -48,9 +49,9 @@
+ MINLIBNAME=$(MAJLIBNAME).$(MINOR)
+
+ ifdef PYTHON
+-all: $(MINLIBNAME) $(LIBNAME).a $(PYTHONMODNAME)
++all: $(MINLIBNAME) $(STATLIBNAME) $(PYTHONMODNAME)
+ else
+-all: $(MINLIBNAME) $(LIBNAME).a
++all: $(MINLIBNAME) $(STATLIBNAME)
+ endif
+
+ _makenames: _makenames.c cap_names.sed
+@@ -63,8 +64,8 @@
+ @echo "=> making cap_names.c from <sys/capability.h>"
+ @sed -ne '/^#define[ \t]CAP[_A-Z]\+[ \t]\+[0-9]\+/{s/^#define \([^ \t]*\)[ \t]*\([^ \t]*\)/ \{ \2, \"\1\" \},/;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/;p;}' < include/sys/capability.h | fgrep -v 0x > cap_names.sed # @sed -ne '/^#define[ \t]CAP[_A-Z]\+[ \t]\+[0-9]\+/{s/^#define CAP_\([^ \t]*\)[ \t]*\([^ \t]*\)/ \{ \2, \"\1\" \},/;y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/;p;}' < /usr/include/linux/capability.h | fgrep -v 0x > cap_names.sed
+
+-$(LIBNAME).a: $(OBJS)
+- ar cruv $(LIBNAME).a $(OBJS)
++$(STATLIBNAME): $(OBJS)
++ ar csruv $(STATLIBNAME) $(OBJS)
+
+ $(MINLIBNAME): $(LOBJS)
+ $(CC) -shared -fPIC -Wl,-soname,$(MAJLIBNAME) -o $@ $(LOBJS)
+@@ -88,7 +89,7 @@
+ mkdir -p -m 0755 $(INCDIR)/sys
+ install -m 0644 include/sys/capability.h $(INCDIR)/sys
+ mkdir -p -m 0755 $(LIBDIR)
+- install -m 0644 $(LIBNAME).a $(LIBDIR)
++ install -m 0644 $(STATLIBNAME) $(LIBDIR)
+ install -m 0644 $(MINLIBNAME) $(LIBDIR)/$(MINLIBNAME)
+ ln -sf $(MINLIBNAME) $(LIBDIR)/$(MAJLIBNAME)
+ ln -sf $(MAJLIBNAME) $(LIBDIR)/$(LIBNAME).so
+@@ -100,7 +101,10 @@
+
+ clean:
+ $(LOCALCLEAN)
+- rm -f $(OBJS) $(LOBJS) $(LIBNAME).a $(LIBNAME).so*
++ rm -f $(OBJS) $(LOBJS) $(STATLIBNAME) $(LIBNAME).so*
+ rm -f cap_names.h cap_names.sed _makenames libcap_wrap.c
+ cd include/sys && $(LOCALCLEAN)
++ifdef PYTHON
++ rm libcap.py libcap_wrap.o libcapmodule.so
++endif
+