summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-16 05:51:57 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-16 05:51:57 +0000
commitc6e0afdf44f4a84c0ef17d0e689304c4b6874f00 (patch)
tree2835fa1bc35a6d30c7b353081f100022c8a7f5bf /sys-libs/glibc/glibc-2.3.5.ebuild
parentVersion bump, closes bug 102191. (diff)
downloadhistorical-c6e0afdf44f4a84c0ef17d0e689304c4b6874f00.tar.gz
historical-c6e0afdf44f4a84c0ef17d0e689304c4b6874f00.tar.bz2
historical-c6e0afdf44f4a84c0ef17d0e689304c4b6874f00.zip
touchup status output while building
Package-Manager: portage-2.0.52-r1 http://ronaldmcnightrider.ytmnd.com/
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.5.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.5.ebuild89
1 files changed, 48 insertions, 41 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5.ebuild b/sys-libs/glibc/glibc-2.3.5.ebuild
index 4ba9d41ef570..b3e83e05c446 100644
--- a/sys-libs/glibc/glibc-2.3.5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.45 2005/09/16 05:03:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5.ebuild,v 1.46 2005/09/16 05:51:57 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -941,7 +941,7 @@ glibc_do_configure() {
GBUILDDIR=${WORKDIR}/build-${ABI}-${CTARGET}-$1
mkdir -p ${GBUILDDIR}
cd ${GBUILDDIR}
- einfo "Configuring GLIBC for $1 with: ${myconf}"
+ einfo "Configuring GLIBC for $1 with: ${myconf// /\n\t\t}"
${S}/configure ${myconf} || die "failed to configure glibc"
}
@@ -1207,20 +1207,22 @@ src_unpack() {
src_compile() {
crosscompile_setup
- # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
- local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ] ; then
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- export ABI
- einfo "Compiling ${ABI} glibc"
- src_compile
- done
- ABI="${OABI}"
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] && has_multilib_profile ; then
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
+ local MLTEST=$(type dyn_unpack)
+ if [[ ${MLTEST/set_abi} == "${MLTEST}" ]] ; then
+ OABI=${ABI}
+ einfo "Building multilib glibc for ABIs: $(get_install_abis)"
+ for ABI in $(get_install_abis) ; do
+ export ABI=${ABI}
+ src_compile
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
+ unset MLTEST
fi
- unset MLTEST
ABI=${ABI:-default}
toolchain-glibc_src_compile
@@ -1229,20 +1231,23 @@ src_compile() {
src_test() {
crosscompile_setup
- # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
- local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ] ; then
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- export ABI
- einfo "Testing ${ABI} glibc"
- src_test
- done
- ABI="${OABI}"
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] && has_multilib_profile ; then
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
+ local MLTEST=$(type dyn_unpack)
+ if [[ ${MLTEST/set_abi} == "${MLTEST}" ]] ; then
+ OABI=${ABI}
+ einfo "Testing multilib glibc for ABIs: $(get_install_abis)"
+ for ABI in $(get_install_abis) ; do
+ export ABI
+ einfo " Testing ${ABI} glibc"
+ src_test
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
+ unset MLTEST
fi
- unset MLTEST
ABI=${ABI:-default}
toolchain-glibc_src_test
@@ -1251,20 +1256,22 @@ src_test() {
src_install() {
crosscompile_setup
- # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
- local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ -z "${OABI}" -a "${MLTEST/set_abi}" = "${MLTEST}" ] ; then
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- export ABI
- einfo "Installing ${ABI} glibc"
- src_install
- done
- ABI="${OABI}"
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] && has_multilib_profile ; then
+ # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
+ local MLTEST=$(type dyn_unpack)
+ if [[ ${MLTEST/set_abi} == "${MLTEST}" ]] ; then
+ OABI=${ABI}
+ einfo "Installing multilib glibc for ABIs: $(get_install_abis)"
+ for ABI in $(get_install_abis) ; do
+ export ABI
+ src_install
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
+ unset MLTEST
fi
- unset MLTEST
ABI=${ABI:-default}