summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Rothe <corsair@gentoo.org>2005-04-29 16:20:01 +0000
committerMarkus Rothe <corsair@gentoo.org>2005-04-29 16:20:01 +0000
commit8239a12e45aeb522879ef2c9cc919f14e416aa69 (patch)
treeacf2d955fcf66a44dd2645009620f3b9fea0110a /sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
parentadded patch to fix compilation with the gcc3.4.x. thanks to Alex Rostovtsev <... (diff)
downloadhistorical-8239a12e45aeb522879ef2c9cc919f14e416aa69.tar.gz
historical-8239a12e45aeb522879ef2c9cc919f14e416aa69.tar.bz2
historical-8239a12e45aeb522879ef2c9cc919f14e416aa69.zip
Added CDEFINE values for ppc64
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 58b73448bdea..67a6876e9864 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.42 2005/04/25 01:40:25 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.43 2005/04/29 16:20:01 corsair Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -988,18 +988,16 @@ crosscompile_setup() {
powerpc64*)
export CFLAGS_ppc="${CFLAGS_ppc--m32}"
export CHOST_ppc="powerpc-unknown-linux-gnu"
- export CDEFINE_ppc=""
+ export CDEFINE_ppc="__powerpc__"
export LIBDIR_ppc="lib"
export CFLAGS_ppc64="${CFLAGS_ppc64--m64}"
export CHOST_ppc64="powerpc64-unknown-linux-gnu"
- export CDEFINE_ppc64=""
+ export CDEFINE_ppc64="__powerpc64__"
export LIBDIR_ppc64="lib64"
export MULTILIB_ABIS="ppc64"
export DEFAULT_ABI="ppc64"
-
- die "ppc64 crosscompile not yet supported. Bug a ppc64 dev to fill in the CDEFINE values in the glibc ebuild."
;;
sparc64*)
export CFLAGS_sparc32="${CFLAGS_sparc--m32}"