summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-06-30 06:51:05 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-06-30 06:51:05 +0000
commit9f87d637a625a69ae831321f7573cda4e6362819 (patch)
treeecdcb7fb60095f97d83745121ca87310daae286f /sys-libs/db
parentAdd db_185.h to the linked files (diff)
downloadhistorical-9f87d637a625a69ae831321f7573cda4e6362819.tar.gz
historical-9f87d637a625a69ae831321f7573cda4e6362819.tar.bz2
historical-9f87d637a625a69ae831321f7573cda4e6362819.zip
Add db_185.h to the linked files
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/Manifest10
-rw-r--r--sys-libs/db/db-3.2.9-r6.ebuild163
-rw-r--r--sys-libs/db/db-4.0.14.ebuild5
-rw-r--r--sys-libs/db/db-4.1.24.ebuild5
-rw-r--r--sys-libs/db/db-4.1.25.ebuild6
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r61
6 files changed, 178 insertions, 12 deletions
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index 248fd7893816..5f3d848b7f41 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -1,15 +1,15 @@
-MD5 79ee2d376f5a52bfe0f014f0a380becd ChangeLog 6304
+MD5 ae945fc50ec7294656140ebe1868b03b ChangeLog 6304
MD5 f5688fefc8d29c29aa1ae2833131eaa3 db-1.85-r1.ebuild 1412
MD5 5f58370f7996039a42c4805b7739715b db-3.2.3h-r4.ebuild 2456
MD5 7bbdb8e7c9f500b78b934c556a7f5eeb db-3.2.9-r1.ebuild 2585
MD5 a037a9713737ca0f498c85f7e0e1dbd6 db-3.2.9-r2.ebuild 3222
MD5 bb23c5ae6636a708085812b7832e2c60 db-3.2.9.ebuild 2465
MD5 0dcedfa3f8fa0c10ac06b6f27217e45d db-3.3.11.ebuild 2408
-MD5 f4e28f62aadadbbd07b63ae7b5f8da0e db-4.1.25.ebuild 2233
-MD5 0fa7df22bc02967484da357720832148 db-4.1.24.ebuild 2234
-MD5 6cd7907826a74bd0b3340e1760d65a2c db-4.0.14.ebuild 2385
+MD5 c5c7fa934af8fbd003cf2dbec6b485d2 db-4.1.25.ebuild 2233
+MD5 aee477a37e90373dcd42753f8ae903fb db-4.1.24.ebuild 2234
+MD5 bf484036409a437296d78662b721653f db-4.0.14.ebuild 2385
MD5 cb0b279b7b645ca4d0e997fefb56ebac db-3.2.9-r5.ebuild 4267
-MD5 2d8efe946d17541a6b5856a7980c5df5 db-3.2.9-r6.ebuild 4323
+MD5 c95e9884d4a13b5d17ba264e4b5abf78 db-3.2.9-r6.ebuild 4322
MD5 1260aeee2785bda43e81a36b6cb247be files/digest-db-4.1.25 62
MD5 194200b3295b95b46b4564980af27f1f files/db-3.2.9-fix-dep-link.patch 1005
MD5 ecd81fa9868ec49c61306444144d44a9 files/db.1.85.patch 55584
diff --git a/sys-libs/db/db-3.2.9-r6.ebuild b/sys-libs/db/db-3.2.9-r6.ebuild
new file mode 100644
index 000000000000..d0f3785e85b5
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r6.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r6.ebuild,v 1.1 2003/06/30 06:50:56 pauldv Exp $
+
+IUSE=""
+
+inherit libtool
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com/"
+
+SLOT="3"
+LICENSE="DB"
+# This ebuild is to be the compatibility ebuild for when db4 is put
+# in the tree.
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+# We need m4 too else build fails without config.guess
+
+# This doesn't build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+src_unpack() {
+ unpack ${A}
+
+ chmod -R ug+w *
+
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/patch.3.2.9.1
+ epatch ${FILESDIR}/patch.3.2.9.2
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/${P}-fix-dep-link.patch
+
+ # We should get dump185 to link against system db1 ..
+ # <azarah@gentoo.org> (23 Feb 2003)
+ mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
+ -e 's:DB185LIB=:DB185LIB= -ldb1:' \
+ ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
+
+ # Fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+ sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
+}
+
+src_compile() {
+ local conf=
+
+ conf="--host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cxx \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr"
+ # --enable-rpc aparently does not work .. should verify this
+ # at some stage ...
+
+ # NOTE: we should not build both shared and static versions
+ # of the libraries in the same build root!
+
+ einfo "Configuring ${P} (static)..."
+ mkdir -p ${S}/build-static
+ cd ${S}/build-static
+ ../dist/configure ${conf} \
+ --enable-static || die
+
+ einfo "Configuring ${P} (shared)..."
+ mkdir -p ${S}/build-shared
+ cd ${S}/build-shared
+ ../dist/configure ${conf} \
+ --enable-shared || die
+
+ # Parallel make does not work
+ MAKEOPTS="${MAKEOPTS} -j1"
+ einfo "Building ${P} (static)..."
+ cd ${S}/build-static
+ emake || die "Static build failed"
+ einfo "Building ${P} (shared)..."
+ cd ${S}/build-shared
+ emake || die "Shared build failed"
+}
+
+src_install () {
+ cd ${S}/build-shared
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ install || die
+
+ cd ${S}/build-static
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+
+ dodir usr/include/db3
+ cd ${D}/usr/include
+ mv *.h db3
+ ln db3/db.h db.h
+
+ cd ${D}/usr/lib
+ ln -s libdb-3.2.so libdb.so.3
+
+ # For some reason, db.so's are *not* readable by group or others,
+ # resulting in no one but root being able to use them!!!
+ # This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ # The .la's aren't readable either
+ chmod go+r *.la
+
+ cd ${S}
+ dodoc README LICENSE
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html
+ rm -rf ${D}/usr/docs
+
+ #making things work better with the db4 ebuild
+ for fname in ${D}/usr/bin/db_*
+ do
+ mv ${fname} ${fname//\/db_/\/db3_}
+ done
+ ln -sf /usr/include/db4/db.h ${D}/usr/include/db.h
+}
+
+fix_so () {
+ cd ${ROOT}/usr/lib
+ target=`find -type f -maxdepth 1 -name "libdb-*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb.so
+ target=`find -type f -maxdepth 1 -name "libdb_cxx*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_cxx.so
+ target=`find -type f -maxdepth 1 -name "libdb_tcl*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_tcl.so
+ target=`find -type f -maxdepth 1 -name "libdb_java*.so" |sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
+
+ cd ${ROOT}/usr/include
+ target=`ls -d db?|sort |tail -n 1`
+ [ -n "${target}" ] && ln -sf ${target}/db.h .
+ [ -n "${target}" ] && ln -sf ${target}/db_185.h .
+}
+
+pkg_postinst () {
+ fix_so
+}
+
+pkg_postrm () {
+ fix_so
+}
+
diff --git a/sys-libs/db/db-4.0.14.ebuild b/sys-libs/db/db-4.0.14.ebuild
index b1265bb77648..1614ea1908b7 100644
--- a/sys-libs/db/db-4.0.14.ebuild
+++ b/sys-libs/db/db-4.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.25 2003/06/22 19:13:11 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14.ebuild,v 1.26 2003/06/30 06:50:56 pauldv Exp $
IUSE="tcltk java"
@@ -80,8 +80,9 @@ fix_so () {
[ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
cd ${ROOT}/usr/include
- target=`ls -d db? |tail -n 1`
+ target=`ls -d db? |sort |tail -n 1`
[ -n "${target}" ] && ln -sf ${target}/db.h .
+ [ -n "${target}" ] && ln -sf ${target}/db_185.h .
}
pkg_postinst () {
diff --git a/sys-libs/db/db-4.1.24.ebuild b/sys-libs/db/db-4.1.24.ebuild
index d6e482143c7d..1cfbcf02b5b5 100644
--- a/sys-libs/db/db-4.1.24.ebuild
+++ b/sys-libs/db/db-4.1.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.19 2003/06/22 19:13:11 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.24.ebuild,v 1.20 2003/06/30 06:50:56 pauldv Exp $
IUSE="tcltk java"
@@ -75,8 +75,9 @@ fix_so () {
[ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
cd ${ROOT}/usr/include
- target=`ls -d db? |tail -n 1`
+ target=`ls -d db? |sort |tail -n 1`
[ -n "${target}" ] && ln -sf ${target}/db.h .
+ [ -n "${target}" ] && ln -sf ${target}/db_185.h .
}
pkg_postinst () {
diff --git a/sys-libs/db/db-4.1.25.ebuild b/sys-libs/db/db-4.1.25.ebuild
index 82b1d3c18438..6dc3b7f1beef 100644
--- a/sys-libs/db/db-4.1.25.ebuild
+++ b/sys-libs/db/db-4.1.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25.ebuild,v 1.7 2003/06/22 19:13:11 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25.ebuild,v 1.8 2003/06/30 06:50:56 pauldv Exp $
IUSE="tcltk java"
@@ -76,9 +76,9 @@ fix_so () {
[ -n "${target}" ] && ln -sf ${target//.\//} libdb_java.so
cd ${ROOT}/usr/include
- target=`ls -d db? |tail -n 1`
+ target=`ls -d db? |sort|tail -n 1`
[ -n "${target}" ] && ln -sf ${target}/db.h .
-
+ [ -n "${target}" ] && ln -sf ${target}/db_185.h .
}
pkg_postinst () {
diff --git a/sys-libs/db/files/digest-db-3.2.9-r6 b/sys-libs/db/files/digest-db-3.2.9-r6
new file mode 100644
index 000000000000..cc0f167ea09b
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r6
@@ -0,0 +1 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238