summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-12-16 10:29:20 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-12-16 10:29:20 +0000
commitcb83e728bd3f0e181e32abdb8fb014de1ed13a35 (patch)
tree22b33d35e12b3b277784b289c6abea65262642ee /sys-libs/db/db-4.2.52_p1.ebuild
parentStable on amd64. (diff)
downloadhistorical-cb83e728bd3f0e181e32abdb8fb014de1ed13a35.tar.gz
historical-cb83e728bd3f0e181e32abdb8fb014de1ed13a35.tar.bz2
historical-cb83e728bd3f0e181e32abdb8fb014de1ed13a35.zip
get_libdir support for multilib archs.
Diffstat (limited to 'sys-libs/db/db-4.2.52_p1.ebuild')
-rw-r--r--sys-libs/db/db-4.2.52_p1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-libs/db/db-4.2.52_p1.ebuild b/sys-libs/db/db-4.2.52_p1.ebuild
index 9c84e4dac349..04f299e4e7c6 100644
--- a/sys-libs/db/db-4.2.52_p1.ebuild
+++ b/sys-libs/db/db-4.2.52_p1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p1.ebuild,v 1.7 2004/09/01 18:24:55 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.2.52_p1.ebuild,v 1.8 2004/12/16 10:29:20 eradicator Exp $
IUSE="tcltk java doc"
@@ -72,7 +72,7 @@ src_compile() {
|| myconf="${myconf} --disable-java"
use tcltk \
- && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/$(get_libdir)" \
|| myconf="${myconf} --disable-tcl"
if use java && [ -n "${JAVAC}" ]; then
@@ -91,6 +91,7 @@ src_compile() {
--datadir=/usr/share \
--sysconfdir=/etc \
--localstatedir=/var/lib \
+ --libdir=/usr/$(get_libdir) \
--enable-compat185 \
--enable-cxx \
--with-uniquename \
@@ -101,7 +102,7 @@ src_compile() {
src_install () {
- einstall || die
+ einstall libdir="${D}/usr/$(get_libdir)" || die
db_src_install_usrbinslot