summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-09-03 19:26:45 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-09-03 19:26:45 +0000
commitd99445d4a76d0ebf45105dcb18257c94912093f7 (patch)
treeb0cf0e90d4f610e2913d568a76c06abf4243f887 /sys-kernel
parentmask new xfs-sources (diff)
downloadhistorical-d99445d4a76d0ebf45105dcb18257c94912093f7.tar.gz
historical-d99445d4a76d0ebf45105dcb18257c94912093f7.tar.bz2
historical-d99445d4a76d0ebf45105dcb18257c94912093f7.zip
updated version
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog12
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.193
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.19.ebuild113
3 files changed, 125 insertions, 3 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 0a0775635d64..a7c01dfbc31b 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.3 2002/07/16 04:51:20 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.4 2002/09/03 19:26:45 lostlogic Exp $
+
+*xfs-sources-2.4.19 (03 Sep 2002)
+
+ 03 Sep 2002; Brandon Low <lostlogic@gentoo.org> xfs-sources-2.4.19.ebuild:
+
+ New version, update to xfs-2002-08-13 from SGI, add EVMS support.
+
+*xfs-sources-2.4.18 (25 Apr 2002)
15 Jul 2002; Mark Guertin <gerk@gentoo.org>
Added arch keywords (-ppc -sparc -sparc64)
@@ -10,5 +18,3 @@
Added sys-apps/xfsprogs to DEPEND. These aren't stictly needed but the user
will very likely want them.
-*xfs-sources-2.4.18 (25 Apr 2002)
-
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.19 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.19
new file mode 100644
index 000000000000..14ba4811a5f5
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.19
@@ -0,0 +1,3 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 4baa9cef16910f54e90c30d0bb51a9d1 xfs-2.4.19-all-i386.bz2 856611
+MD5 c3edcb37a701f5528ab50cff4f5594fc patch-2.4.19-xfs.bz2 215835
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.19.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.19.ebuild
new file mode 100644
index 000000000000..3d251e0727f8
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.19.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.19.ebuild,v 1.1 2002/09/03 19:26:45 lostlogic Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${OKV}-xfs
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# This kernel is a straight XFS CVS snapshot from 13 Aug 2002 at 01:22 UTC
+# And evms support from http://evms.sourceforge.net/
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ ftp://oss.sgi.com/projects/xfs/download/patches/2.4.19/xfs-2.4.19-all-i386.bz2
+ http://gentoo.lostlogicx.com/patch-2.4.19-xfs.bz2"
+
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://oss.sgi.com/projects/xfs http://evms.sourceforge.net"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+if [ $ETYPE = "sources" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND="!build? ( >=sys-devel/binutils-2.11.90.0.31
+ sys-apps/xfsprogs )"
+ RDEPEND="${DEPEND}
+ !build? ( >=sys-libs/ncurses-5.2
+ sys-devel/perl
+ >=sys-apps/modutils-2.4.2
+ sys-devel/make )"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ bzcat ${DISTDIR}/xfs-${OKV}-all-i386.bz2 | patch -p1 || die
+ bzcat ${DISTDIR}/patch-${KV}.bz2 | patch -p1 || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig > Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make distclean || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}