summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-09-24 06:41:49 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-09-24 06:41:49 +0000
commit53caf42566103033472304d4e925489c3d82ac26 (patch)
tree77c0235a29126f2a9c99ca07a0e20e6c2e7790fd /sys-kernel
parenteclass.makequiet() (diff)
downloadhistorical-53caf42566103033472304d4e925489c3d82ac26.tar.gz
historical-53caf42566103033472304d4e925489c3d82ac26.tar.bz2
historical-53caf42566103033472304d4e925489c3d82ac26.zip
xfs
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog16
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre42
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre4.ebuild51
3 files changed, 68 insertions, 1 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index e74496b568c4..065866aaf098 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.10 2002/09/22 16:29:21 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.11 2002/09/24 06:41:49 lostlogic Exp $
+
+*lolo-sources-2.4.19.10_pre4 (24 Sep 2002)
+
+ 24 Sep 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.19.10_pre4.ebuild:
+
+ While testing this kerenl I ran into very bad crashing behavior with
+ the USE="acpi4linux" option enabled... just a warning. But for you
+ laptopers it is still there.
+
+ Well I dug up about 3-4 hours of time and merged xfs into this kernel
+ so everyone who has been asking for it finally gets their way because
+ I hate being unpopular. I hope you all enjoy XFS, it is enabled by a
+ hidden useflag so set USE="xfs" to turn it on for this kernel. Please
+ let me know your results.
*lolo-sources-2.4.19.10_pre3 (21 Sep 2002)
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre4 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre4
new file mode 100644
index 000000000000..db4f3e3c814e
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre4
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 e402b308ccd540894f06623727085cce patches-2.4.19-lolo-r10_pre4.tar.bz2 2676899
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre4.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre4.ebuild
new file mode 100644
index 000000000000..13e6beaabeca
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre4.ebuild,v 1.1 2002/09/24 06:41:49 lostlogic Exp $
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ # This is the XFS filesystem from SGI, use at your own risk ;)
+ [ `use xfs` ] || rm *xfs*
+
+ # This is the latest release of ACPI from
+ # http://www.sourceforge.net/projects/acpi
+ [ `use acpi4linux` ] || rm 70*
+
+ kernel_src_unpack
+}