summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-12-01 01:03:10 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-12-01 01:03:10 +0000
commit257e56c1590eae30dd6cd7863b05e0cf9729443d (patch)
treef2f49d7b122fc330db996ae9545ff7e0ef72b33f /sys-kernel
parentnew version (diff)
downloadhistorical-257e56c1590eae30dd6cd7863b05e0cf9729443d.tar.gz
historical-257e56c1590eae30dd6cd7863b05e0cf9729443d.tar.bz2
historical-257e56c1590eae30dd6cd7863b05e0cf9729443d.zip
version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog9
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.202
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.20.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 65070f66331c..e548fde52eb6 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.3 2002/10/09 09:46:14 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.4 2002/12/01 01:03:10 seemant Exp $
+
+*sparc-sources-2.4.20 (30 Nov 2002)
+
+ 30 Nov 2002; Seemant Kulleen <seemant@gentoo.org>
+ sparc-sources-2.4.20.ebuild files/digest-sparc-sources-2.4.20 :
+
+ Version bump. Same framebuffer logo patch.
*sparc-sources-2.4.20_pre10 (09 Oct 2002)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20
new file mode 100644
index 000000000000..85018c93a7eb
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 ab29056fe069db257373bcda217a4f84 patches-2.4.20-sparc.tar.bz2 45511
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.20.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.20.ebuild
new file mode 100644
index 000000000000..f8d6dc7a79f8
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.20.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.20.ebuild,v 1.1 2002/12/01 01:03:10 seemant Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the
+# same.
+KV=${PV}
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://cvs.gentoo.org/~seemant/patches-${PV}-sparc.tar.bz2"
+KEYWORDS="~x86 -ppc ~sparc ~sparc64"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ kernel_src_unpack
+}