summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-05-08 05:59:25 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-05-08 05:59:25 +0000
commit43a5db4cafc76903e7e8d0867be40f2d0c4fd7ba (patch)
treee864658c67ec080d1c5a896df07642c8439bc795 /sys-kernel/vanilla-sources
parentuse check_KV and depend on portage >=> 1.9.10 (diff)
downloadhistorical-43a5db4cafc76903e7e8d0867be40f2d0c4fd7ba.tar.gz
historical-43a5db4cafc76903e7e8d0867be40f2d0c4fd7ba.tar.bz2
historical-43a5db4cafc76903e7e8d0867be40f2d0c4fd7ba.zip
/usr/src/linux "don't touch that symlink" fixups
Diffstat (limited to 'sys-kernel/vanilla-sources')
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild20
1 files changed, 4 insertions, 16 deletions
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
index 86e9a15a16f3..2a45c7467602 100644
--- a/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
+++ b/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild,v 1.3 2002/04/29 21:01:13 sandymac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.4.18.ebuild,v 1.4 2002/05/08 05:59:25 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -91,21 +91,9 @@ pkg_preinst() {
pkg_postinst() {
[ "$ETYPE" = "headers" ] && return
- cd ${ROOT}usr/src/linux-${KV}
- make mrproper
- if [ -e "${ROOT}usr/src/linux/.config" ]
+ if [ ! -e ${ROOT}usr/src/linux ]
then
- cp "${ROOT}usr/src/linux/.config" .config
- #we only make dep when upgrading to a new kernel (with existing config)
- #The default setting will be selected.
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- else
- cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
fi
- #remove /usr/src/linux symlink
- rm -f ${ROOT}/usr/src/linux
- #set up a new one
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
}