summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Jackson <iggy@gentoo.org>2003-12-02 08:57:26 +0000
committerBrian Jackson <iggy@gentoo.org>2003-12-02 08:57:26 +0000
commitf54f7097b674871d40d9b6d034c37cccea909fa9 (patch)
tree0cbea9931094545d308ce4f19d9c72085bc8bc34 /sys-kernel/sparc-sources
parentversion bump for do_brk vuln (diff)
downloadhistorical-f54f7097b674871d40d9b6d034c37cccea909fa9.tar.gz
historical-f54f7097b674871d40d9b6d034c37cccea909fa9.tar.bz2
historical-f54f7097b674871d40d9b6d034c37cccea909fa9.zip
version bump for do_brk vuln
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/Manifest4
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.22-r12
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.22-r1.ebuild63
3 files changed, 67 insertions, 2 deletions
diff --git a/sys-kernel/sparc-sources/Manifest b/sys-kernel/sparc-sources/Manifest
index 2323c5c4b6ab..a662bc053751 100644
--- a/sys-kernel/sparc-sources/Manifest
+++ b/sys-kernel/sparc-sources/Manifest
@@ -1,9 +1,9 @@
-MD5 6ecee1fbe6ce263f49a690a87a69eef9 sparc-sources-2.4.22-r1.ebuild 2231
+MD5 80b3fccff7c048360ee7c859b28389f3 sparc-sources-2.4.22-r1.ebuild 2234
MD5 084b1528fa23bc2836219c1b5d0644a6 sparc-sources-2.4.21-r1.ebuild 2229
MD5 34a347e2b0eaa4ac76faa335675407f9 sparc-sources-2.4.23.ebuild 2150
MD5 29de7eebe8a32ba875514a32f6f95d07 sparc-sources-2.4.20-r8.ebuild 2395
MD5 754c42fba6640866b8dbbac53d24fe8d sparc-sources-2.4.22.ebuild 2226
-MD5 62b22986f0752351d55739fdc35d0560 ChangeLog 6336
+MD5 c87d402997488a0c3705915dd7c267b3 ChangeLog 6487
MD5 6706a601c155869440dcb544e3759a04 metadata.xml 381
MD5 afd982621a7d4faba455607353e659c9 files/digest-sparc-sources-2.4.22 140
MD5 8c8598fb61743bb94c3a9eaf3ff339f4 files/digest-sparc-sources-2.4.23 140
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.22-r1 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.22-r1
new file mode 100644
index 000000000000..9d9f1d27d3f0
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.22-r1
@@ -0,0 +1,2 @@
+MD5 75dc85149b06ac9432106b8941eb9f7b linux-2.4.22.tar.bz2 29528612
+MD5 d339475347d5ee6509950d19e59cd399 patches-2.4.22-sparc.tar.bz2 136290
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.22-r1.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.22-r1.ebuild
new file mode 100644
index 000000000000..b7255aaca4d8
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.22-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.22-r1.ebuild,v 1.1 2003/12/02 08:57:24 iggy Exp $
+
+IUSE="build ultra1"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV/-r*/}.tar.bz2"
+
+KEYWORDS="~x86 -ppc sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${WORKDIR}/${KV}
+
+ epatch ${FILESDIR}/do_brk_fix.patch || die "failed to patch for do_brk vuln"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}