summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2004-09-14 16:26:28 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2004-09-14 16:26:28 +0000
commit66b2ac7abcbc9b02e03f82fad023efb141b52370 (patch)
tree0ad95b645239a2f6156047468a481c31db6160a4 /sys-kernel/openmosix-sources/openmosix-sources-2.4.27-r2.ebuild
parentStable on x86. (diff)
downloadhistorical-66b2ac7abcbc9b02e03f82fad023efb141b52370.tar.gz
historical-66b2ac7abcbc9b02e03f82fad023efb141b52370.tar.bz2
historical-66b2ac7abcbc9b02e03f82fad023efb141b52370.zip
fix for non-dfsa users
Diffstat (limited to 'sys-kernel/openmosix-sources/openmosix-sources-2.4.27-r2.ebuild')
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.27-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.27-r2.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.27-r2.ebuild
new file mode 100644
index 000000000000..d484bcd54c0c
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.27-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.27-r2.ebuild,v 1.1 2004/09/14 16:26:28 voxus Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+inherit kernel eutils
+
+OKV="2.4.27"
+TIMESTAMP="20040914"
+[ "${PR}" == "r0" ] && KV=${PV/_/-}-openmosix || KV=${PV/_/-}-openmosix-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# ${OKV}, plus:
+# ${OKV} openmosix-migshm-${OKV}-${TIMESTAMP} by voxus
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel, including shared memory migration patch (migshm)"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://dev.gentoo.org/~voxus/om/patch-${OKV}-om-migshm-${TIMESTAMP}.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/
+ http://www.openmosix.org/
+ http://dev.gentoo.org/~voxus/om/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="-*"
+IUSE=""
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd linux-${KV}
+ epatch ${DISTDIR}/patch-${OKV}-om-migshm-${TIMESTAMP}.bz2 || die "openMosix patch failed."
+ kernel_universal_unpack
+}