summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-08-30 10:14:27 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-08-30 10:14:27 +0000
commita1fde61b5aacea92282aba3cec0ffbd17abfb9b9 (patch)
tree81c0113dc3c7683a6553e7febf07e2149a988dbe /sys-kernel/mips-sources
parentAdded a patch to fix a bug in the SGI WD scsi driver. Allows the kernel to b... (diff)
downloadhistorical-a1fde61b5aacea92282aba3cec0ffbd17abfb9b9.tar.gz
historical-a1fde61b5aacea92282aba3cec0ffbd17abfb9b9.tar.bz2
historical-a1fde61b5aacea92282aba3cec0ffbd17abfb9b9.zip
Added a patch to fix a bug in the SGI WD scsi driver. Allows the kernel to boot.
Diffstat (limited to 'sys-kernel/mips-sources')
-rw-r--r--sys-kernel/mips-sources/Manifest4
-rw-r--r--sys-kernel/mips-sources/files/mipscvs-2.4.22-20030825-sgiwd-fix.patch41
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.4.22-r1.ebuild5
3 files changed, 47 insertions, 3 deletions
diff --git a/sys-kernel/mips-sources/Manifest b/sys-kernel/mips-sources/Manifest
index 859cc62a8e22..f6f525c32485 100644
--- a/sys-kernel/mips-sources/Manifest
+++ b/sys-kernel/mips-sources/Manifest
@@ -1,7 +1,7 @@
-MD5 d4773eda08479254bf46891fc30eec0e ChangeLog 2113
+MD5 3c3e04e2ed9ec761a5a64935528f1503 ChangeLog 2113
MD5 08a588f2eb09f3b98093effe2ceef909 mips-sources-2.4.21-r1.ebuild 1306
MD5 e3dfe7ffe70f8b678152c59ab96a6311 mips-sources-2.4.21-r2.ebuild 1131
-MD5 b5633ab312a5ded7ac13a6fc2e4545ed mips-sources-2.4.22-r1.ebuild 1271
+MD5 8a2f76d0ae8ff8922c8b7f66cd645fd6 mips-sources-2.4.22-r1.ebuild 1271
MD5 e40e67b089d55da6d5aeb91ae63a81cb files/mipscvs-2.4.22-20030825-sgiwd-fix.patch 1256
MD5 747353be86040c7e4c49b553f3467b7c files/digest-mips-sources-2.4.21-r1 160
MD5 054c3c8e9c8804a13c79d01ec52793ed files/mips-patches-gcc-makefile-fix.patch 915
diff --git a/sys-kernel/mips-sources/files/mipscvs-2.4.22-20030825-sgiwd-fix.patch b/sys-kernel/mips-sources/files/mipscvs-2.4.22-20030825-sgiwd-fix.patch
new file mode 100644
index 000000000000..37b13c8f9d8b
--- /dev/null
+++ b/sys-kernel/mips-sources/files/mipscvs-2.4.22-20030825-sgiwd-fix.patch
@@ -0,0 +1,41 @@
+Index: drivers/scsi/sgiwd93.c
+===================================================================
+RCS file: /home/cvs/linux/drivers/scsi/sgiwd93.c,v
+retrieving revision 1.28.2.8
+diff -u -r1.28.2.8 sgiwd93.c
+--- drivers/scsi/sgiwd93.c 14 Aug 2003 15:32:13 -0000 1.28.2.8
++++ drivers/scsi/sgiwd93.c 20 Aug 2003 16:08:59 -0000
+@@ -92,7 +92,7 @@
+ unsigned long physaddr;
+ unsigned long count;
+
+- physaddr = virt_to_bus(addr);
++ physaddr = PHYSADDR(addr);
+ while (len) {
+ /*
+ * even cntinfo could be up to 16383, without
+@@ -141,7 +141,7 @@
+ DPRINTK(" HPCGO\n");
+
+ /* Start up the HPC. */
+- hregs->ndptr = virt_to_bus(hdata->dma_bounce_buffer);
++ hregs->ndptr = PHYSADDR(hdata->dma_bounce_buffer);
+ if (datainp) {
+ dma_cache_inv((unsigned long) cmd->SCp.ptr,
+ cmd->SCp.this_residual);
+@@ -197,13 +197,13 @@
+ start = (unsigned long) buf;
+ end = start + PAGE_SIZE;
+ while (start < end) {
+- hcp->desc.pnext = virt_to_bus(hcp + 1);
++ hcp->desc.pnext = PHYSADDR(hcp + 1);
+ hcp->desc.cntinfo = HPCDMA_EOX;
+ hcp++;
+ start += sizeof(struct hpc_chunk);
+ };
+ hcp--;
+- hcp->desc.pnext = virt_to_bus(buf);
++ hcp->desc.pnext = PHYSADDR(buf);
+
+ /* Force flush to memory */
+ dma_cache_wback_inv((unsigned long) buf, PAGE_SIZE);
diff --git a/sys-kernel/mips-sources/mips-sources-2.4.22-r1.ebuild b/sys-kernel/mips-sources/mips-sources-2.4.22-r1.ebuild
index cc811297c07e..ccefb7754496 100644
--- a/sys-kernel/mips-sources/mips-sources-2.4.22-r1.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-2.4.22-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.4.22-r1.ebuild,v 1.1 2003/08/26 07:24:58 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.4.22-r1.ebuild,v 1.2 2003/08/30 10:14:23 kumba Exp $
ETYPE="sources"
@@ -32,6 +32,9 @@ src_unpack() {
# Update the vanilla sources with linux-mips CVS changes
cat ${WORKDIR}/mipscvs-${OKV}-${CVSDATE}.diff | patch -p1
+ # Patch the SGI WD scsi driver so the kernel can boot
+ cat ${FILESDIR}/mipscvs-${OKV}-${CVSDATE}-sgiwd-fix.patch | patch -p0
+
# Patch arch/mips/Makefile for gcc
cat ${FILESDIR}/mipscvs-${OKV}-${CVSDATE}-makefile-fix.patch | patch -p0