summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-08-04 05:56:00 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-08-04 05:56:00 +0000
commit29c376ffbbe46d00565807154ef0ee28e1681462 (patch)
tree185d0db490cc0762f161d38af41e84d16e9a2bad /sys-kernel/mips-sources
parentNew snapshot of linux-mips CVS from 20030803 (diff)
downloadhistorical-29c376ffbbe46d00565807154ef0ee28e1681462.tar.gz
historical-29c376ffbbe46d00565807154ef0ee28e1681462.tar.bz2
historical-29c376ffbbe46d00565807154ef0ee28e1681462.zip
New snapshot of linux-mips CVS from 20030803
Diffstat (limited to 'sys-kernel/mips-sources')
-rw-r--r--sys-kernel/mips-sources/Manifest4
-rw-r--r--sys-kernel/mips-sources/files/digest-mips-sources-2.4.21-r22
-rw-r--r--sys-kernel/mips-sources/files/mips-patches-gcc-makefile-fix.patch28
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.4.21-r2.ebuild39
4 files changed, 71 insertions, 2 deletions
diff --git a/sys-kernel/mips-sources/Manifest b/sys-kernel/mips-sources/Manifest
index 22956a83f63a..3247fb09b56a 100644
--- a/sys-kernel/mips-sources/Manifest
+++ b/sys-kernel/mips-sources/Manifest
@@ -1,7 +1,7 @@
-MD5 90040b8c4cf1c206b81fe3015aca7e67 ChangeLog 1344
+MD5 d0a2b3c4eaca087c03d065d133abc80d ChangeLog 1344
MD5 8ee4042c4c033ceb173a4c8335201a2d mips-sources-2.4.19.ebuild 3012
MD5 fc37b4c5cb627a67e424ee3f1c0bbea3 mips-sources-2.4.21-r1.ebuild 1242
-MD5 f959d6ea4b167d79077b4ae94d0d3224 mips-sources-2.4.21-r2.ebuild 1131
+MD5 e3dfe7ffe70f8b678152c59ab96a6311 mips-sources-2.4.21-r2.ebuild 1131
MD5 3ebb3cdf7486564838a96e1b6bb79b6b files/digest-mips-sources-2.4.19 144
MD5 747353be86040c7e4c49b553f3467b7c files/digest-mips-sources-2.4.21-r1 160
MD5 054c3c8e9c8804a13c79d01ec52793ed files/mips-patches-gcc-makefile-fix.patch 915
diff --git a/sys-kernel/mips-sources/files/digest-mips-sources-2.4.21-r2 b/sys-kernel/mips-sources/files/digest-mips-sources-2.4.21-r2
new file mode 100644
index 000000000000..9e16838f5d98
--- /dev/null
+++ b/sys-kernel/mips-sources/files/digest-mips-sources-2.4.21-r2
@@ -0,0 +1,2 @@
+MD5 f51e12efa18bb828cf57d9d4a81b2fb1 linux-2.4.21.tar.bz2 28533733
+MD5 aea17fa0a6fc0bef9847b8713d4c3923 mipscvs-2.4.21-20030803.diff.bz2 1011871
diff --git a/sys-kernel/mips-sources/files/mips-patches-gcc-makefile-fix.patch b/sys-kernel/mips-sources/files/mips-patches-gcc-makefile-fix.patch
new file mode 100644
index 000000000000..18bd1e135426
--- /dev/null
+++ b/sys-kernel/mips-sources/files/mips-patches-gcc-makefile-fix.patch
@@ -0,0 +1,28 @@
+--- arch/mips/Makefile.orig 2003-08-03 18:24:17.000000000 -0400
++++ arch/mips/Makefile 2003-08-03 18:25:59.000000000 -0400
+@@ -69,7 +69,7 @@ ifdef CONFIG_CPU_VR41XX
+ GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_R4X00
+-GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
++GCCFLAGS += -mips3 -mabi=32 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_TX49XX
+ GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
+@@ -81,14 +81,14 @@ ifdef CONFIG_CPU_MIPS64
+ GCCFLAGS += -mcpu=r4600 -mips2 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_R5000
+-GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
++GCCFLAGS += -mips4 -mabi=32 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_R5432
+ GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_NEVADA
+ # Cannot use -mmad with currently recommended tools
+-GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
++GCCFLAGS += -mips4 -mabi=32 -Wa,--trap
+ endif
+ ifdef CONFIG_CPU_RM7000
+ GCCFLAGS += -mcpu=r5000 -mips2 -Wa,--trap
diff --git a/sys-kernel/mips-sources/mips-sources-2.4.21-r2.ebuild b/sys-kernel/mips-sources/mips-sources-2.4.21-r2.ebuild
new file mode 100644
index 000000000000..1b156fcb94d2
--- /dev/null
+++ b/sys-kernel/mips-sources/mips-sources-2.4.21-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.4.21-r2.ebuild,v 1.1 2003/08/04 05:51:52 kumba Exp $
+
+
+ETYPE="sources"
+inherit kernel
+OKV=${PV/_/-}
+CVSDATE=20030803
+S=${WORKDIR}/linux-${OKV}
+PROVIDE="virtual/linux-sources"
+EXTRAVERSION=-mipscvs-${CVSDATE}
+
+# What's in this kernel?
+
+# INCLUDED:
+# 1) linux sources from kernel.org
+# 2) linux-mips.org CVS snapshot diff from 03 Aug 2003
+# 3) patch to fix arch/mips/Makefile to pass appropriate CFLAGS
+
+DESCRIPTION="Linux-Mips CVS sources for MIPS-based machines"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/mipscvs-${OKV}-${CVSDATE}.diff.bz2"
+HOMEPAGE="http://www.linux-mips.org/"
+KEYWORDS="-* ~mips"
+SLOT="${OKV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Update the vanilla sources with linux-mips CVS changes
+ cat ${WORKDIR}/mipscvs-${OKV}-${CVSDATE}.diff | patch -p1
+
+ # Patch arch/mips/Makefile for gcc
+ cat ${FILESDIR}/mips-patches-gcc-makefile-fix.patch | patch -p0
+
+ kernel_universal_unpack
+}