summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2005-12-09 17:48:16 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2005-12-09 17:48:16 +0000
commit095fda6af633a3756dd0325be2d79b0edd4408fa (patch)
tree889f4964980f62b2b4d932d4605308d5afb7e9e6 /sys-fs
parentMarked stable on amd64 (diff)
downloadhistorical-095fda6af633a3756dd0325be2d79b0edd4408fa.tar.gz
historical-095fda6af633a3756dd0325be2d79b0edd4408fa.tar.bz2
historical-095fda6af633a3756dd0325be2d79b0edd4408fa.zip
077-r3 fix baselayout dependancy and restart udevd when installed
Package-Manager: portage-2.0.53
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/udev/ChangeLog9
-rw-r--r--sys-fs/udev/Manifest4
-rw-r--r--sys-fs/udev/files/digest-udev-077-r31
-rw-r--r--sys-fs/udev/udev-077-r3.ebuild208
4 files changed, 220 insertions, 2 deletions
diff --git a/sys-fs/udev/ChangeLog b/sys-fs/udev/ChangeLog
index d0038644fe66..1adf24bc5d0e 100644
--- a/sys-fs/udev/ChangeLog
+++ b/sys-fs/udev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/udev
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.159 2005/12/08 18:38:02 gregkh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/ChangeLog,v 1.160 2005/12/09 17:48:16 gregkh Exp $
+
+*udev-077-r3 (09 Dec 2005)
+
+ 09 Dec 2005; Greg Kroah-Hartman <gregkh@gentoo.org> +udev-077-r3.ebuild:
+ 077-r3 release - fix dependancy on newer version of baselayout (for those who
+ are running stable for other packages, and don't seem to want to upgrade) as
+ we need it to start udev properly at boot time.
*udev-077-r2 (08 Dec 2005)
diff --git a/sys-fs/udev/Manifest b/sys-fs/udev/Manifest
index 2693e4dcf8c5..fddd00d3999f 100644
--- a/sys-fs/udev/Manifest
+++ b/sys-fs/udev/Manifest
@@ -1,4 +1,4 @@
-MD5 e9bb4adbd24774a78b34de588e2c94bd ChangeLog 29229
+MD5 73eff3a5ffc9b99443f1f15f6a527bf5 ChangeLog 29542
MD5 d03e92ce93131fd7d29fcae1b3f2627b files/digest-udev-068-r1 61
MD5 05abfc4c9a5cad86f814161806c97148 files/digest-udev-069 61
MD5 760a25fb7cc243e76c1889076b6ec829 files/digest-udev-070-r1 61
@@ -8,6 +8,7 @@ MD5 76a7034314dedfa3554108a616210e88 files/digest-udev-073 61
MD5 918aa5f6b5b4a478bcda926d0a41f28a files/digest-udev-077 61
MD5 918aa5f6b5b4a478bcda926d0a41f28a files/digest-udev-077-r1 61
MD5 918aa5f6b5b4a478bcda926d0a41f28a files/digest-udev-077-r2 61
+MD5 918aa5f6b5b4a478bcda926d0a41f28a files/digest-udev-077-r3 61
MD5 f00e3e0d3382e93cbd0c64fcef99f826 files/udev-021-udev_add_c-gcc295-compat.patch 493
MD5 7b0a35c905183730e4dfdcf29f5a1816 files/udev-050-udev_volume_id.patch 388
MD5 3bcc6c8d9c7a3cf7ff0d3b5a36bde3d6 files/udev-parisc-path_id.patch 706
@@ -37,4 +38,5 @@ MD5 1c2f39137e776ead6a5c022aa80f076b udev-072.ebuild 6983
MD5 2323e2f8802a6e2d5dd3c73d9669b83d udev-073.ebuild 6983
MD5 f69e426e47bd01dd952db7f7c952af2b udev-077-r1.ebuild 6889
MD5 a4a449edc3da2388173ea56cad7ee698 udev-077-r2.ebuild 6892
+MD5 605179fb690630bb11422080817cb68a udev-077-r3.ebuild 6907
MD5 4cf7b677380f3571eec3dc7326e984b2 udev-077.ebuild 6845
diff --git a/sys-fs/udev/files/digest-udev-077-r3 b/sys-fs/udev/files/digest-udev-077-r3
new file mode 100644
index 000000000000..d4ff64912f29
--- /dev/null
+++ b/sys-fs/udev/files/digest-udev-077-r3
@@ -0,0 +1 @@
+MD5 61ec646daf7795e9777e8f33975408fe udev-077.tar.bz2 222315
diff --git a/sys-fs/udev/udev-077-r3.ebuild b/sys-fs/udev/udev-077-r3.ebuild
new file mode 100644
index 000000000000..f30d0858807f
--- /dev/null
+++ b/sys-fs/udev/udev-077-r3.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/udev/udev-077-r3.ebuild,v 1.1 2005/12/09 17:48:16 gregkh Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Linux dynamic and persistent device naming support (aka userspace devfs)"
+HOMEPAGE="http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html"
+SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="sys-apps/hotplug-base"
+RDEPEND="${DEPEND}
+ >=sys-apps/baselayout-1.11.14"
+# We need the lib/rcscripts/addon support
+PROVIDE="virtual/dev-manager"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # patches go here...
+ #epatch ${FILESDIR}/${P}-udev_volume_id.patch
+ epatch ${FILESDIR}/udev-parisc-path_id.patch
+
+ # No need to clutter the logs ...
+ sed -ie '/^DEBUG/ c\DEBUG = false' Makefile
+ # Do not use optimization flags from the package
+ sed -ie 's|$(OPTIMIZATION)||g' Makefile
+
+ # Make sure there is no sudden changes to udev.rules.gentoo
+ # (more for my own needs than anything else ...)
+ MD5=`md5sum < "${S}/etc/udev/gentoo/udev.rules"`
+ MD5=${MD5/ -/}
+ if [ "${MD5}" != "84fa41fd643ad2afeb922b3048cfd05f" ]
+ then
+ echo
+ eerror "gentoo/udev.rules has been updated, please validate!"
+ die "gentoo/udev.rules has been updated, please validate!"
+ fi
+}
+
+src_compile() {
+ filter-flags -fprefetch-loop-arrays
+ local myconf=
+ local extras="extras/scsi_id extras/volume_id extras/ata_id extras/run_directory extras/usb_id extras/floppy extras/cdrom_id extras/firmware"
+
+ use selinux && myconf="${myconf} USE_SELINUX=true"
+
+ # Not everyone has full $CHOST-{ld,ar,etc...} yet
+ local mycross=""
+ type -p ${CHOST}-ar && mycross=${CHOST}-
+
+ # Do not work with emake
+ make \
+ EXTRAS="${extras}" \
+ udevdir="/dev/" \
+ CROSS=${mycross} \
+ ${myconf} || die
+}
+
+src_install() {
+ # we install everything by "hand" and don't rely on the udev Makefile to do
+ # it for us (why? it's easier that way...)
+ dobin udevinfo
+ dobin udevtest
+ dobin udevmonitor
+ into /
+ dosbin udev
+ dosbin udevd
+ dosbin udevsend
+ dosbin udevstart
+ dosbin udevcontrol
+ dosbin extras/run_directory/udev_run_devd
+ dosbin extras/run_directory/udev_run_hotplugd
+ dosbin extras/ata_id/ata_id
+ dosbin extras/volume_id/vol_id
+ dosbin extras/scsi_id/scsi_id
+ dosbin extras/usb_id/usb_id
+ dosbin extras/cdrom_id/cdrom_id
+ dosbin extras/path_id
+ dosbin extras/floppy/create_floppy_devices
+ dosbin extras/firmware/firmware_helper
+
+ #exeinto /etc/udev/scripts
+ exeinto /lib/udev
+ #doexe extras/ide-devfs.sh
+ #doexe extras/scsi-devfs.sh
+ doexe extras/raid-devfs.sh
+
+ # Our udev config file
+ insinto /etc/udev
+ newins ${FILESDIR}/udev.conf.post_059 udev.conf
+
+ # Our rules files
+ insinto /etc/udev/rules.d/
+ #newins etc/udev/gentoo/udev.rules 50-udev.rules
+ newins ${FILESDIR}/udev.rules-077-r1 50-udev.rules
+
+ # scsi_id configuration
+ insinto /etc
+ doins extras/scsi_id/scsi_id.config
+
+ # set up symlinks in /etc/hotplug.d/default
+ dodir /etc/hotplug.d/default
+ dosym ../../../sbin/udevsend /etc/hotplug.d/default/10-udev.hotplug
+
+ # set up the /etc/dev.d directory tree
+ dodir /etc/dev.d/default
+ dodir /etc/dev.d/net
+ exeinto /etc/dev.d/net
+ doexe extras/run_directory/dev.d/net/hotplug.dev
+
+ # all of the man pages
+ doman *.8
+ doman extras/ata_id/ata_id.8
+ doman extras/edd_id/edd_id.8
+ doman extras/scsi_id/scsi_id.8
+ doman extras/volume_id/vol_id.8
+ doman extras/dasd_id/dasd_id.8
+ doman extras/cdrom_id/cdrom_id.8
+
+ # our udev hooks into the rc system
+ insinto /lib/rcscripts/addons
+ newins "${FILESDIR}"/udev-start-077-r2.sh udev-start.sh
+ doins "${FILESDIR}"/udev-stop.sh
+
+ dodoc ChangeLog FAQ README TODO RELEASE-NOTES
+ dodoc docs/{overview,udev_vs_devfs}
+ dodoc docs/writing_udev_rules/*
+
+ newdoc extras/volume_id/README README_volume_id
+}
+
+pkg_preinst() {
+ if [ -f "${ROOT}/etc/udev/udev.config" -a \
+ ! -f "${ROOT}/etc/udev/udev.rules" ]
+ then
+ mv -f ${ROOT}/etc/udev/udev.config ${ROOT}/etc/udev/udev.rules
+ fi
+
+ # delete the old udev.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/udev.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/udev.hotplug
+ fi
+
+ # delete the old wait_for_sysfs.hotplug symlink if it is present
+ if [ -h "${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug" ]
+ then
+ rm -f ${ROOT}/etc/hotplug.d/default/05-wait_for_sysfs.hotplug
+ fi
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" -a -n "`pidof udevd`" ]
+ then
+ killall -15 udevd &>/dev/null
+ sleep 1
+ killall -9 udevd &>/dev/null
+ fi
+ /sbin/udevd --daemon
+
+ # people want reminders, I'll give them reminders. Odds are they will
+ # just ignore them anyway...
+ ewarn "Note: If you are upgrading from a version of udev prior to 046"
+ ewarn " and you rely on the output of udevinfo for anything, please"
+ ewarn " either run 'udevstart' now, or reboot, in order to get a"
+ ewarn " up-to-date udev database."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 050"
+ ewarn " and you had written some custom permissions rules, please"
+ ewarn " realize that the permission rules are now part of the main"
+ ewarn " udev rules files and are not stand-alone anymore. This means"
+ ewarn " you need to rewrite them."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 057"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, please read the RELEASE-NOTES file for details"
+ ewarn " on what has changed with this feature, and how to change your"
+ ewarn " rules to work properly."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 059"
+ ewarn " and you have written custom rules, and rely on the etc/dev.d/"
+ ewarn " functionality, or the etc/hotplug.d functionality, or just"
+ ewarn " want to write some very cool and power udev rules, please "
+ ewarn " read the RELEASE-NOTES file for details on what has changed"
+ ewarn " with this feature, and how to change your rules to work properly."
+ ewarn
+ ewarn "Note: If you are upgrading from a version of udev prior to 063"
+ ewarn " and you use the devfs-style names for your block devices"
+ ewarn " or use devfs-style names in /etc/inittab or /etc/securetty or"
+ ewarn " your GRUB or LILO kernel boot command line, you need to"
+ ewarn " change them back to LSB compliant names, as the devfs names are"
+ ewarn " now gone. If you wish to use some persistent names for your"
+ ewarn " block devices, look at the symlinks in /dev/disk/ for the names"
+ ewarn " you can use."
+
+ einfo
+ einfo "For more information on udev on Gentoo, writing udev rules, and"
+ einfo " fixing known issues visit:"
+ einfo " http://www.gentoo.org/doc/en/udev-guide.xml"
+}