summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-23 04:27:53 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-23 04:27:53 +0000
commita1342c84c5b5fc79e00dc2358bcf263ee042b595 (patch)
treeae759e5fe8eb3cd00f67a8531ae369e6dd80fb4a /sys-fs/xfsdump/xfsdump-2.2.48.ebuild
parentold (diff)
downloadhistorical-a1342c84c5b5fc79e00dc2358bcf263ee042b595.tar.gz
historical-a1342c84c5b5fc79e00dc2358bcf263ee042b595.tar.bz2
historical-a1342c84c5b5fc79e00dc2358bcf263ee042b595.zip
Version bump #211113 by Raúl Porcel.
Package-Manager: portage-2.2_pre2
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-2.2.48.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-2.2.48.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/xfsdump-2.2.48.ebuild b/sys-fs/xfsdump/xfsdump-2.2.48.ebuild
new file mode 100644
index 000000000000..132a0a369aab
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-2.2.48.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-2.2.48.ebuild,v 1.1 2008/02/23 04:27:53 vapier Exp $
+
+inherit eutils autotools
+
+MY_P="${PN}_${PV}-1"
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/download/cmd_tars/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ sys-fs/xfsprogs
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ -e '/^GCFLAGS/s:-O1::' \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-2.2.42-Makefile-deps.patch
+ eautoconf
+}
+
+src_compile() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DIST_ROOT="${D}" install || die
+ prepalldocs
+}