summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-12-24 11:59:35 +0000
committerMike Frysinger <vapier@gentoo.org>2007-12-24 11:59:35 +0000
commit7de97de6778e7e8362f89af1448822b94aa71bc5 (patch)
tree95a8eef154ab0743f1206c6c4b915f996c15dca9 /sys-fs/quota
parentUpdated l7-filter patches for iptables-1.4.x. (diff)
downloadhistorical-7de97de6778e7e8362f89af1448822b94aa71bc5.tar.gz
historical-7de97de6778e7e8362f89af1448822b94aa71bc5.tar.bz2
historical-7de97de6778e7e8362f89af1448822b94aa71bc5.zip
old
Diffstat (limited to 'sys-fs/quota')
-rw-r--r--sys-fs/quota/files/digest-quota-3.123
-rw-r--r--sys-fs/quota/files/digest-quota-3.133
-rw-r--r--sys-fs/quota/quota-3.12.ebuild61
-rw-r--r--sys-fs/quota/quota-3.13.ebuild76
4 files changed, 0 insertions, 143 deletions
diff --git a/sys-fs/quota/files/digest-quota-3.12 b/sys-fs/quota/files/digest-quota-3.12
deleted file mode 100644
index 1249f11a3933..000000000000
--- a/sys-fs/quota/files/digest-quota-3.12
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 d69870f4a9732ed2fe072952ee7f1462 quota-3.12.tar.gz 211909
-RMD160 25c864c849f177dc3009ef2e3b447e2a00e217ce quota-3.12.tar.gz 211909
-SHA256 7b391f6a34e9faa5d4cf841e4014d57b5df0a992cd83a6475cd36d8987db7cdb quota-3.12.tar.gz 211909
diff --git a/sys-fs/quota/files/digest-quota-3.13 b/sys-fs/quota/files/digest-quota-3.13
deleted file mode 100644
index adc28e88f42b..000000000000
--- a/sys-fs/quota/files/digest-quota-3.13
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 8a91c4bc342dca2ddf9f620af24fc5e7 quota-3.13.tar.gz 237287
-RMD160 e2aee822959224c76897d04cdf02a86ca3334aa4 quota-3.13.tar.gz 237287
-SHA256 b014cd00a0d3d5b75be1852aa75554c925e38229cebed4e01497f779c551dd4b quota-3.13.tar.gz 237287
diff --git a/sys-fs/quota/quota-3.12.ebuild b/sys-fs/quota/quota-3.12.ebuild
deleted file mode 100644
index 441a6cb6697b..000000000000
--- a/sys-fs/quota/quota-3.12.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12.ebuild,v 1.9 2005/08/17 00:27:50 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Linux quota tools"
-HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
-SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86"
-IUSE="nls tcpd"
-
-RDEPEND="virtual/libc
- tcpd? ( sys-apps/tcp-wrappers )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/quota-tools
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # patch to prevent quotactl.2 manpage from being installed
- # that page is provided by man-pages instead
- epatch ${FILESDIR}/${PN}-no-quotactl-manpage.patch
-
- sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
-}
-
-src_compile() {
- econf $(use_enable nls) || die
- emake || die
-}
-
-src_install() {
- dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
- make ROOTDIR="${D}" install || die
- rm -r "${D}"/usr/include #70938
-
- insinto /etc
- insopts -m0644
- doins warnquota.conf quotatab
-
- dodoc doc/*
-
- newinitd ${FILESDIR}/quota.rc6 quota
- newconfd ${FILESDIR}/quota.confd quota
-}
-
-pkg_postinst() {
- einfo "with this release, you can configure the used"
- einfo "ports through /etc/services"
- einfo
- einfo "eg. use the default"
- einfo "rquotad 4003/tcp # quota"
- einfo "rquotad 4003/udp # quota"
-}
diff --git a/sys-fs/quota/quota-3.13.ebuild b/sys-fs/quota/quota-3.13.ebuild
deleted file mode 100644
index 561431d32dff..000000000000
--- a/sys-fs/quota/quota-3.13.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.13.ebuild,v 1.10 2007/06/21 18:45:49 armin76 Exp $
-
-inherit eutils
-
-DESCRIPTION="Linux quota tools"
-HOMEPAGE="http://sourceforge.net/projects/linuxquota/"
-SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ~mips ppc sparc x86"
-IUSE="nls tcpd ldap rpc"
-
-RDEPEND="ldap? ( net-nds/openldap )
- tcpd? ( sys-apps/tcp-wrappers )
- rpc? ( net-nds/portmap )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-S=${WORKDIR}/quota-tools
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-configure-LANG.patch #131432
- epatch "${FILESDIR}"/${PN}-3.14-headers.patch
-
- # patch to prevent quotactl.2 manpage from being installed
- # that page is provided by man-pages instead
- epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
-
- # Don't strip binaries (from Fedora)
- epatch "${FILESDIR}"/quota-3.06-no-stripping.patch
-
- sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
-}
-
-src_compile() {
- econf \
- $(use_enable nls) \
- $(use_enable ldap ldapmail) \
- $(use_enable rpc) \
- $(use_enable rpc rpcsetquota) \
- || die
- emake || die
-}
-
-src_install() {
- dodir /{sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
- make ROOTDIR="${D}" install || die
- rm -r "${D}"/usr/include #70938
-
- insinto /etc
- insopts -m0644
- doins warnquota.conf quotatab
-
- dodoc doc/*
- dodoc README.*
- dodoc Changelog
-
- newinitd "${FILESDIR}"/quota.rc6 quota
- newconfd "${FILESDIR}"/quota.confd quota
-
- if use ldap ; then
- insinto /etc/openldap/schema
- insopts -m0644
- doins ldap-scripts/quota.schema
-
- exeinto /usr/share/quota/ldap-scripts
- doexe ldap-scripts/*.pl
- doexe ldap-scripts/edquota_editor
- fi
-}