summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-09-22 00:16:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-09-22 00:16:14 +0000
commitd8cc94901353fa929e15fd9ad203160b91e5ef0a (patch)
tree4d94596bc17b23e02bcfe58d75035224fb95bbc7 /sys-fs/lvm2
parentRemove 'ft' and 'javascript' from 'media-video/gpac' (diff)
downloadhistorical-d8cc94901353fa929e15fd9ad203160b91e5ef0a.tar.gz
historical-d8cc94901353fa929e15fd9ad203160b91e5ef0a.tar.bz2
historical-d8cc94901353fa929e15fd9ad203160b91e5ef0a.zip
Version bump - needed for upstream fixes to locking, clustering and LVM mirroring.
Package-Manager: portage-2.1.2_pre1
Diffstat (limited to 'sys-fs/lvm2')
-rw-r--r--sys-fs/lvm2/ChangeLog8
-rw-r--r--sys-fs/lvm2/files/digest-lvm2-2.02.103
-rw-r--r--sys-fs/lvm2/lvm2-2.02.10.ebuild108
3 files changed, 118 insertions, 1 deletions
diff --git a/sys-fs/lvm2/ChangeLog b/sys-fs/lvm2/ChangeLog
index 7927aa3adc1f..2765bff9da4c 100644
--- a/sys-fs/lvm2/ChangeLog
+++ b/sys-fs/lvm2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/lvm2
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.85 2006/09/07 16:50:36 rocket Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/ChangeLog,v 1.86 2006/09/22 00:16:14 robbat2 Exp $
+
+*lvm2-2.02.10 (22 Sep 2006)
+
+ 22 Sep 2006; Robin H. Johnson <robbat2@gentoo.org> +lvm2-2.02.10.ebuild:
+ Version bump - needed for upstream fixes to locking, clustering and LVM
+ mirroring.
07 Sep 2006; Eric Edgar <rocket@gentoo.org> lvm2-2.02.06.ebuild:
Update the lvm2-2.02.06 ebuild to require device-mapper 1.02.07 or higher
diff --git a/sys-fs/lvm2/files/digest-lvm2-2.02.10 b/sys-fs/lvm2/files/digest-lvm2-2.02.10
new file mode 100644
index 000000000000..523ddc7915d5
--- /dev/null
+++ b/sys-fs/lvm2/files/digest-lvm2-2.02.10
@@ -0,0 +1,3 @@
+MD5 a03249bd9f16510dbef241b0f15f9b83 LVM2.2.02.10.tgz 490592
+RMD160 0f0e873ab9651ee0216336bcde79ac16d86d0595 LVM2.2.02.10.tgz 490592
+SHA256 4108de3f4f9f55f29cb6f3e469c44cfa35c6dfcf3a66cae4499e98594ec046c9 LVM2.2.02.10.tgz 490592
diff --git a/sys-fs/lvm2/lvm2-2.02.10.ebuild b/sys-fs/lvm2/lvm2-2.02.10.ebuild
new file mode 100644
index 000000000000..a1adece36a12
--- /dev/null
+++ b/sys-fs/lvm2/lvm2-2.02.10.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/lvm2/lvm2-2.02.10.ebuild,v 1.1 2006/09/22 00:16:14 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="User-land utilities for LVM2 (device-mapper) software."
+HOMEPAGE="http://sources.redhat.com/lvm2/"
+SRC_URI="ftp://sources.redhat.com/pub/lvm2/${PN/lvm/LVM}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="readline nolvmstatic clvm cman gulm nolvm1 nosnapshots nomirrors selinux"
+
+DEPEND=">=sys-fs/device-mapper-1.02.10
+ clvm? ( >=sys-cluster/dlm-1.01.00
+ cman? ( >=sys-cluster/cman-1.01.00 )
+ gulm? ( >=sys-cluster/gulm-1.00.00 ) )"
+
+RDEPEND="${DEPEND}
+ !sys-fs/lvm-user
+ !sys-fs/clvm"
+
+S="${WORKDIR}/${PN/lvm/LVM}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ #epatch ${FILESDIR}/lvm2-2.02.04-vgid.patch
+}
+
+src_compile() {
+ # Static compile of lvm2 so that the install described in the handbook works
+ # http://www.gentoo.org/doc/en/lvm2.xml
+ # fixes http://bugs.gentoo.org/show_bug.cgi?id=84463
+ local myconf
+
+ if ! use nolvmstatic
+ then
+ myconf="${myconf} --enable-static_link"
+ use nosnapshots || myconf="${myconf} --with-snapshots=internal"
+ use nomirrors || myconf="${myconf} --with-mirrors=internal"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=internal"
+ fi
+ else
+ use nosnapshots || myconf="${myconf} --with-snapshots=shared"
+ use nomirrors || myconf="${myconf} --with-mirrors=shared"
+ if use nolvm1
+ then
+ myconf="${myconf} --with-lvm1=none"
+ else
+ myconf="${myconf} --with-lvm1=shared"
+ fi
+ fi
+
+ # disable O_DIRECT support on hppa, breaks pv detection (#99532)
+ use hppa && myconf="${myconf} --disable-o_direct"
+
+ if use clvm; then
+ if use nolvmstatic
+ then
+ myconf="${myconf} --with-cluster=shared"
+ else
+ myconf="${myconf} --with-cluster=internal"
+ fi
+ if useq cman && useq gulm; then
+ myconf="${myconf} --with-clvmd=all"
+ fi
+ if useq cman && ! useq gulm; then
+ myconf="${myconf} --with-clvmd=cman"
+ fi
+ if useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=gulm"
+ fi
+ if ! useq gulm && ! useq cman; then
+ myconf="${myconf} --with-clvmd=none"
+ fi
+ fi
+
+ econf $(use_enable readline) $(use_enable selinux) ${myconf} || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall sbindir="${D}/sbin" staticdir="${D}/sbin" confdir="${D}/etc/lvm"
+ mv -f "${D}/sbin/lvm.static" "${D}/sbin/lvm"
+
+ dodoc COPYING* INSTALL README VERSION WHATS_NEW doc/*.{conf,c,txt}
+ insinto /lib/rcscripts/addons
+ newins ${FILESDIR}/lvm2-start.sh lvm-start.sh || die
+ newins ${FILESDIR}/lvm2-stop.sh lvm-stop.sh || die
+ if use clvm; then
+ newinitd ${FILESDIR}/clvmd.rc clvmd || die
+ fi
+
+ ewarn "use flag nocman is deprecated and replaced"
+ ewarn "with cman and gulm use flags."
+ ewarn ""
+ ewarn "use flags clvm,cman and gulm are masked"
+ ewarn "by default and need to be unmasked to use them"
+ ewarn ""
+ ewarn "Rebuild your genkernel initramfs if you are using lvm"
+}