summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-07-28 02:24:07 +0000
committerNed Ludd <solar@gentoo.org>2005-07-28 02:24:07 +0000
commitc9c9f46ea068ce4714edfd222682cfc34f8b245a (patch)
treebe4d2b66db7ac9256257e088e7f956c38571133d /sys-fs/dmraid
parentRemoved old versionRemoved old version (diff)
downloadhistorical-c9c9f46ea068ce4714edfd222682cfc34f8b245a.tar.gz
historical-c9c9f46ea068ce4714edfd222682cfc34f8b245a.tar.bz2
historical-c9c9f46ea068ce4714edfd222682cfc34f8b245a.zip
- initial version of dmraid. bug #63041 - This software discovers, activates, deactivates and displays properties of software RAID sets (eg, ATARAID) and contained DOS partitions.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'sys-fs/dmraid')
-rw-r--r--sys-fs/dmraid/ChangeLog11
-rw-r--r--sys-fs/dmraid/Manifest16
-rw-r--r--sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild62
-rw-r--r--sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r11
-rw-r--r--sys-fs/dmraid/metadata.xml10
5 files changed, 100 insertions, 0 deletions
diff --git a/sys-fs/dmraid/ChangeLog b/sys-fs/dmraid/ChangeLog
new file mode 100644
index 000000000000..ee7459a0c68b
--- /dev/null
+++ b/sys-fs/dmraid/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-fs/dmraid
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/ChangeLog,v 1.1 2005/07/28 02:24:07 solar Exp $
+
+*dmraid-1.0.0_rc8-r1 (27 Jul 2005)
+
+ 27 Jul 2005; <solar.@gentoo.org> +metadata.xml, +dmraid-1.0.0_rc8-r1.ebuild:
+ - initial version of dmraid. bug #63041 - This software discovers, activates,
+ deactivates and displays properties of software RAID sets (eg, ATARAID) and
+ contained DOS partitions.
+
diff --git a/sys-fs/dmraid/Manifest b/sys-fs/dmraid/Manifest
new file mode 100644
index 000000000000..0f8449deda11
--- /dev/null
+++ b/sys-fs/dmraid/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 46a1d838b5b9f7ad952de8ee586fde52 dmraid-1.0.0_rc8-r1.ebuild 1802
+MD5 33fde53a400fbc7df899c9f27f5e5bca ChangeLog 500
+MD5 3bb7e945a8c9e94592bf5ad614aeb57a metadata.xml 449
+MD5 397241bdc56be36ee9e2bc81b7a67f67 files/digest-dmraid-1.0.0_rc8-r1 69
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iQCVAwUBQuhBHZ4WFLgrx1GWAQL0swP/Wm9ZgD4+RZJ+0CQssU4KFlg0WKVqgbJs
+oOTq1D5DpSNzQnl6aNE7ayL3fUl9YwEOa1jXq58mKyqdRysg8e0wq1gTST07KZVZ
+m+QyfsUocMVqHOc4f8qvzvloSY5IUYKDMclZJJcd2inInm4iZr+NDQSS8yMrJ5Wd
+IG21pn/Wavg=
+=U2jc
+-----END PGP SIGNATURE-----
diff --git a/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild b/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild
new file mode 100644
index 000000000000..7c3fa7820865
--- /dev/null
+++ b/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2005-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dmraid/dmraid-1.0.0_rc8-r1.ebuild,v 1.1 2005/07/28 02:24:07 solar Exp $
+
+inherit linux-info flag-o-matic
+
+DESCRIPTION="dmraid (Device-mapper RAID tool and library)"
+HOMEPAGE="http://people.redhat.com/~heinzm/sw/dmraid/"
+SRC_URI="http://people.redhat.com/~heinzm/sw/dmraid/src/${P/_/.}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+DEPEND="sys-fs/device-mapper"
+S=${WORKDIR}/${PN}/${PV/_/.}
+
+pkg_setup() {
+ if kernel_is lt 2 6; then
+ ewarn "You are using a kernel < 2.6"
+ ewarn "DMraid uses recently introduced Device-Mapper features."
+ ewarn "These might be unavailable in the kernel you are running now."
+ fi
+}
+
+src_compile() {
+ # Build fix rc8 for shared lib
+ sed -e 's:global\::global\:\ init_locking;:' -i lib/.export.sym
+
+ #inlining doesnt seem to work for dmraid
+ filter-flags -fno-inline
+
+ # We want shared. For static boot stuff, people should use genkernel.
+ ./configure --enable-shared_lib || die "Failed configure"
+ #econf --enable-shared_lib || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die "einstall failed"
+
+ dolib.a lib/libdmraid.a
+
+ # no header file is installed by make install
+ insinto /usr/include
+ newins include/dmraid.h libdmraid.h
+
+ dodoc CHANGELOG README TODO KNOWN_BUGS doc/*
+}
+
+pkg_postinst() {
+ echo
+ einfo "For booting Gentoo from Device-Mapper RAID you can use Genkernel."
+ echo
+ einfo "Genkernel will generate the kernel and the initrd with a staticly linked dmraid binary:"
+ einfo "emerge -av sys-kernel/genkernel"
+ einfo "genkernel --dmraid --udev all"
+ echo
+ ewarn "DMraid should be safe to use, but no warranties can be given"
+ echo
+ ebeep
+}
diff --git a/sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r1 b/sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r1
new file mode 100644
index 000000000000..76214c73f1e1
--- /dev/null
+++ b/sys-fs/dmraid/files/digest-dmraid-1.0.0_rc8-r1
@@ -0,0 +1 @@
+MD5 b7843de0ff7a10434cf0b84d0a19724d dmraid-1.0.0.rc8.tar.bz2 130421
diff --git a/sys-fs/dmraid/metadata.xml b/sys-fs/dmraid/metadata.xml
new file mode 100644
index 000000000000..e0088fb7d088
--- /dev/null
+++ b/sys-fs/dmraid/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>solar@gentoo.org</email>
+ <description>housemate needed it</description>
+ </maintainer>
+ <longdescription>This software discovers, activates, deactivates and displays properties of software RAID sets eg: ATARAID and contained DOS partitions.</longdescription>
+</pkgmetadata>