summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-29 15:51:10 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-29 15:51:10 +0000
commit42948cd7af5e9cc2546e786eaf8aa5e2580ed423 (patch)
treead208af619950a1c58809de6c628d68e454ba858 /sys-fs/cryptsetup
parentStable on amd64 wrt bug #320687 (diff)
downloadhistorical-42948cd7af5e9cc2546e786eaf8aa5e2580ed423.tar.gz
historical-42948cd7af5e9cc2546e786eaf8aa5e2580ed423.tar.bz2
historical-42948cd7af5e9cc2546e786eaf8aa5e2580ed423.zip
old
Diffstat (limited to 'sys-fs/cryptsetup')
-rw-r--r--sys-fs/cryptsetup/cryptsetup-0.1-r3.ebuild74
-rw-r--r--sys-fs/cryptsetup/files/1.0.5-dm-crypt-start.sh286
-rw-r--r--sys-fs/cryptsetup/files/1.0.5-dmcrypt.confd88
-rw-r--r--sys-fs/cryptsetup/files/cryptfs.confd35
-rw-r--r--sys-fs/cryptsetup/files/cryptsetup-libmapper.patch13
-rw-r--r--sys-fs/cryptsetup/files/dm-crypt-start.sh146
-rw-r--r--sys-fs/cryptsetup/files/dm-crypt-stop.sh51
7 files changed, 0 insertions, 693 deletions
diff --git a/sys-fs/cryptsetup/cryptsetup-0.1-r3.ebuild b/sys-fs/cryptsetup/cryptsetup-0.1-r3.ebuild
deleted file mode 100644
index 3d7b1512b6a2..000000000000
--- a/sys-fs/cryptsetup/cryptsetup-0.1-r3.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/cryptsetup-0.1-r3.ebuild,v 1.13 2009/04/10 16:51:56 caleb Exp $
-
-inherit linux-info multilib eutils
-
-DESCRIPTION="Tool to setup encrypted devices with dm-crypt"
-HOMEPAGE="http://www.saout.de/misc/dm-crypt/"
-SRC_URI="http://www.saout.de/misc/dm-crypt/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-RDEPEND="|| (
- >=sys-fs/lvm2-2.02.45
- >=sys-fs/device-mapper-1.00.07-r1
- )
- !sys-fs/cryptsetup-luks"
-DEPEND="dev-libs/popt
- >=dev-libs/libgcrypt-1.1.42
- dev-libs/libgpg-error"
-
-dm-crypt_check() {
- ebegin "Checking for dm-crypt support"
- linux_chkconfig_present DM_CRYPT
- eend $?
-
- if [[ $? -ne 0 ]] ; then
- ewarn "cryptsetup requires dm-crypt support!"
- ewarn "Please enable dm-crypt support in your kernel config, found at:"
- ewarn "(for 2.6 kernels)"
- ewarn
- ewarn " Device Drivers"
- ewarn " Multi-Device Support"
- ewarn " Device mapper support"
- ewarn " [*] Crypt Target Support"
- ewarn
- ewarn "and recompile your kernel if you want this package to work with this kernel"
- epause 5
- fi
-}
-
-pkg_setup() {
- linux-info_pkg_setup
- dm-crypt_check;
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/cryptsetup-libmapper.patch"
-}
-
-src_compile() {
- econf --bindir=/bin --disable-nls || die
-
- sed -i \
- -e "s|-lgcrypt|/usr/$(get_libdir)/libgcrypt.a|" \
- -e "s|-lgpg-error|/usr/$(get_libdir)/libgpg-error.a|" \
- Makefile src/Makefile
- sed -i -e "s|-lpopt|/usr/$(get_libdir)/libpopt.a|" src/Makefile
-
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
-
- newconfd ${FILESDIR}/cryptfs.confd cryptfs
- insinto /lib/rcscripts/addons
- doins "${FILESDIR}"/dm-crypt-{start,stop}.sh
-}
diff --git a/sys-fs/cryptsetup/files/1.0.5-dm-crypt-start.sh b/sys-fs/cryptsetup/files/1.0.5-dm-crypt-start.sh
deleted file mode 100644
index 055bfe9aabc5..000000000000
--- a/sys-fs/cryptsetup/files/1.0.5-dm-crypt-start.sh
+++ /dev/null
@@ -1,286 +0,0 @@
-# /lib/rcscripts/addons/dm-crypt-start.sh
-
-# For backwards compatability with baselayout < 1.13.0
-dm_crypt_execute_checkfs() {
- dm_crypt_execute_dmcrypt
-}
-
-dm_crypt_execute_volumes() {
- dm_crypt_execute_dmcrypt
-}
-
-# Setup mappings for an individual target/swap
-# Note: This relies on variables localized in the main body below.
-dm_crypt_execute_dmcrypt() {
- local dev ret mode
- # some colors
- local red='\x1b[31;01m' green='\x1b[32;01m' off='\x1b[0;0m'
-
- if [ -n "$target" ]; then
- # let user set options, otherwise leave empty
- : ${options:=' '}
- elif [ -n "$swap" ]; then
- local foo
- einfo "Checking swap is not LUKS"
- cryptsetup isLuks ${source} 2>/dev/null >/dev/console </dev/console
- foo="$?"
- if [ "${foo}" -eq 0 ]; then
- ewarn "The swap you have defined is a LUKS partition. Aborting crypt-swap setup."
- return
- fi
- target=${swap}
- # swap contents do not need to be preserved between boots, luks not required.
- # suspend2 users should have initramfs's init handling their swap partition either way.
- : ${options:='-c aes -h sha1 -d /dev/urandom'}
- : ${pre_mount:='mkswap ${dev}'}
- else
- return
- fi
- if [ -z "$source" ] && [ ! -e "$source" ]; then
- ewarn "source \"${source}\" for ${target} missing, skipping..."
- return
- fi
-
- if [[ -n ${loop_file} ]] ; then
- dev="/dev/mapper/${target}"
- ebegin " Setting up loop device ${source}"
- /sbin/losetup ${source} ${loop_file}
- fi
-
- # cryptsetup:
- # luksOpen <device> <name> # <device> is $source
- # create <name> <device> # <name> is $target
- local arg1="create" arg2="$target" arg3="$source" luks=0
-
- cryptsetup isLuks ${source} 2>/dev/null && { arg1="luksOpen"; arg2="$source"; arg3="$target"; luks=1; }
-
- if /sbin/cryptsetup status ${target} | egrep -q '\<active:' ; then
- einfo "dm-crypt mapping ${target} is already configured"
- return
- fi
- splash svc_input_begin ${SVCNAME} >/dev/null 2>&1
- # Handle keys
- if [ -n "$key" ]; then
- # Notes: sed not used to avoid case where /usr partition is encrypted.
- mode=${key/*:/} && ( [ "$mode" == "$key" ] || [ -z "$mode" ] ) && mode=reg
- key=${key/:*/}
- case "$mode" in
- gpg|reg)
- # handle key on removable device
- if [ -n "$remdev" ]; then
- # temp directory to mount removable device
- local mntrem=/mnt/remdev
- local c=0 ans
- for (( i = 0 ; i < 10 ; i++ ))
- do
- [ ! -d "$mntrem" ] && mkdir -p ${mntrem} 2>/dev/null >/dev/null
- if mount -n -o ro ${remdev} ${mntrem} 2>/dev/null >/dev/null ; then
- sleep 2
- # keyfile exists?
- if [ ! -e "${mntrem}${key}" ]; then
- umount -n ${mntrem} 2>/dev/null >/dev/null
- rmdir ${mntrem} 2>/dev/null >/dev/null
- einfo "Cannot find ${key} on removable media."
- echo -n -e " ${green}*${off} Abort?(${red}yes${off}/${green}no${off})" >/dev/console
- read ${read_timeout} ans </dev/console
- echo >/dev/console
- [ "$ans" = "no" ] && { i=0; c=0; } || return
- else
- key="${mntrem}${key}"
- break
- fi
- else
- [ "$c" -eq 0 ] && einfo "Please insert removable device for ${target}"
- c=1
- sleep 2
- # let user abort
- if [ "$i" -eq 9 ]; then
- rmdir ${mntrem} 2>/dev/null >/dev/null
- einfo "Removable device for ${target} not present."
- echo -n -e " ${green}*${off} Abort?(${red}yes${off}/${green}no${off})" >/dev/console
- read ${read_timeout} ans </dev/console
- echo >/dev/console
- [ "$ans" = "no" ] && { i=0; c=0; } || return
- fi
- fi
- done
- else # keyfile ! on removable device
- if [ ! -e "$key" ]; then
- ewarn "${source} will not be decrypted ..."
- einfo "Reason: keyfile ${key} does not exist."
- return
- fi
- fi
- ;;
- *)
- ewarn "${source} will not be decrypted ..."
- einfo "Reason: mode ${mode} is invalid."
- return
- ;;
- esac
- else
- mode=none
- fi
- ebegin "dm-crypt map ${target}"
- einfo "cryptsetup will be called with : ${options} ${arg1} ${arg2} ${arg3}"
- if [ "$mode" == "gpg" ]; then
- : ${gpg_options:='-q -d'}
- # gpg available ?
- if type -p gpg >/dev/null ; then
- for (( i = 0 ; i < 3 ; i++ ))
- do
- # paranoid, don't store key in a variable, pipe it so it stays very little in ram unprotected.
- # save stdin stdout stderr "values"
- exec 3>&0 4>&1 6>&2 # ABS says fd 5 is reserved
- exec &>/dev/console </dev/console
- gpg ${gpg_options} ${key} 2>/dev/null | cryptsetup ${options} ${arg1} ${arg2} ${arg3}
- ret="$?"
- # restore values and close file descriptors
- exec 0>&3 1>&4 2>&6
- exec 3>&- 4>&- 6>&-
- [ "$ret" -eq 0 ] && break
- done
- eend "${ret}" "failure running cryptsetup"
- else
- ewarn "${source} will not be decrypted ..."
- einfo "Reason: cannot find gpg application."
- einfo "You have to install app-crypt/gnupg first."
- einfo "If you have /usr on its own partition, try copying gpg to /bin ."
- fi
- else
- if [ "$mode" == "reg" ]; then
- cryptsetup ${options} -d ${key} ${arg1} ${arg2} ${arg3} >/dev/console </dev/console
- ret="$?"
- eend "${ret}" "failure running cryptsetup"
- else
- cryptsetup ${options} ${arg1} ${arg2} ${arg3} >/dev/console </dev/console
- ret="$?"
- eend "${ret}" "failure running cryptsetup"
- fi
- fi
- if [ -d "$mntrem" ]; then
- umount -n ${mntrem} 2>/dev/null >/dev/null
- rmdir ${mntrem} 2>/dev/null >/dev/null
- fi
- splash svc_input_end ${SVCNAME} >/dev/null 2>&1
-
- if [[ ${ret} != 0 ]] ; then
- cryptfs_status=1
- else
- if [[ -n ${pre_mount} ]] ; then
- dev="/dev/mapper/${target}"
- ebegin " Running pre_mount commands for ${target}"
- eval "${pre_mount}" > /dev/null
- ewend $? || cryptfs_status=1
- fi
- fi
-}
-
-# Run any post_mount commands for an individual mount
-#
-# Note: This relies on variables localized in the main body below.
-dm_crypt_execute_localmount() {
- local mount_point
-
- [ -z "$target" ] && [ -z "$post_mount" ] && return
-
- if ! /sbin/cryptsetup status ${target} | egrep -q '\<active:' ; then
- ewarn "Skipping unmapped target ${target}"
- cryptfs_status=1
- return
- fi
-
- mount_point=$(grep "/dev/mapper/${target}" /proc/mounts | cut -d' ' -f2)
- if [[ -z ${mount_point} ]] ; then
- ewarn "Failed to find mount point for ${target}, skipping"
- cryptfs_status=1
- fi
-
- if [[ -n ${post_mount} ]] ; then
- ebegin "Running post_mount commands for target ${target}"
- eval "${post_mount}" >/dev/null
- eend $? || cryptfs_status=1
- fi
-}
-
-# Determine string lengths
-strlen() {
- if [ -z "$1" ]
- then
- echo "usage: strlen <variable_name>"
- die
- fi
- eval echo "\${#${1}}"
-}
-
-# Lookup optional bootparams
-parse_opt() {
- case "$1" in
- *\=*)
- local key_name="`echo "$1" | cut -f1 -d=`"
- local key_len=`strlen key_name`
- local value_start=$((key_len+2))
- echo "$1" | cut -c ${value_start}-
- ;;
- esac
-}
-
-local cryptfs_status=0
-local gpg_options key loop_file target targetline options pre_mount post_mount source swap remdev
-
-CMDLINE="`cat /proc/cmdline`"
-for x in ${CMDLINE}
-do
- case "${x}" in
- key_timeout\=*)
- KEY_TIMEOUT=`parse_opt "${x}"`
- if [ ${KEY_TIMEOUT} -gt 0 ]; then
- read_timeout="-t ${KEY_TIMEOUT}"
- fi
- ;;
- esac
-done
-
-if [[ -f /etc/conf.d/dmcrypt ]] && [[ -x /sbin/cryptsetup ]] ; then
- ebegin "Setting up dm-crypt mappings"
-
- # Fix for baselayout-1.12.10 (bug 174256)
- [ -z ${SVCNAME} ] && SVCNAME="${myservice}"
-
- while read targetline ; do
- # skip comments and blank lines
- [[ ${targetline}\# == \#* ]] && continue
-
- # check for the start of a new target/swap
- case ${targetline} in
- target=*|swap=*)
- # If we have a target queued up, then execute it
- dm_crypt_execute_${SVCNAME}
-
- # Prepare for the next target/swap by resetting variables
- unset gpg_options key loop_file target options pre_mount post_mount source swap remdev
- ;;
-
- gpg_options=*|remdev=*|key=*|loop_file=*|options=*|pre_mount=*|post_mount=*|source=*)
- if [[ -z ${target} && -z ${swap} ]] ; then
- ewarn "Ignoring setting outside target/swap section: ${targetline}"
- continue
- fi
- ;;
-
- *)
- ewarn "Skipping invalid line in /etc/conf.d/dmcrypt: ${targetline}"
- ;;
- esac
-
- # Queue this setting for the next call to dm_crypt_execute_${SVCNAME}
- eval "${targetline}"
- done < /etc/conf.d/dmcrypt
-
- # If we have a target queued up, then execute it
- dm_crypt_execute_${SVCNAME}
-
- ewend ${cryptfs_status} "Failed to setup dm-crypt devices"
-fi
-
-# vim:ts=4
diff --git a/sys-fs/cryptsetup/files/1.0.5-dmcrypt.confd b/sys-fs/cryptsetup/files/1.0.5-dmcrypt.confd
deleted file mode 100644
index faa61383ceb6..000000000000
--- a/sys-fs/cryptsetup/files/1.0.5-dmcrypt.confd
+++ /dev/null
@@ -1,88 +0,0 @@
-# /etc/conf.d/cryptfs
-
-#--------------------
-# Instructions
-#--------------------
-
-# Note regarding the syntax of this file. This file is *almost* bash,
-# but each line is evaluated separately. Separate swaps/targets can be
-# specified. The init-script which reads this file assumes that a
-# swap= or target= line starts a new section, similar to lilo or grub
-# configuration.
-
-# Note when using gpg keys and /usr on a separate partition, you will
-# have to copy /usr/bin/gpg to /bin/gpg so that it will work properly
-# and ensure that gpg has been compiled statically.
-# See http://bugs.gentoo.org/90482 for more information.
-
-# Note that the init-script which reads this file detects whether your
-# partition is LUKS or not. No mkfs is run unless you specify a makefs
-# option.
-
-# Arguments:
-#-----------
-# target=<name> == Mapping name for partition.
-# swap=<name> == Mapping name for swap partition.
-# source='<dev>' == Real device for partition.
-# key='</path/to/keyfile>[:<mode>]' == Fullpath from / or from inside removable media.
-# remdev='<dev>' == Device that will be assigned to removable media.
-# gpg_options='<opts>' == Default are --quiet --decrypt
-# options='<opts>' == cryptsetup, for LUKS you can only use --readonly
-# loop_file='<file>' == Loopback file.
-# pre_mount='cmds' == commands to execute before mounting partition.
-# post_mount='cmds' == commands to execute after mounting partition.
-#-----------
-# Supported Modes
-# gpg == decrypt and pipe key into cryptsetup.
-# Note: new-line character must not be part of key.
-# Command to erase \n char: 'cat key | tr -d '\n' > cleanKey'
-
-#--------------------
-# dm-crypt examples
-#--------------------
-
-## swap
-# Swap partitions. These should come first so that no keys make their
-# way into unencrypted swap.
-# If no options are given, they will default to: -c aes -h sha1 -d /dev/urandom
-# If no makefs is given then mkswap will be assumed
-#swap=crypt-swap
-#source='/dev/hda2'
-
-## /home with passphrase
-#target=crypt-home
-#source='/dev/hda5'
-
-## /home with regular keyfile
-#target=crypt-home
-#source='/dev/hda5'
-#key='/full/path/to/homekey'
-
-## /home with gpg protected key
-#target=crypt-home
-#source='/dev/hda5'
-#key='/full/path/to/homekey:gpg'
-
-## /home with regular keyfile on removable media(such as usb-stick)
-#target=crypt-home
-#source='/dev/hda5'
-#key='/full/path/to/homekey'
-#remdev='/dev/sda1'
-
-##/home with gpg protected key on removable media(such as usb-stick)
-#target=crypt-home
-#source='/dev/hda5'
-#key='/full/path/to/homekey:gpg'
-#remdev='/dev/sda1'
-
-##/tmp with regular keyfile
-#target=crypt-tmp
-#source='/dev/hda6'
-#key='/full/path/to/tmpkey'
-#pre_mount='/sbin/mkreiserfs -f -f ${dev}'
-#post_mount='chown root:root ${mount_point}; chmod 1777 ${mount_point}'
-
-## Loopback file example
-#mount='crypt-loop-home'
-#source='/dev/loop0'
-#loop_file='/mnt/crypt/home'
diff --git a/sys-fs/cryptsetup/files/cryptfs.confd b/sys-fs/cryptsetup/files/cryptfs.confd
deleted file mode 100644
index 9fcc3cce6678..000000000000
--- a/sys-fs/cryptsetup/files/cryptfs.confd
+++ /dev/null
@@ -1,35 +0,0 @@
-# /etc/conf.d/cryptfs
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/files/cryptfs.confd,v 1.2 2005/05/21 06:10:25 vapier Exp $
-
-# Note regarding the syntax of this file. This file is *almost* bash,
-# but each line is evaluated separately. Separate swaps/mounts can be
-# specified. The init-script which reads this file assumes that a
-# swap= or mount= line starts a new section, similar to lilo or grub
-# configuration.
-
-# Note when using gpg keys and /usr on a separate partition, you will
-# have to copy /usr/bin/gpg to /bin/gpg so that it will work properly.
-# See http://bugs.gentoo.org/90482 for more information.
-
-# Swap partitions. These should come first so that no keys make their
-# way into unencrypted swap.
-# If no options are given, they will default to: -c aes -h sha1 -d /dev/urandom
-# If no makefs is given then mkswap will be assumed
-#swap=crypt-swap
-#source='/dev/main/swap'
-
-# Mounts
-# If no options are given, they will default to: -c aes -h sha1
-# No mkfs is run unless you specify a makefs option
-#mount=crypt-tmp
-#source='/dev/main/tmp'
-#options='-d /dev/urandom'
-#pre_mount='/sbin/mkreiserfs -f -f ${dev}'
-#post_mount='chown root:root ${mount_point}; chmod 1777 ${mount_point}'
-
-# Loopback file example
-
-#mount='home-crypt'
-#source='/dev/loop0'
-#options='-c serpent -s 256'
-#loop_file='/mnt/crypt/home'
diff --git a/sys-fs/cryptsetup/files/cryptsetup-libmapper.patch b/sys-fs/cryptsetup/files/cryptsetup-libmapper.patch
deleted file mode 100644
index 6f3dd180f83b..000000000000
--- a/sys-fs/cryptsetup/files/cryptsetup-libmapper.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/libdevmapper.c
-+++ src/libdevmapper.c
-@@ -216,6 +216,10 @@
- r = -EINVAL;
- if (!dm_task_get_info(dmt, &dmi))
- goto out;
-+ if (!dmi.exists) {
-+ r = -ENODEV;
-+ goto out;
-+ }
-
- next = dm_get_next_target(dmt, next, &start, &length,
- &target_type, &params);
diff --git a/sys-fs/cryptsetup/files/dm-crypt-start.sh b/sys-fs/cryptsetup/files/dm-crypt-start.sh
deleted file mode 100644
index 95dec15817e2..000000000000
--- a/sys-fs/cryptsetup/files/dm-crypt-start.sh
+++ /dev/null
@@ -1,146 +0,0 @@
-# /lib/rcscripts/addons/dm-crypt-start.sh
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/files/dm-crypt-start.sh,v 1.6 2006/04/12 02:52:43 vapier Exp $
-
-# Setup mappings for an individual mount/swap
-#
-# Note: This relies on variables localized in the main body below.
-dm-crypt-execute-checkfs() {
- local dev target ret
-
- if [[ -n ${loop_file} ]] ; then
- dev="/dev/mapper/${target}"
- ebegin " Setting up loop device ${source}"
- /sbin/losetup ${source} ${loop_file}
- fi
-
- if [[ -n ${mount} ]] ; then
- target=${mount}
- : ${options:='-c aes -h sha1'}
- [[ -n ${key} ]] && : ${gpg_options:='-q -d'}
- elif [[ -n ${swap} ]] ; then
- target=${swap}
- : ${options:='-c aes -h sha1 -d /dev/urandom'}
- : ${pre_mount:='mkswap ${dev}'}
- else
- return
- fi
-
- if /bin/cryptsetup status ${target} | egrep -q '\<active:' ; then
- einfo "dm-crypt mapping ${target} is already configured"
- return
- fi
-
- splash svc_input_begin checkfs
- ebegin "dm-crypt map ${target}"
- if [[ -z ${key} ]] ; then
- /bin/cryptsetup ${options} create ${target} ${source} >/dev/console </dev/console
- ret=$?
- eend ${ret} "failure running cryptsetup"
- else
- if type -p gpg >/dev/null ; then
- ret=1
- while [[ ${ret} -gt 0 ]] ; do
- keystring=$(gpg ${gpg_options} ${key} 2>/dev/null </dev/console)
- if [[ -z ${keystring} ]] ; then
- ret=5
- else
- echo ${keystring} | /bin/cryptsetup ${options} create ${target} ${source}
- ret=$?
- fi
- done
- eend ${ret}
- else
- einfo "You have to install app-crypt/gnupg first"
- fi
- fi
- splash svc_input_end checkfs
-
- if [[ ${ret} != 0 ]] ; then
- cryptfs_status=1
- else
- if [[ -n ${pre_mount} ]] ; then
- dev="/dev/mapper/${target}"
- ebegin " Running pre_mount commands for ${target}"
- eval "${pre_mount}" > /dev/null
- ewend $? || cryptfs_status=1
- fi
- fi
-}
-
-# Run any post_mount commands for an individual mount
-#
-# Note: This relies on variables localized in the main body below.
-dm-crypt-execute-localmount() {
- local mount_point target
-
- if [[ -n ${mount} && -n ${post_mount} ]] ; then
- target=${mount}
- else
- return
- fi
-
- if ! /bin/cryptsetup status ${target} | egrep -q '\<active:' ; then
- ewarn "Skipping unmapped target ${target}"
- cryptfs_status=1
- return
- fi
-
- mount_point=$(grep "/dev/mapper/${target}" /proc/mounts | cut -d' ' -f2)
- if [[ -z ${mount_point} ]] ; then
- ewarn "Failed to find mount point for ${target}, skipping"
- cryptfs_status=1
- fi
-
- if [[ -n ${post_mount} ]] ; then
- ebegin "Running post_mount commands for target ${target}"
- eval "${post_mount}" >/dev/null
- eend $? || cryptfs_status=1
- fi
-}
-
-local cryptfs_status=0
-local gpg_options key loop_file mount mountline options pre_mount post_mount source swap
-
-if [[ -f /etc/conf.d/cryptfs ]] && [[ -x /bin/cryptsetup ]] ; then
- ebegin "Setting up dm-crypt mappings"
-
- while read mountline ; do
- # skip comments and blank lines
- [[ ${mountline}\# == \#* ]] && continue
-
- # check for the start of a new mount/swap
- case ${mountline} in
- mount=*|swap=*)
- # If we have a mount queued up, then execute it
- dm-crypt-execute-${myservice}
-
- # Prepare for the next mount/swap by resetting variables
- unset gpg_options key loop_file mount options pre_mount post_mount source swap
- ;;
-
- gpg_options=*|key=*|loop_file=*|options=*|pre_mount=*|post_mount=*|source=*)
- if [[ -z ${mount} && -z ${swap} ]] ; then
- ewarn "Ignoring setting outside mount/swap section: ${mountline}"
- continue
- fi
- ;;
-
- *)
- ewarn "Skipping invalid line in /etc/conf.d/cryptfs: ${mountline}"
- ;;
- esac
-
- # Queue this setting for the next call to dm-crypt-execute-${myservice}
- eval "${mountline}"
- done < /etc/conf.d/cryptfs
-
- # If we have a mount queued up, then execute it
- dm-crypt-execute-${myservice}
-
- ewend ${cryptfs_status} "Failed to setup dm-crypt devices"
-fi
-
-
-# vim:ts=4
diff --git a/sys-fs/cryptsetup/files/dm-crypt-stop.sh b/sys-fs/cryptsetup/files/dm-crypt-stop.sh
deleted file mode 100644
index e499813a16d9..000000000000
--- a/sys-fs/cryptsetup/files/dm-crypt-stop.sh
+++ /dev/null
@@ -1,51 +0,0 @@
-# /lib/rcscripts/addons/dm-crypt-stop.sh
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/cryptsetup/files/dm-crypt-stop.sh,v 1.2 2005/03/02 15:16:39 vapier Exp $
-
-# Try to remove any dm-crypt mappings
-if [ -f /etc/conf.d/cryptfs ] && [ -x /bin/cryptsetup ]
-then
- einfo "Removing dm-crypt mappings"
-
- /bin/egrep "^(mount|swap)" /etc/conf.d/cryptfs | \
- while read mountline
- do
- mount=
- swap=
- target=
-
- eval ${mountline}
-
- if [ -n "${mount}" ]
- then
- target=${mount}
- elif [ -n "${swap}" ]
- then
- target=${swap}
- else
- ewarn "Invalid line in /etc/conf.d/cryptfs: ${mountline}"
- fi
-
- ebegin "Removing dm-crypt mapping for: ${target}"
- /bin/cryptsetup remove ${target}
- eend $? "Failed to remove dm-crypt mapping for: ${target}"
- done
-
- if [[ -n $(/bin/egrep -e "^(source=)./dev/loop*" /etc/conf.d/cryptfs) ]] ; then
- einfo "Taking down any dm-crypt loop devices"
- /bin/egrep -e "^(source)" /etc/conf.d/cryptfs | while read sourceline
- do
- source=
- eval ${sourceline}
- if [[ -n $(echo ${source} | grep /dev/loop) ]] ; then
- ebegin " Taking down ${source}"
- /sbin/losetup -d ${source}
- eend $? " Failed to remove loop"
- fi
- done
- fi
-fi
-
-
-# vim:ts=4