summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Peterson <lavajoe@gentoo.org>2008-08-06 04:05:53 +0000
committerJoe Peterson <lavajoe@gentoo.org>2008-08-06 04:05:53 +0000
commit2ff985718a5847a7d9be07c8d47d9dd4687ada34 (patch)
treef009f6f50a935ea94e3561170ae772e6a1eaa46c /sys-fs/btrfs
parentversion bump (diff)
downloadhistorical-2ff985718a5847a7d9be07c8d47d9dd4687ada34.tar.gz
historical-2ff985718a5847a7d9be07c8d47d9dd4687ada34.tar.bz2
historical-2ff985718a5847a7d9be07c8d47d9dd4687ada34.zip
New version 0.16
Package-Manager: portage-2.2_rc6/cvs/Linux 2.6.26-gentoo i686
Diffstat (limited to 'sys-fs/btrfs')
-rw-r--r--sys-fs/btrfs/ChangeLog7
-rw-r--r--sys-fs/btrfs/btrfs-0.16.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/sys-fs/btrfs/ChangeLog b/sys-fs/btrfs/ChangeLog
index b4e3b84cbb53..5a039f14d0de 100644
--- a/sys-fs/btrfs/ChangeLog
+++ b/sys-fs/btrfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/btrfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.10 2008/07/29 03:42:26 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/ChangeLog,v 1.11 2008/08/06 04:04:52 lavajoe Exp $
+
+*btrfs-0.16 (05 Aug 2008)
+
+ 05 Aug 2008; Joe Peterson <lavajoe@gentoo.org> +btrfs-0.16.ebuild:
+ New version 0.16
29 Jul 2008; Joe Peterson <lavajoe@gentoo.org> btrfs-0.15-r2.ebuild,
btrfs-9999.ebuild:
diff --git a/sys-fs/btrfs/btrfs-0.16.ebuild b/sys-fs/btrfs/btrfs-0.16.ebuild
new file mode 100644
index 000000000000..15b73c1992cd
--- /dev/null
+++ b/sys-fs/btrfs/btrfs-0.16.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/btrfs/btrfs-0.16.ebuild,v 1.1 2008/08/06 04:04:52 lavajoe Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="A checksumming copy-on-write filesystem"
+HOMEPAGE="http://btrfs.wiki.kernel.org/"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+pkg_setup()
+{
+ linux-mod_pkg_setup
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KERNELDIR=${KV_OUT_DIR}"
+ MODULE_NAMES="btrfs(fs:${S}/"
+
+ if ! kernel_is 2 6; then
+ eerror "Need a 2.6 kernel to compile against!"
+ die "Need a 2.6 kernel to compile against!"
+ fi
+
+ if ! linux_chkconfig_present LIBCRC32C; then
+ eerror "You need to enable LIBCRC32C in your kernel!"
+ die "You need to enable LIBCRC32C in your kernel!"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply hot fixes
+ #epatch "${FILESDIR}/${P}-hotfix.patch"
+}
+
+src_install()
+{
+ linux-mod_src_install
+
+ dodoc INSTALL TODO
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ ewarn "WARNING: Btrfs is under heavy development and is not suitable for"
+ ewarn " any uses other than benchmarking and review."
+ ewarn " The Btrfs disk format is not yet finalized."
+ ewarn
+ ewarn " Also, it is highly recommended that the versions of"
+ ewarn " btrfs and btrfs-progs match."
+ ewarn
+ ewarn "Note: THE DISK FORMAT HAS CHANGED!"
+ ewarn " You must backup your data and re-create your btrfs"
+ ewarn " filesystem(s) for use with this version."
+}