summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:06:27 +0000
committerJavier Villavicencio <the_paya@gentoo.org>2009-01-22 21:06:27 +0000
commit229a1f9d4e026cbe2d47737178139bf14ae7adfb (patch)
tree36f692e9af2ad5dc3511b3101ce11ce9adcbfbe5 /sys-freebsd/freebsd-ubin
parentFix bug 256040, we need to run eautoreconf when we sed a .am (diff)
downloadhistorical-229a1f9d4e026cbe2d47737178139bf14ae7adfb.tar.gz
historical-229a1f9d4e026cbe2d47737178139bf14ae7adfb.tar.bz2
historical-229a1f9d4e026cbe2d47737178139bf14ae7adfb.zip
Import of the 7.1 ebuilds from gentoo-bsd overlay.
Package-Manager: portage-2.2_rc23/cvs/FreeBSD i386
Diffstat (limited to 'sys-freebsd/freebsd-ubin')
-rw-r--r--sys-freebsd/freebsd-ubin/ChangeLog8
-rw-r--r--sys-freebsd/freebsd-ubin/freebsd-ubin-7.1.ebuild139
2 files changed, 146 insertions, 1 deletions
diff --git a/sys-freebsd/freebsd-ubin/ChangeLog b/sys-freebsd/freebsd-ubin/ChangeLog
index ad197b841463..be3adde7991c 100644
--- a/sys-freebsd/freebsd-ubin/ChangeLog
+++ b/sys-freebsd/freebsd-ubin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-freebsd/freebsd-ubin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.57 2009/01/08 21:17:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/ChangeLog,v 1.58 2009/01/22 21:06:12 the_paya Exp $
+
+*freebsd-ubin-7.1 (22 Jan 2009)
+
+ 22 Jan 2009; Javier Villavicencio <the_paya@gentoo.org>
+ +freebsd-ubin-7.1.ebuild:
+ Import 7.1 ebuilds from gentoo-bsd overlay.
08 Jan 2009; Alexis Ballier <aballier@gentoo.org>
-freebsd-ubin-6.2.ebuild:
diff --git a/sys-freebsd/freebsd-ubin/freebsd-ubin-7.1.ebuild b/sys-freebsd/freebsd-ubin/freebsd-ubin-7.1.ebuild
new file mode 100644
index 000000000000..5a4bf047511c
--- /dev/null
+++ b/sys-freebsd/freebsd-ubin/freebsd-ubin-7.1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-ubin/freebsd-ubin-7.1.ebuild,v 1.1 2009/01/22 21:06:12 the_paya Exp $
+
+inherit bsdmk freebsd flag-o-matic pam
+
+DESCRIPTION="FreeBSD's base system source for /usr/bin"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE="atm bluetooth ssl usb nls ipv6 kerberos nis build"
+
+SRC_URI="mirror://gentoo/${UBIN}.tar.bz2
+ mirror://gentoo/${CONTRIB}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2
+ mirror://gentoo/${ETC}.tar.bz2
+ mirror://gentoo/${BIN}.tar.bz2
+ mirror://gentoo/${INCLUDE}.tar.bz2
+ build? ( mirror://gentoo/${SYS}.tar.bz2 )"
+
+RDEPEND=">=sys-freebsd/freebsd-lib-6.2_rc2
+ ssl? ( dev-libs/openssl )
+ kerberos? ( virtual/krb5 )
+ virtual/pam
+ sys-libs/zlib
+ !dev-util/csup"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ !build? ( =sys-freebsd/freebsd-sources-${RV}* )
+ =sys-freebsd/freebsd-mk-defs-${RV}*"
+
+RDEPEND="${RDEPEND}
+ >=sys-auth/pambase-20080219.1
+ sys-process/cronbase"
+
+S="${WORKDIR}/usr.bin"
+
+pkg_setup() {
+ use nls || mymakeopts="${mymakeopts} NO_NLS= "
+ use atm || mymakeopts="${mymakeopts} NO_ATM= "
+ use bluetooth || mymakeopts="${mymakeopts} NO_BLUETOOTH= "
+ use ssl || mymakeopts="${mymakeopts} NO_OPENSSL= NO_CRYPT= "
+ use usb || mymakeopts="${mymakeopts} NO_USB= "
+ use ipv6 || mymakeopts="${mymakeopts} NO_INET6= "
+ use kerberos || mymakeopts="${mymakeopts} NO_KERBEROS= "
+ use nis || mymakeopts="${mymakeopts} NO_NIS= "
+
+ mymakeopts="${mymakeopts} NO_SENDMAIL= "
+}
+
+# List of patches to apply
+PATCHES="${FILESDIR}/${PN}-6.0-bsdcmp.patch
+ ${FILESDIR}/${PN}-6.0-fixmakefiles.patch
+ ${FILESDIR}/${PN}-setXid.patch
+ ${FILESDIR}/${PN}-lint-stdarg.patch
+ ${FILESDIR}/${PN}-6.0-kdump-ioctl.patch"
+
+# Here we remove some sources we don't need because they are already
+# provided by portage's packages or similar. In order:
+# - Archiving tools, provided by their own ebuilds
+# - ncurses stuff
+# - less stuff
+# - bind utils
+# - rsh stuff
+# - binutils gprof
+# and the rest are misc utils we already provide somewhere else.
+REMOVE_SUBDIRS="bzip2 bzip2recover tar
+ gzip gprof
+ tput tset
+ less lessecho lesskey
+ dig hesinfo nslookup nsupdate host
+ rsh rlogin rusers rwho ruptime
+ compile_et lex vi smbutil file vacation nc ftp telnet
+ c99 c89
+ whois tftp"
+
+pkg_preinst() {
+ # bison installs a /usr/bin/yacc symlink ...
+ # we need to remove it to avoid triggering
+ # collision-protect errors
+ if [[ -L ${ROOT}/usr/bin/yacc ]] ; then
+ rm -f "${ROOT}"/usr/bin/yacc
+ fi
+}
+
+
+src_unpack() {
+ freebsd_src_unpack
+
+ use build || ln -s "/usr/src/sys-${RV}" "${WORKDIR}/sys"
+
+ # Rename manpage for renamed cmp
+ mv "${S}"/cmp/cmp.1 "${S}"/cmp/bsdcmp.1
+ # Fix whereis(1) manpath search.
+ sed -i -e 's:"manpath -q":"manpath":' "${S}/whereis/pathnames.h"
+
+ # Build a dynamic make
+ sed -i -e '/^NO_SHARED/ s/^/#/' "${S}"/make/Makefile
+}
+
+src_install() {
+ freebsd_src_install
+
+ # baselayout requires these in /bin
+ dodir /bin
+ for bin in sed; do
+ mv "${D}/usr/bin/${bin}" "${D}/bin/" || die "mv ${bin} failed"
+ dosym /bin/${bin} /usr/bin/${bin} || die "dosym ${bin} failed"
+ done
+
+ for pamdfile in login passwd su; do
+ newpamd "${FILESDIR}/${pamdfile}.1.pamd" ${pamdfile}
+ done
+
+ cd "${WORKDIR}/etc"
+ insinto /etc
+ doins remote phones opieaccess fbtab
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/locate-updatedb-cron" locate.updatedb
+}
+
+pkg_postinst() {
+ # We need to ensure that login.conf.db is up-to-date.
+ if [[ -e "${ROOT}"etc/login.conf ]] ; then
+ einfo "Updating ${ROOT}etc/login.conf.db"
+ "${ROOT}"usr/bin/cap_mkdb -f "${ROOT}"etc/login.conf "${ROOT}"etc/login.conf
+ elog "Remember to run cap_mkdb /etc/login.conf after making changes to it"
+ fi
+}
+
+pkg_postrm() {
+ # and if we uninstall yacc but keep bison,
+ # lets restore the /usr/bin/yacc symlink
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] && [[ -e ${ROOT}/usr/bin/yacc.bison ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}