summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-11-07 12:42:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-11-07 12:42:54 +0000
commit924e9525c1f21fff0c0f74964d9ff80f264211f6 (patch)
tree1e93857ca8ec33cdad2cd6c05bc0c3cffa80e5b3 /sys-freebsd/boot0
parentversion bump (diff)
downloadhistorical-924e9525c1f21fff0c0f74964d9ff80f264211f6.tar.gz
historical-924e9525c1f21fff0c0f74964d9ff80f264211f6.tar.bz2
historical-924e9525c1f21fff0c0f74964d9ff80f264211f6.zip
bump to 9.0_rc1
Package-Manager: portage-2.2.0_alpha72/cvs/Linux x86_64
Diffstat (limited to 'sys-freebsd/boot0')
-rw-r--r--sys-freebsd/boot0/ChangeLog7
-rw-r--r--sys-freebsd/boot0/boot0-9.0_rc1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-freebsd/boot0/ChangeLog b/sys-freebsd/boot0/ChangeLog
index 7e243977e2c7..600c359b2732 100644
--- a/sys-freebsd/boot0/ChangeLog
+++ b/sys-freebsd/boot0/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-freebsd/boot0
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.27 2011/07/25 10:26:26 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.28 2011/11/07 12:18:39 aballier Exp $
+
+*boot0-9.0_rc1 (07 Nov 2011)
+
+ 07 Nov 2011; Alexis Ballier <aballier@gentoo.org> +boot0-9.0_rc1.ebuild:
+ bump to 9.0_rc1
25 Jul 2011; Naohiro Aota <naota@gentoo.org> boot0-8.2.ebuild,
+files/boot0-8.2-zfsboot-makefile.patch:
diff --git a/sys-freebsd/boot0/boot0-9.0_rc1.ebuild b/sys-freebsd/boot0/boot0-9.0_rc1.ebuild
new file mode 100644
index 000000000000..800f68925133
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-9.0_rc1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.0_rc1.ebuild,v 1.1 2011/11/07 12:18:39 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd flag-o-matic
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+KEYWORDS="~sparc-fbsd ~x86-fbsd"
+
+IUSE="bzip2 ieee1394 tftp zfs"
+
+SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+boot0_use_enable() {
+ use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
+}
+
+pkg_setup() {
+ boot0_use_enable ieee1394 FIREWIRE
+ boot0_use_enable zfs ZFS
+ boot0_use_enable tftp TFTP
+ boot0_use_enable bzip2 BZIP2
+}
+
+src_prepare() {
+ sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
+ -i "${S}"/i386/boot2/Makefile \
+ -i "${S}"/i386/gptboot/Makefile \
+ -i "${S}"/i386/gptzfsboot/Makefile \
+ -i "${S}"/i386/zfsboot/Makefile || die
+}
+
+src_compile() {
+ strip-flags
+ append-flags "-I/usr/include/libstand/"
+ append-flags "-fno-strict-aliasing"
+ NOFLAGSTRIP="yes" freebsd_src_compile
+}
+
+src_install() {
+ dodir /boot/defaults
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+}