summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-11-23 02:12:49 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-11-23 02:12:49 +0000
commitdf1b9c1d4b09d0f14ee1f42dcc2e966dea24a8a8 (patch)
tree4bd267fc93370a03275c9080d5d682b5f63c2f95 /sys-devel
parentNew version (diff)
downloadhistorical-df1b9c1d4b09d0f14ee1f42dcc2e966dea24a8a8.tar.gz
historical-df1b9c1d4b09d0f14ee1f42dcc2e966dea24a8a8.tar.bz2
historical-df1b9c1d4b09d0f14ee1f42dcc2e966dea24a8a8.zip
added einfo lines and gdbm/berkdb confirmation to perl-5.6.1-r8
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/perl/ChangeLog6
-rw-r--r--sys-devel/perl/perl-5.6.1-r8.ebuild17
2 files changed, 21 insertions, 2 deletions
diff --git a/sys-devel/perl/ChangeLog b/sys-devel/perl/ChangeLog
index 40c039cc687d..28ff13112596 100644
--- a/sys-devel/perl/ChangeLog
+++ b/sys-devel/perl/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for sys-devel/perl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.15 2002/11/22 19:03:38 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.16 2002/11/23 02:12:49 mcummings Exp $
*perl-5.6.1-r8 (13 Oct 2002)
22 Nov 2002; <mcummings@gentoo.org>
+ Added einfo note (finally) to instruct users to install MakeMaker
+ patch. Also added catch for cases where -gdbm and -berkdb are in
+ the use flags - perl requires at least one of them to be available
+
Second incantation of -r8. This time, it is for LC_ALL=C being added to
the ebuild itself. Perl won't compile correctly otherwise and handles
internationaliztion post install.
diff --git a/sys-devel/perl/perl-5.6.1-r8.ebuild b/sys-devel/perl/perl-5.6.1-r8.ebuild
index e2925561b3bc..3f94e9aad032 100644
--- a/sys-devel/perl/perl-5.6.1-r8.ebuild
+++ b/sys-devel/perl/perl-5.6.1-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r8.ebuild,v 1.4 2002/11/22 19:03:38 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r8.ebuild,v 1.5 2002/11/23 02:12:49 mcummings Exp $
IUSE="berkdb gdbm"
@@ -20,6 +20,7 @@ DEPEND="sys-apps/groff
${RDEPEND}"
src_compile() {
+ use gdbm || use berkdb || die "You must have either gdbm or berkdb installed and in your use flags."
#The following is to handle international users. Perl does nls post-install
export LC_ALL=C
@@ -40,6 +41,7 @@ src_compile() {
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
+
# configure for libperl.so
sh Configure -des \
@@ -194,3 +196,16 @@ src_install() {
./perl installhtml --recurse --htmldir=${D}/usr/share/doc/${PF}/html
}
+
+
+pkg_postinst() {
+
+ einfo
+ einfo "Now that Perl is installed, you *must* install "
+ einfo "dev-perl/ExtUtils-MakeMaker. This is an update to "
+ einfo "the MakeMaker that comes bundled with Perl and includes "
+ einfo "fixes applicable to the Gentoo sandbox. You must do this"
+ einfo "even if you are re-installing Perl."
+ einfo
+
+}