summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-11-29 20:21:29 +0000
committerNick Hadaway <raker@gentoo.org>2002-11-29 20:21:29 +0000
commitd5ccafb187ffe80193aa6dc2cb0eaa03193e065b (patch)
treeef5ab29152df8105d464dcf70738255f5273b87a /sys-devel
parentcleanups (diff)
downloadhistorical-d5ccafb187ffe80193aa6dc2cb0eaa03193e065b.tar.gz
historical-d5ccafb187ffe80193aa6dc2cb0eaa03193e065b.tar.bz2
historical-d5ccafb187ffe80193aa6dc2cb0eaa03193e065b.zip
Version bump. Still marked unstable. Attends to bug #11088
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog8
-rw-r--r--sys-devel/binutils/binutils-2.13.90.0.16.ebuild140
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.13.90.0.161
3 files changed, 148 insertions, 1 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index 06510c7bdbc5..c288a73d8559 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.15 2002/11/18 12:59:15 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.16 2002/11/29 20:21:29 raker Exp $
+
+*binutils-2.13.90.0.16 (29 Nov 2002)
+
+ 29 Nov 2002; Nick Hadaway <raker@gentoo.org>
+ binutils-2.13.90.0.16.ebuild, files/digest-binutils-2.13.90.0.16 :
+ Version bump. No changes in the ebuild. Solves bug #11088
*binutils-2.13.90.0.14 (18 Nov 2002)
diff --git a/sys-devel/binutils/binutils-2.13.90.0.16.ebuild b/sys-devel/binutils/binutils-2.13.90.0.16.ebuild
new file mode 100644
index 000000000000..f94d93926f65
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.13.90.0.16.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.13.90.0.16.ebuild,v 1.1 2002/11/29 20:21:29 raker Exp $
+
+IUSE="nls bootstrap static build"
+
+# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
+# the manpages, but seems this is incorrect ....
+
+inherit libtool flag-o-matic
+
+# Generate borked binaries. Bug #6730
+filter-flags "-fomit-frame-pointer"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/devel/binutils/test/${P}.tar.bz2"
+HOMEPAGE="http://sources.redhat.com/binutils/"
+
+SLOT="0"
+LICENSE="GPL-2|LGPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc64 ~sparc"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.21
+ nls? ( sys-devel/gettext )
+ || ( sys-devel/perl
+ ( !build? ( sys-devel/perl ) )
+ ( !bootstrap? ( sys-devel/perl ) )
+ )"
+# This is a hairy one. Basically depend on sys-devel/perl
+# if "build" or "bootstrap" not in USE.
+
+
+src_compile() {
+
+ local myconf=""
+ use nls && \
+ myconf="${myconf} --without-included-gettext" || \
+ myconf="${myconf} --disable-nls"
+
+ # Fix /usr/lib/libbfd.la
+ elibtoolize --portage
+
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ if [ "`use static`" ]
+ then
+ make headers -C bfd CFLAGS=-O || die
+ emake -e LDFLAGS=-all-static || die
+ else
+ make headers -C bfd CFLAGS=-O || die
+ emake || die
+ fi
+
+ if [ -z "`use build`" ]
+ then
+ if [ -z "`use bootstrap`" ]
+ then
+ #nuke the manpages to recreate them (only use this if we have perl)
+ find . -name '*.1' -exec rm -f {} \; || :
+ fi
+ #make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ insinto /usr/include
+ doins include/libiberty.h
+
+ #c++filt is included with gcc -- what are these GNU people thinking?
+ #but not the manpage, so leave that!
+ rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
+ # /usr/bin/strip we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ # The strip symlink gets created in the loop below
+
+ # By default ar, as, ld, nm, ranlib and strip are in two places; create
+ # symlinks. This will reduce the size of the tbz2 significantly. We also
+ # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
+ # appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x=""
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv ${x} ../${CHOST}/bin/${x}
+ else
+ rm -f ${x}
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ # Install pre-generated manpages .. currently we do not ...
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
+
diff --git a/sys-devel/binutils/files/digest-binutils-2.13.90.0.16 b/sys-devel/binutils/files/digest-binutils-2.13.90.0.16
new file mode 100644
index 000000000000..351046eb89ea
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.13.90.0.16
@@ -0,0 +1 @@
+MD5 d27a33db69b9799a414d98f4b274b3a6 binutils-2.13.90.0.16.tar.bz2 9735189