summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-22 01:56:33 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-22 01:56:33 +0000
commit9a04fb378d6152aeb3faef8c420a6d2bd56207a8 (patch)
tree0e5f255f7bd13ef0e827521e7a86b1983d0f9d84 /sys-devel
parentcleanup KEYWORDS (diff)
downloadhistorical-9a04fb378d6152aeb3faef8c420a6d2bd56207a8.tar.gz
historical-9a04fb378d6152aeb3faef8c420a6d2bd56207a8.tar.bz2
historical-9a04fb378d6152aeb3faef8c420a6d2bd56207a8.zip
Version bump.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-4.2.0_alpha200610143
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20061014.ebuild64
3 files changed, 74 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 6f4de6876ba0..49e0badf4fbc 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.574 2006/10/18 12:24:13 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.575 2006/10/22 01:56:33 vapier Exp $
+
+*gcc-4.2.0_alpha20061014 (22 Oct 2006)
+
+ 22 Oct 2006; Mike Frysinger <vapier@gentoo.org>
+ +gcc-4.2.0_alpha20061014.ebuild:
+ Version bump.
18 Oct 2006; Roy Marples <uberlord@gentoo.org> gcc-4.1.1-r1.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061014 b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061014
new file mode 100644
index 000000000000..3975036cf671
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-4.2.0_alpha20061014
@@ -0,0 +1,3 @@
+MD5 1436184012555202c14f58f7c781b2e6 gcc-4.2-20061014.tar.bz2 40625634
+RMD160 660f6d2a7ca5caf98c7dff231cc85c9ca421c862 gcc-4.2-20061014.tar.bz2 40625634
+SHA256 ee499f2284c2def2b08b23e92ea56a09dfc5582400ebbcd7f1b22eb0eb947c24 gcc-4.2-20061014.tar.bz2 40625634
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20061014.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20061014.ebuild
new file mode 100644
index 000000000000..9b6b737831a4
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20061014.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20061014.ebuild,v 1.1 2006/10/22 01:56:33 vapier Exp $
+
+ETYPE="gcc-compiler"
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="-*"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
+ virtual/libiconv
+ fortran? (
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.2.0_p10
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ >=${CATEGORY}/binutils-2.16.1"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+pkg_setup() {
+ if [[ -z ${I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS} ]] ; then
+ die "Please \`export I_PROMISE_TO_SUPPLY_PATCHES_WITH_BUGS=1\` or define it in your make.conf if you want to use this ebuild. This is to try and cut down on people filing bugs for a compiler we do not currently support."
+ fi
+}
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.1.0/gcc-4.1.0-cross-compile.patch
+}
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ einfo "This gcc-4 ebuild is provided for your convenience, and the use"
+ einfo "of this compiler is not supported by the Gentoo Developers."
+ einfo "Please file bugs related to gcc-4 with upstream developers."
+ einfo "Compiler bugs should be filed at http://gcc.gnu.org/bugzilla/"
+}