summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2004-07-06 21:27:30 +0000
committerLisa M. Seelye <lisa@gentoo.org>2004-07-06 21:27:30 +0000
commit390f84a2496957593adf56e8f6a2895fafa97ea9 (patch)
tree7056650df98899b1c9e4ddaeb5e15a817d96bc1b /sys-devel
parentAdd ~amd64 after extensive testing of many roms ;-) closes bug #53461 (diff)
downloadhistorical-390f84a2496957593adf56e8f6a2895fafa97ea9.tar.gz
historical-390f84a2496957593adf56e8f6a2895fafa97ea9.tar.bz2
historical-390f84a2496957593adf56e8f6a2895fafa97ea9.zip
version bump. ARCHES: please test and let me know if it is ok to bump.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog7
-rw-r--r--sys-devel/distcc/Manifest14
-rw-r--r--sys-devel/distcc/distcc-2.15.ebuild148
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.151
4 files changed, 163 insertions, 7 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index e3e95c5feb4c..02f42e3bbe21 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.106 2004/06/24 22:44:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.107 2004/07/06 21:27:30 lisa Exp $
+
+*distcc-2.15 (06 Jul 2004)
+
+ 06 Jul 2004; Lisa Seelye <lisa@gentoo.org> +distcc-2.15.ebuild:
+ version bump
15 May 2004; Lisa Seelye <lisa@gentoo.org> distcc-2.13-r1.ebuild,
distcc-2.14.ebuild:
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 58a9c620d38f..3b716d0dd644 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,11 +1,13 @@
-MD5 775ff8bd8e92fd4ba79efedac2b4e525 distcc-2.14.ebuild 4706
-MD5 e410d067ffa3099f48c975b64dc98ec8 distcc-2.12.1-r1.ebuild 4627
MD5 67987c9a0f3eae8d0a7edf4c02cfb580 distcc-2.13-r1.ebuild 4695
-MD5 28931d841b929ffcd010c61439c0fc0b ChangeLog 19045
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
+MD5 6bdf4ac3be936f37ed38540af34735b8 ChangeLog 19151
+MD5 e410d067ffa3099f48c975b64dc98ec8 distcc-2.12.1-r1.ebuild 4627
+MD5 26172aca9cc31ae2708f30bd45468fa7 distcc-2.15.ebuild 4703
+MD5 775ff8bd8e92fd4ba79efedac2b4e525 distcc-2.14.ebuild 4706
+MD5 47a8df000e00ce5f8bff08c9342bdae4 files/digest-distcc-2.14 64
MD5 9ca407ce154707a1f27485523adf943c files/digest-distcc-2.12.1-r1 66
+MD5 75012a6d64ecdfef7d2cbf28abaa6ed9 files/digest-distcc-2.15 64
MD5 6ab90bfeafe27c0d276eb8b6f1257560 files/digest-distcc-2.13-r1 64
-MD5 47a8df000e00ce5f8bff08c9342bdae4 files/digest-distcc-2.14 64
-MD5 853c422cfaa9f8af9a2f25c78cb793b7 files/2.11.1p/conf 544
-MD5 0f86be5afa04088831e049957f87582a files/2.11.1p/init 642
MD5 f1caa9d9fd82ed7ee71db5d86db24ca4 files/2.11.1p/distcc-config 4883
+MD5 0f86be5afa04088831e049957f87582a files/2.11.1p/init 642
+MD5 853c422cfaa9f8af9a2f25c78cb793b7 files/2.11.1p/conf 544
diff --git a/sys-devel/distcc/distcc-2.15.ebuild b/sys-devel/distcc/distcc-2.15.ebuild
new file mode 100644
index 000000000000..2313de3343b5
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.15.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.15.ebuild,v 1.1 2004/07/06 21:27:30 lisa Exp $
+
+# If you change this in any way please email lisa@gentoo.org and make an
+# entry in the ChangeLog (this means you spanky :P). (2004-04-11) Lisa Seelye
+
+inherit eutils gcc flag-o-matic
+
+PATCHLEVEL="2.11.1p"
+
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~ia64 ~amd64 ~s390"
+IUSE="gnome gtk selinux ipv6"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow
+ dev-util/pkgconfig"
+RDEPEND="
+ !arm? ( !mips? (
+ gnome? (
+ >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ >=gnome-base/gconf-2.0.0
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ ) )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && ! use mips && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && ! use mips && myconf="${myconf} --with-gnome"
+ use mips && use gtk || use gnome && ewarn "X support for Mips has been disabled."
+ #Above, mips is excluded due to version issues. 2004-02-20
+
+ [ `gcc-major-version` -eq 2 ] && filter-lfs-flags
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ myconf=" ${myconf} --enable-rfc2553 "
+ sleep 4s
+ fi
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Setting permissions on ${ROOT}var/run/distccd"
+ chown -R distcc:daemon ${ROOT}var/run/distccd
+ echo ""
+
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version includes a new distcc-config. If you encounter problems with it,"
+ ewarn "please report them to our Bugzilla at bugs.gentoo.org"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+ sleep 3s
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.15 b/sys-devel/distcc/files/digest-distcc-2.15
new file mode 100644
index 000000000000..e098a4b9b66b
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.15
@@ -0,0 +1 @@
+MD5 96c636bbce34f6851c059390d3a18250 distcc-2.15.tar.bz2 336352