summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-05-08 14:24:04 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-05-08 14:24:04 +0000
commit2103bfa239b28b4905b7e0d6b0d57022a4fd6b34 (patch)
tree2388d491e44802e18e60a1128f8297e988bd86ea /sys-devel/patch
parent~amd64 (diff)
downloadhistorical-2103bfa239b28b4905b7e0d6b0d57022a4fd6b34.tar.gz
historical-2103bfa239b28b4905b7e0d6b0d57022a4fd6b34.tar.bz2
historical-2103bfa239b28b4905b7e0d6b0d57022a4fd6b34.zip
Fixes BUG #46892.
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/ChangeLog7
-rw-r--r--sys-devel/patch/Manifest8
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild14
3 files changed, 22 insertions, 7 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index c129ad9e2de9..b00a834fd783 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/patch
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.20 2004/03/29 21:53:56 avenj Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.21 2004/05/08 14:24:04 kugelfang Exp $
+
+ 08 May 2004; Danny van Dyk <kugelfang@gentoo.org> patch-2.5.9.ebuild:
+ Filtering "-pie" from LDFLAGS and appending manually to the Makefile for amd64.
29 Mar 2004; Jon Portnoy <avenj@gentoo.org> patch-2.5.9.ebuild :
Added strip-flags, bug #42698.
diff --git a/sys-devel/patch/Manifest b/sys-devel/patch/Manifest
index 0370e7e5a1c5..37d292ee1493 100644
--- a/sys-devel/patch/Manifest
+++ b/sys-devel/patch/Manifest
@@ -1,6 +1,6 @@
-MD5 d8308835b63cc0644a67523856ef2df8 files/digest-patch-2.5.4-r5 63
-MD5 7113f2413944cb06cecdd0c57ab54078 files/digest-patch-2.5.9 63
-MD5 19af6d6f96a24773d4476bc36c0e2cb2 ChangeLog 2629
+MD5 d0d5279fa38abc6ca22a675f5b34a5e6 ChangeLog 2788
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 113d8b76c54663b406b5ecb5c06244e6 patch-2.5.4-r5.ebuild 914
-MD5 14d62567bf92d7d79e2eca6e505571ab patch-2.5.9.ebuild 1050
+MD5 73dbd03f7a2042ab5dbd29c7ad0d500c patch-2.5.9.ebuild 1482
+MD5 d8308835b63cc0644a67523856ef2df8 files/digest-patch-2.5.4-r5 63
+MD5 7113f2413944cb06cecdd0c57ab54078 files/digest-patch-2.5.9 63
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index b56b7b5f6b2c..6c0d70f427d5 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.15 2004/04/24 08:06:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.16 2004/05/08 14:24:04 kugelfang Exp $
inherit flag-o-matic
@@ -20,8 +20,20 @@ DEPEND="virtual/glibc"
src_compile() {
strip-flags
CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
+ # workaround for hardened on amd64, 1st part
+ if [ "`use amd64`" ] && [ "is-ldflags -pie" ]; then
+ einfo Stripping "-pie" from LDFLAGS, adding it to Makefile manually
+ filter-ldflags -pie
+ append-flags -fPIC
+ LDFLAGS_PIE="1"
+ fi
ac_cv_sys_long_file_names=yes \
./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ # workaround for hardened on amd64, 2nd part
+ if [ ${LDFLAGS_PIE} = "1" ]; then
+ einfo "Patching Makefile..."
+ sed -i -e 's/^LDFLAGS =/& -pie/' Makefile || die "Patching Makefile failed!"
+ fi
if ! use static ; then
emake || die "emake failed"
else