summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-09 17:28:30 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-09 17:28:30 +0000
commita872618c6ff5a32b4ae6cfd3984dcd18d48ebdea (patch)
treea9b80375ec962930c0fc1a49f01af979f9fa41d6 /sys-devel/m4
parentversion bump to a masked gtk2 galeon (diff)
downloadhistorical-a872618c6ff5a32b4ae6cfd3984dcd18d48ebdea.tar.gz
historical-a872618c6ff5a32b4ae6cfd3984dcd18d48ebdea.tar.bz2
historical-a872618c6ff5a32b4ae6cfd3984dcd18d48ebdea.zip
new version to fix bug #15573
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/ChangeLog11
-rw-r--r--sys-devel/m4/files/digest-m4-1.42
-rw-r--r--sys-devel/m4/m4-1.4.ebuild59
3 files changed, 69 insertions, 3 deletions
diff --git a/sys-devel/m4/ChangeLog b/sys-devel/m4/ChangeLog
index 64a6eba6b273..5bdf4ef962a8 100644
--- a/sys-devel/m4/ChangeLog
+++ b/sys-devel/m4/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for sys-devel/m4
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.10 2003/02/24 10:11:26 carpaski Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.11 2003/03/09 17:28:30 azarah Exp $
+
+*m4-1.4 (09 Mar 2003)
+
+ 09 Mar 2003; Martin Schlemmer <azarah@gentoo.org> m4-1.4.ebuild :
+ Add non beta, with Debian fixes to close bug #15573.
24 Feb 2003; Nicholas Jones <carpaski@gentoo.org> :
- Fixed the 1.4p ebuilds for the 'env' call that was putting root's
- environment into /tmp world readable.
+ Fixed the 1.4p ebuilds for the 'env' call that was putting root's
+ environment into /tmp world readable.
18 Feb 2003; Zach Welch <zwelch@gentoo.org> :
Added arm to keywords.
diff --git a/sys-devel/m4/files/digest-m4-1.4 b/sys-devel/m4/files/digest-m4-1.4
new file mode 100644
index 000000000000..05b23dcd788a
--- /dev/null
+++ b/sys-devel/m4/files/digest-m4-1.4
@@ -0,0 +1,2 @@
+MD5 9eb2dd07740b2d2f3c7adb3e8d299bda m4-1.4.tar.gz 317588
+MD5 dd3b693906f1a69319d8b99b914df25b m4_1.4-15.diff.gz 5538
diff --git a/sys-devel/m4/m4-1.4.ebuild b/sys-devel/m4/m4-1.4.ebuild
new file mode 100644
index 000000000000..915714909d3a
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.ebuild,v 1.1 2003/03/09 17:28:30 azarah Exp $
+
+IUSE="nls"
+
+inherit eutils gnuconfig
+
+S="${WORKDIR}/${PN}-1.4"
+DESCRIPTION="GNU macro processor"
+SRC_URI="ftp://ftp.seindal.dk/gnu/${PN}-1.4.tar.gz
+ http://ftp.debian.org/debian/pool/main/m/m4/m4_1.4-15.diff.gz"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+
+DEPEND="virtual/glibc
+ sys-devel/perl
+ nls? ( sys-devel/gettext )
+ >=sys-devel/libtool-1.3.5-r2"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${DISTDIR}/${PN}_1.4-15.diff.gz
+
+ use alpha && gnuconfig_update
+}
+
+src_compile() {
+ local myconf=
+
+ use nls || myconf="--disable-nls"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --enable-changeword \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+# rm -rf ${D}/usr/include
+
+ dodoc AUTHORS BACKLOG ChangeLog COPYING NEWS README* THANKS TODO
+}
+