summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-16 04:03:19 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-16 04:03:19 +0000
commitfd762703ccdc48ba97c2f50eba23a6ca4621dc39 (patch)
treef54ec1929e14775a830d0f4090d99c762bf9212b /sys-devel/libtool/libtool-1.5.6.ebuild
parentver bump #55918 (diff)
downloadhistorical-fd762703ccdc48ba97c2f50eba23a6ca4621dc39.tar.gz
historical-fd762703ccdc48ba97c2f50eba23a6ca4621dc39.tar.bz2
historical-fd762703ccdc48ba97c2f50eba23a6ca4621dc39.zip
Fix all the gnuconfig_update screwiness in these ebuilds #57224
Diffstat (limited to 'sys-devel/libtool/libtool-1.5.6.ebuild')
-rw-r--r--sys-devel/libtool/libtool-1.5.6.ebuild22
1 files changed, 5 insertions, 17 deletions
diff --git a/sys-devel/libtool/libtool-1.5.6.ebuild b/sys-devel/libtool/libtool-1.5.6.ebuild
index 99e82684f6eb..7374538876d3 100644
--- a/sys-devel/libtool/libtool-1.5.6.ebuild
+++ b/sys-devel/libtool/libtool-1.5.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.6.ebuild,v 1.4 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.6.ebuild,v 1.5 2004/07/16 04:03:19 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig
@@ -70,8 +70,6 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
epatch ${FILESDIR}/ltconfig-uclibc.patch
- gnuconfig_update
-
cd ${S}
echo
# Install updated missing script
@@ -133,6 +131,10 @@ src_unpack() {
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"
+
+ # Run gnuconfig_update for both old and new versions *after* patches so we
+ # don't screw them up
+ gnuconfig_update ${WORKDIR}
}
src_compile() {
@@ -144,15 +146,6 @@ src_compile() {
cd ${OLD_S}
- # Detect mips/mips64
- gnuconfig_update
-
- # regen to allow for build,host,target ppc64
- gnuconfig_update
-
- # detect uclibc
- gnuconfig_update
-
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \
@@ -167,11 +160,6 @@ src_compile() {
cd ${S}
- # Detect mips/mips64
- gnuconfig_update
-
- gnuconfig_update
-
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
--prefix=/usr \