summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-01-13 19:13:57 +0000
committerMike Frysinger <vapier@gentoo.org>2012-01-13 19:13:57 +0000
commitfdd28c641adddc98e9ef783dcbadb63a5626b290 (patch)
treec10c9487b6db4267c41a95a36febf62cb9dc4840 /sys-devel/gdb/gdb-9999.ebuild
parentFix autoreconf with >=automake-1.11.2 wrt bug #397715 by Jason Mours <jason.m... (diff)
downloadhistorical-fdd28c641adddc98e9ef783dcbadb63a5626b290.tar.gz
historical-fdd28c641adddc98e9ef783dcbadb63a5626b290.tar.bz2
historical-fdd28c641adddc98e9ef783dcbadb63a5626b290.zip
Unify live/release ebuilds, and properly control zlib dep.
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index d90545495518..840dead190fe 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.7 2012/01/02 05:42:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.8 2012/01/13 19:13:57 vapier Exp $
EAPI="3"
@@ -50,15 +50,16 @@ SRC_URI="${SRC_URI} ${PATCH_VER:+mirror://gentoo/${P}-patches-${PATCH_VER}.tar.x
LICENSE="GPL-2 LGPL-2"
SLOT="0"
if [[ ${PV} != 9999* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
-IUSE="+client expat multitarget nls +python +server test vanilla"
+IUSE="+client expat multitarget nls +python +server test vanilla zlib"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
sys-libs/readline
expat? ( dev-libs/expat )
- python? ( =dev-lang/python-2* )"
+ python? ( =dev-lang/python-2* )
+ zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/yacc
@@ -119,6 +120,7 @@ src_configure() {
$(use_enable nls)
$(use multitarget && echo --enable-targets=all)
$(use_with python python "${EPREFIX}/usr/bin/python2")
+ $(use_with zlib)
)
fi
@@ -132,7 +134,7 @@ src_test() {
src_install() {
use server && ! use client && cd gdb/gdbserver
emake DESTDIR="${D}" install || die
- use client && { rm "${ED}"/usr/lib*/libiberty.a || die ; }
+ use client && { find "${ED}"/usr -name libiberty.a -delete || die ; }
cd "${S}"
# Don't install docs when building a cross-gdb