summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-09-24 16:43:08 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-09-24 16:43:08 +0000
commit86c961377d04ab42b8f39d607554a2b7a3ec3d2c (patch)
treeda9594f90d6a8bbeae808457cc971b02fdf41ae7 /sys-devel/distcc
parentFix bug 29511. Seems as if the depends were silently changed. (diff)
downloadhistorical-86c961377d04ab42b8f39d607554a2b7a3ec3d2c.tar.gz
historical-86c961377d04ab42b8f39d607554a2b7a3ec3d2c.tar.bz2
historical-86c961377d04ab42b8f39d607554a2b7a3ec3d2c.zip
Fix bug 29511. Seems as if the depends were silently changed.
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.11-r1.ebuild115
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.11-r11
3 files changed, 118 insertions, 2 deletions
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 39d795b5fc7a..41affe6d83d8 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,4 +1,4 @@
-MD5 274a93f9cbfb3a792a2c3c58fe1daeb0 ChangeLog 12958
+MD5 e94897c7d034a4e0444fd02bbd4df27f ChangeLog 13125
MD5 ff26d9e0a5f8d639aa1f2810187d9012 distcc-2.10-r1.ebuild 3489
MD5 a64395143382132b1a82f6d87016e21e distcc-2.10-r2.ebuild 3508
MD5 58d1c3a6aa178de53f9e352990c8ff23 distcc-2.10-r3.ebuild 3380
@@ -8,7 +8,7 @@ MD5 c68dd76338384f0a996204db7364f8f7 distcc-2.8-r2.ebuild 3357
MD5 f7332ba9718f262c2f3efb2f7f8945c7 distcc-2.9.ebuild 3445
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
MD5 434444ae4d6679a445b1640a32368278 distcc-2.11.ebuild 3420
-MD5 caed16c7b3825bbf31a88df4c27097aa distcc-2.11-r1.ebuild 3546
+MD5 2feb5ef608b6a01791939a04b33548a3 distcc-2.11-r1.ebuild 3549
MD5 996b45704fdf266745dfc2e6038a1f76 files/digest-distcc-2.10 64
MD5 996b45704fdf266745dfc2e6038a1f76 files/digest-distcc-2.10-r1 64
MD5 996b45704fdf266745dfc2e6038a1f76 files/digest-distcc-2.10-r2 64
diff --git a/sys-devel/distcc/distcc-2.11-r1.ebuild b/sys-devel/distcc/distcc-2.11-r1.ebuild
new file mode 100644
index 000000000000..f6708a3b7762
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.11-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.11-r1.ebuild,v 1.1 2003/09/24 16:43:05 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+PATCHLEVEL="2.11"
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="gnome"
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="gnome? ( >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. It saves a dependancy
+
+ use gtk && myconf="${myconf} --with-gnome"
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
+ $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ /usr/bin/distcc-config --set-env DISTCC_DIR ""
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.11-r1 b/sys-devel/distcc/files/digest-distcc-2.11-r1
new file mode 100644
index 000000000000..dadd02017bde
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.11-r1
@@ -0,0 +1 @@
+MD5 f3458779c13255d88ee89ea7ccddda29 distcc-2.11.tar.bz2 249365