summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2002-12-10 00:36:27 +0000
committerJon Portnoy <avenj@gentoo.org>2002-12-10 00:36:27 +0000
commitb9a6e80ae30da50d8144d0c4514bd98a7e503d8c (patch)
treef4b2c122c531bd846344e228be5c04cef38553dd /sys-devel/bison
parentUpdated per bug 11708 (diff)
downloadhistorical-b9a6e80ae30da50d8144d0c4514bd98a7e503d8c.tar.gz
historical-b9a6e80ae30da50d8144d0c4514bd98a7e503d8c.tar.bz2
historical-b9a6e80ae30da50d8144d0c4514bd98a7e503d8c.zip
Update to be icc-able with USE=icc
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog10
-rw-r--r--sys-devel/bison/bison-1.35.ebuild7
-rw-r--r--sys-devel/bison/bison-1.75.ebuild5
3 files changed, 16 insertions, 6 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index f5ae1d891489..3bcd77e40085 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-devel/bison
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.7 2002/12/09 04:37:27 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.8 2002/12/10 00:36:27 avenj Exp $
\* Autoupdate keywords (12-6-02)
06 Dec 2002; Rodney Rees <manson@gentoo.org> changed sparc ~sparc keywords
@@ -12,6 +12,10 @@
20 Oct 2002; Martin Schlemmer <azarah@gentoo.org> : Update version.
+ 09 Dec 2002; Jon Portnoy <avenj@gentoo.org> :
+
+ Update to be icc-able with USE=icc.
+
*bison-1.35 (09 Aug 2002)
16 Aug 2002; Seemant Kulleen <seemant@gentoo.org> bison-1.35.ebuild :
@@ -26,6 +30,10 @@
Version bump to newest stable, which fixes issues with the spanish
language environment.
+ 09 Dec 2002; Jon Portnoy <avenj@gentoo.org> bison-1.35.ebuild :
+
+ Update to be icc-able with USE=icc.
+
*bison-1.34-r1 (2 Apr 2002)
2 Apr 2002; M.Schlemmer <azarah@gentoo.org> :
diff --git a/sys-devel/bison/bison-1.35.ebuild b/sys-devel/bison/bison-1.35.ebuild
index 380ed5122868..7f5e456e6be0 100644
--- a/sys-devel/bison/bison-1.35.ebuild
+++ b/sys-devel/bison/bison-1.35.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.35.ebuild,v 1.6 2002/12/09 04:37:27 manson Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.35.ebuild,v 1.7 2002/12/10 00:36:27 avenj Exp $
-IUSE="nls static build"
+IUSE="nls static build icc"
S=${WORKDIR}/${P}
DESCRIPTION="A yacc-compatible parser generator"
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gnu.org/pub/gnu/bison/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc alpha"
+KEYWORDS="x86 ppc sparc alpha"
DEPEND="nls? ( sys-devel/gettext )"
@@ -21,6 +21,7 @@ src_compile() {
then
myconf="--disable-nls"
fi
+ use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
./configure --prefix=/usr \
--datadir=/usr/share \
diff --git a/sys-devel/bison/bison-1.75.ebuild b/sys-devel/bison/bison-1.75.ebuild
index 08592dc7beb9..d65173915c31 100644
--- a/sys-devel/bison/bison-1.75.ebuild
+++ b/sys-devel/bison/bison-1.75.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.75.ebuild,v 1.3 2002/10/20 21:26:48 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.75.ebuild,v 1.4 2002/12/10 00:36:27 avenj Exp $
-IUSE="nls static build"
+IUSE="nls static build icc"
S="${WORKDIR}/${P}"
DESCRIPTION="A yacc-compatible parser generator"
@@ -18,6 +18,7 @@ DEPEND="nls? ( sys-devel/gettext )"
src_compile() {
+ use icc && CC="iccbin" CXX="iccbin" LD="iccbin"
local myconf=""
use nls || myconf="--disable-nls"