summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-01-17 02:06:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-01-17 02:06:55 +0000
commit77f1fb11bb50fffcdf8fbabc93d4668a18f0cc9d (patch)
treec4b6e8ba8c97ad4849aea9bd3a1370dcdb7ab88e /sys-devel/binutils-bfin/files
parentremove outdated changelog reference (diff)
downloadhistorical-77f1fb11bb50fffcdf8fbabc93d4668a18f0cc9d.tar.gz
historical-77f1fb11bb50fffcdf8fbabc93d4668a18f0cc9d.tar.bz2
historical-77f1fb11bb50fffcdf8fbabc93d4668a18f0cc9d.zip
Fix elf2flt support.
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'sys-devel/binutils-bfin/files')
-rw-r--r--sys-devel/binutils-bfin/files/digest-binutils-bfin-2005.4_rc11
-rw-r--r--sys-devel/binutils-bfin/files/elf2flt-configure-ldscript-path.patch113
2 files changed, 113 insertions, 1 deletions
diff --git a/sys-devel/binutils-bfin/files/digest-binutils-bfin-2005.4_rc1 b/sys-devel/binutils-bfin/files/digest-binutils-bfin-2005.4_rc1
index 7ebd60244694..4cecc20a673c 100644
--- a/sys-devel/binutils-bfin/files/digest-binutils-bfin-2005.4_rc1
+++ b/sys-devel/binutils-bfin/files/digest-binutils-bfin-2005.4_rc1
@@ -1,2 +1 @@
MD5 b1a60d6d5fffbc0af642c6554a7cea0f bfin-gcc-3.4.05r4-2.tar.gz 55042813
-MD5 b4f9e872d7a9c028017d38f90268ba35 elf2flt-20060111.tar.bz2 97522
diff --git a/sys-devel/binutils-bfin/files/elf2flt-configure-ldscript-path.patch b/sys-devel/binutils-bfin/files/elf2flt-configure-ldscript-path.patch
new file mode 100644
index 000000000000..edbd0a764c1a
--- /dev/null
+++ b/sys-devel/binutils-bfin/files/elf2flt-configure-ldscript-path.patch
@@ -0,0 +1,113 @@
+--- elf2flt/Makefile.in
++++ elf2flt/Makefile.in
+@@ -13,7 +13,7 @@ TARGET = @target_alias@
+ CFLAGS = @CFLAGS@
+ INCLUDES = @bfd_include_dir@ @binutils_include_dir@
+ CPPFLAGS = @CPPFLAGS@
+-LDFLAGS = @LDFLAGS@ -static
++LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ INSTALL = @INSTALL@
+ DEFS = @DEFS@ -DTARGET_$(CPU)
+--- elf2flt/configure
++++ elf2flt/configure
+@@ -20,6 +20,8 @@
+ ac_help="$ac_help
+ --with-binutils-include-dir=<dir> include path for binutils headers "
+ ac_help="$ac_help
++ --with-binutils-ldscript-dir=<dir> path to install elf2flt.ld "
++ac_help="$ac_help
+ --disable-got-check - disable check for GOT (needed on H8) "
+
+ # Initialize some variables set by options.
+@@ -572,6 +574,16 @@
+ fi
+
+
++# Check whether --with-binutils-ldscript-dir or --without-binutils-ldscript-dir was given.
++if test "${with_binutils_ldscript_dir+set}" = set; then
++ withval="$with_binutils_ldscript_dir"
++ ac_binutils_ldscript_dir=$withval
++else
++ ac_binutils_ldscript_dir=NONE
++
++fi
++
++
+ # Check whether --enable-got-check or --disable-got-check was given.
+ if test "${enable_got_check+set}" = set; then
+ enableval="$enable_got_check"
+@@ -1049,6 +1061,12 @@
+ binutils_include_dir="-I$ac_binutils_include_dir"
+ fi
+
++binutils_ldscript_dir=
++if test "$ac_binutils_ldscript_dir" = "NONE"; then
++ ac_binutils_ldscript_dir="\${TOOLDIR}/../${target_alias}/lib"
++fi
++binutils_ldscript_dir="$ac_binutils_ldscript_dir"
++
+ if test "$ac_libbfd" = "NONE" -o "$ac_libiberty" = "NONE" ; then
+ echo
+ echo "You need to specify the location of the libfd.a and libiberty.a"
+@@ -1653,6 +1672,7 @@
+ s%@CPP@%$CPP%g
+ s%@bfd_include_dir@%$bfd_include_dir%g
+ s%@binutils_include_dir@%$binutils_include_dir%g
++s%@binutils_ldscript_dir@%$binutils_ldscript_dir%g
+ s%@got_check@%$got_check%g
+
+ CEOF
+--- elf2flt/configure.in
++++ elf2flt/configure.in
+@@ -25,6 +25,12 @@ AC_ARG_WITH(binutils-include-dir,
+ [ ac_binutils_include_dir=NONE ]
+ )
+
++AC_ARG_WITH(binutils-ldscript-dir,
++ [ --with-binutils-ldscript-dir=<dir> path to install elf2flt.ld ],
++ [ ac_binutils_ldscript_dir=$withval ],
++ [ ac_binutils_ldscript_dir=NONE ]
++)
++
+ AC_ARG_ENABLE(got-check,
+ [ --disable-got-check - disable check for GOT (needed on H8) ],
+ [ got_check=$enableval ],
+@@ -62,6 +68,12 @@ if test "$ac_binutils_include_dir" != "N
+ binutils_include_dir="-I$ac_binutils_include_dir"
+ fi
+
++binutils_ldscript_dir=
++if test "$ac_binutils_ldscript_dir" = "NONE"; then
++ ac_binutils_ldscript_dir="\${TOOLDIR}/../${target_alias}/lib"
++fi
++binutils_ldscript_dir="$ac_binutils_ldscript_dir"
++
+ if test "$ac_libbfd" = "NONE" -o "$ac_libiberty" = "NONE" ; then
+ echo
+ echo "You need to specify the location of the libfd.a and libiberty.a"
+@@ -108,6 +120,7 @@ AC_SUBST(target_os)
+ AC_SUBST(target_vendor)
+ AC_SUBST(bfd_include_dir)
+ AC_SUBST(binutils_include_dir)
++AC_SUBST(binutils_ldscript_dir)
+ AC_SUBST(got_check)
+
+ AC_OUTPUT(Makefile ld-elf2flt)
+--- elf2flt/ld-elf2flt.in
++++ elf2flt/ld-elf2flt.in
+@@ -15,12 +15,12 @@
+ LINKER="$0.real" # the original renamed-linker
+ ELF2FLT="`expr $0 : '\(.*\)ld'`elf2flt"
+ TOOLDIR="`dirname $0`" # let gcc find the tools for us
+-LDSCRIPTPATH="${TOOLDIR}/../@target_alias@/lib" # and the scripts
++LDSCRIPTPATH="@binutils_ldscript_dir@" # and the scripts
+ SHARED_ID=""
+ NEWLDSCRIPT=""
+
+ # check TOOLDIR from prefix/bin/ or prefix/target-alias/bin/
+-[ -d "${TOOLDIR}/../@target_alias@/lib" ] || LDSCRIPTPATH="${TOOLDIR}/../lib"
++[ -d "${LDSCRIPTPATH}" ] || LDSCRIPTPATH="${TOOLDIR}/../lib"
+
+ #
+ # if we have the elf2flt options, run it