summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-07-10 11:13:32 +0000
committerMichael Imhof <tantive@gentoo.org>2003-07-10 11:13:32 +0000
commit0c39aa5d18c42fef11ea751cacc903641dfe4ad6 (patch)
tree45586fbcff39b1f9ac58b7296d09b38fec8ef674 /sys-cluster/pvm
parentShould close #24197. (diff)
downloadhistorical-0c39aa5d18c42fef11ea751cacc903641dfe4ad6.tar.gz
historical-0c39aa5d18c42fef11ea751cacc903641dfe4ad6.tar.bz2
historical-0c39aa5d18c42fef11ea751cacc903641dfe4ad6.zip
Should close #24197.
Diffstat (limited to 'sys-cluster/pvm')
-rw-r--r--sys-cluster/pvm/Manifest4
-rw-r--r--sys-cluster/pvm/files/digest-pvm-3.4.4-r11
-rw-r--r--sys-cluster/pvm/files/pvm-3.4.4-gentoo.diff18
-rw-r--r--sys-cluster/pvm/pvm-3.4.4-r1.ebuild63
4 files changed, 84 insertions, 2 deletions
diff --git a/sys-cluster/pvm/Manifest b/sys-cluster/pvm/Manifest
index edc41f75cde7..33182ec8b610 100644
--- a/sys-cluster/pvm/Manifest
+++ b/sys-cluster/pvm/Manifest
@@ -1,6 +1,6 @@
-MD5 e8ca5524f5bc5a7fd3b57b523ff9db08 ChangeLog 461
+MD5 3c214c86c2c560189674c4da50dd4484 ChangeLog 462
MD5 df4a94a51f5b47e4d1eaba74355998d8 pvm-3.4.4.ebuild 994
MD5 3aef1438820897ee1a62860abaec7a52 pvm-3.4.4-r1.ebuild 1083
MD5 c6d622987f4e06f522dcbc72cff9127d files/digest-pvm-3.4.4 57
-MD5 98cb28a5dda549bbcd7e1dbe6de672b6 files/pvm-3.4.4-gentoo.diff 583
+MD5 726a6a69ba5fb9e140e8f7e1a85c9c9d files/pvm-3.4.4-gentoo.diff 608
MD5 c6d622987f4e06f522dcbc72cff9127d files/digest-pvm-3.4.4-r1 57
diff --git a/sys-cluster/pvm/files/digest-pvm-3.4.4-r1 b/sys-cluster/pvm/files/digest-pvm-3.4.4-r1
new file mode 100644
index 000000000000..d82d614afdd9
--- /dev/null
+++ b/sys-cluster/pvm/files/digest-pvm-3.4.4-r1
@@ -0,0 +1 @@
+MD5 806abe9a866eab5981383c17ff9ed175 pvm3.4.4.tgz 967852
diff --git a/sys-cluster/pvm/files/pvm-3.4.4-gentoo.diff b/sys-cluster/pvm/files/pvm-3.4.4-gentoo.diff
new file mode 100644
index 000000000000..dfe5af27e80f
--- /dev/null
+++ b/sys-cluster/pvm/files/pvm-3.4.4-gentoo.diff
@@ -0,0 +1,18 @@
+diff -ur test/pvm3/src/lpvmgen.c pvm3/src/lpvmgen.c
+--- pvm3/src/lpvmgen.c 2001-09-27 01:35:43.000000000 +0200
++++ pvm3/src/lpvmgen.c 2003-07-05 20:16:49.000000000 +0200
+@@ -1,4 +1,4 @@
+-
++#define USESTRERROR
+ static char rcsid[] =
+ "$Id: pvm-3.4.4-gentoo.diff,v 1.1 2003/07/10 11:13:17 tantive Exp $";
+
+diff -ur test/pvm3/src/pvmlog.c pvm3/src/pvmlog.c
+--- pvm3/src/pvmlog.c 2001-09-26 23:23:56.000000000 +0200
++++ pvm3/src/pvmlog.c 2003-07-05 20:28:21.000000000 +0200
+@@ -1,4 +1,4 @@
+-
++#define USESTRERROR
+ static char rcsid[] =
+ "$Id: pvm-3.4.4-gentoo.diff,v 1.1 2003/07/10 11:13:17 tantive Exp $";
+
diff --git a/sys-cluster/pvm/pvm-3.4.4-r1.ebuild b/sys-cluster/pvm/pvm-3.4.4-r1.ebuild
new file mode 100644
index 000000000000..a2f1945b1314
--- /dev/null
+++ b/sys-cluster/pvm/pvm-3.4.4-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S=${WORKDIR}/pvm-${PV}
+DESCRIPTION="PVM: Parallel Virtual Machine"
+SRC_URI="ftp.netlib.org/pvm3/pvm${PV}.tgz"
+HOMEPAGE="http://www.epm.ornl.gov/pvm/pvm_home.html"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~alpha"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 <${FILESDIR}/pvm-3.4.4-gentoo.diff || die
+}
+
+
+
+src_compile() {
+ cd ${WORKDIR}/pvm3
+
+ export PVM_ROOT=${WORKDIR}"/pvm3"
+
+ emake || die
+}
+
+src_install() {
+ cd ${WORKDIR}/pvm3
+
+ dodir /usr/share/man
+ rm man/man1 -fr
+ mv man/man3 ${D}/usr/share/man/
+ prepallman
+
+ dodoc Readme
+
+ #installs the rest of pvm
+
+ dodir /usr/local/pvm3
+ cp -r * ${D}/usr/local/pvm3
+
+ #environment variables:
+
+ touch 98pvm
+ echo PVM_ROOT=/usr/local/pvm3 >98pvm
+ echo PVM_ARCH=LINUX >>98pvm
+ insinto /etc/env.d
+ doins 98pvm
+
+}
+
+pkg_postinst() {
+ ewarn "Environment Variables have changed. Do not forget to reboot or perform"
+ ewarn "source /etc/profile before using pvm !"
+}
+