summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-03-29 07:38:45 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-03-29 07:38:45 +0000
commit5fe89dd532a3ebfaa1ebc8beedab18874e2d1bcd (patch)
treea87a176ff6e00883913aa1a9c30c33ff80ccb23e /sys-cluster/mpich
parentFix digest (diff)
downloadhistorical-5fe89dd532a3ebfaa1ebc8beedab18874e2d1bcd.tar.gz
historical-5fe89dd532a3ebfaa1ebc8beedab18874e2d1bcd.tar.bz2
historical-5fe89dd532a3ebfaa1ebc8beedab18874e2d1bcd.zip
updated to present release version,
as well as made it actually compile and install stuff properly...
Diffstat (limited to 'sys-cluster/mpich')
-rw-r--r--sys-cluster/mpich/ChangeLog7
-rw-r--r--sys-cluster/mpich/files/digest-mpich-1.2.51
-rw-r--r--sys-cluster/mpich/mpich-1.2.5.ebuild76
3 files changed, 83 insertions, 1 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
index d00f9f318215..3b72db662020 100644
--- a/sys-cluster/mpich/ChangeLog
+++ b/sys-cluster/mpich/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-cluster/mpich
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.3 2003/02/12 09:12:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.4 2003/03/29 07:38:45 george Exp $
+*mpich-1.2.5 (28 Mar 2003)
+
+ 28 Mar 2003; George Shapovalov <george@gentoo.org> mpich-1.2.5.ebuild :
+ new version,
+ made ebuild actually compile stuff and install it properly.. (see #10345)
*mpich-1.2.4 (05 Nov 2002)
diff --git a/sys-cluster/mpich/files/digest-mpich-1.2.5 b/sys-cluster/mpich/files/digest-mpich-1.2.5
new file mode 100644
index 000000000000..da880c59243f
--- /dev/null
+++ b/sys-cluster/mpich/files/digest-mpich-1.2.5
@@ -0,0 +1 @@
+MD5 e10f2fde92b6c3264eeb00fdefbb09f1 mpich-1.2.5.tar.gz 12573526
diff --git a/sys-cluster/mpich/mpich-1.2.5.ebuild b/sys-cluster/mpich/mpich-1.2.5.ebuild
new file mode 100644
index 000000000000..18c5ce125107
--- /dev/null
+++ b/sys-cluster/mpich/mpich-1.2.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.5.ebuild,v 1.1 2003/03/29 07:38:45 george Exp $
+
+S=${WORKDIR}/mpich-${PV}
+DESCRIPTION="MPICH - A portable MPI implementation"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/mpich-${PV}.tar.gz"
+HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND="net-misc/openssh"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ mv romioinstall.in romioinstall.in-orig
+ sed -e "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in-orig >romioinstall.in
+}
+
+src_compile() {
+ #looks like P is one of used vars, need to wrap around build...
+ local PSave
+ PSave=${P}
+ unset P
+ ./configure \
+ --mandir=/usr/share/man \
+ --prefix=/usr || die
+ make || die
+ P=${PSave}
+}
+
+src_install() {
+ dodir /usr/sbin
+ dodir /usr/local/bin
+
+ #mangle P here as well..
+ local PSave
+ PSave=${P}
+ unset P
+
+ #mpic install process is really weird, need to do some hand work perheaps
+
+ #to skip installation of man pages, uncomment following line
+ #export MPIINSTALL_OPTS=-noman
+
+ ./bin/mpiinstall -prefix=${D}/usr || die
+
+ P=${PSave}
+
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/doc/* ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/doc/
+
+ dodir /etc/mpich
+ mv ${D}/usr/etc/* ${D}/etc/mpich/
+ rmdir ${D}/usr/etc/
+
+ dodir /usr/share/${PN}
+ mv ${D}/usr/examples ${D}/usr/share/${PN}/examples1
+ mv ${D}/usr/share/examples ${D}/usr/share/${PN}/examples2
+
+ rm -rf ${D}/usr/local
+ rm -f ${D}/usr/man/mandesc
+
+ mv ${D}/usr/share/{machines*,jumpshot-3,Makefile.sample,upshot} ${D}/usr/share/${PN}
+
+ dodoc COPYING README
+ mv ${D}/usr/www ${D}/usr/share/doc/${PF}/html
+}
+