summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Moss <robmoss@gentoo.org>2004-08-24 00:05:44 +0000
committerRobert Moss <robmoss@gentoo.org>2004-08-24 00:05:44 +0000
commitedb2c8162ba9aaf567ac979f4c612b3c92d873a4 (patch)
treed0e711c65a6e68e662c2c7b4676ec991b4c2b8be /sys-boot
parentVersion bump. Closes bug #61115. (diff)
downloadhistorical-edb2c8162ba9aaf567ac979f4c612b3c92d873a4.tar.gz
historical-edb2c8162ba9aaf567ac979f4c612b3c92d873a4.tar.bz2
historical-edb2c8162ba9aaf567ac979f4c612b3c92d873a4.zip
New grub ebuild, server- and uclibc-friendly, with added bugfix goodness
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/grub/ChangeLog8
-rw-r--r--sys-boot/grub/Manifest6
-rw-r--r--sys-boot/grub/files/digest-grub-0.95.200408232
-rw-r--r--sys-boot/grub/grub-0.95.20040823.ebuild125
-rw-r--r--sys-boot/grub/metadata.xml3
5 files changed, 141 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 097f256dcf0b..09854764499c 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/grub
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.20 2004/08/22 17:50:22 robmoss Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.21 2004/08/24 00:05:44 robmoss Exp $
+
+*grub-0.95.20040823 (24 Aug 2004)
+
+ 24 Aug 2004; <rmoss@gentoo.org> metadata.xml, +grub-0.95.20040823.ebuild:
+ Initial commit of grub-0.95 with CVS snapshot update. Supports (amongst other
+ things) savedefault (server-friendly feature) and uclibc (I hope...).
*grub-0.94-r2 (22 Aug 2004)
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index f70ada2116cc..bef6e7a0b668 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -1,9 +1,11 @@
MD5 b33a30955cdcfd9e2f0fbc11ef8c1945 grub-0.94-r1.ebuild 3388
MD5 d2c5f3ba084defee6f806a4eab5d3e36 grub-0.92-r1.ebuild 2526
MD5 31d6e6382d1e08bfd4037a99fb29a2d0 grub-0.94-r2.ebuild 3501
-MD5 a5f04de6d9aa9871bac89cdbb8b48125 ChangeLog 9520
+MD5 59ca1f46bdd9b0c08e5398f1248fe067 ChangeLog 9784
MD5 fc967cbfa21d5efadccfe2146dfa03df grub-0.93.20030118.ebuild 2512
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 b0eacbb6edb031d87f33ed0b08f5916d metadata.xml 226
+MD5 2b5779a79d6040227ac8be17221db023 grub-0.95.20040823.ebuild 3516
+MD5 3a653f86b731c2a17482d25f57b2d041 files/digest-grub-0.95.20040823 149
MD5 cdd6c89d48982ecd544c0b4774755afd files/splash.xpm.gz 33856
MD5 e9e73f57d9f9d5c550792980b2635f94 files/grub-0.94-gcc3.4.patch 479
MD5 7357395b0d223c0bbf0675a9af31f9c3 files/grub-0.94-grub.conf.patch 7574
diff --git a/sys-boot/grub/files/digest-grub-0.95.20040823 b/sys-boot/grub/files/digest-grub-0.95.20040823
new file mode 100644
index 000000000000..c8246ab022ba
--- /dev/null
+++ b/sys-boot/grub/files/digest-grub-0.95.20040823
@@ -0,0 +1,2 @@
+MD5 6867cf182a3cf1e6a214b41f0370b7eb grub-0.95.20040823.tar.gz 921128
+MD5 7d0c1f5a474a8877a6f38edc4599030a grub-0.95.20040823-splash.patch.bz2 40226
diff --git a/sys-boot/grub/grub-0.95.20040823.ebuild b/sys-boot/grub/grub-0.95.20040823.ebuild
new file mode 100644
index 000000000000..82ab0526ca43
--- /dev/null
+++ b/sys-boot/grub/grub-0.95.20040823.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.95.20040823.ebuild,v 1.1 2004/08/24 00:05:44 robmoss Exp $
+
+inherit mount-boot eutils flag-o-matic gcc gnuconfig
+
+DESCRIPTION="GNU GRUB boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/${P}-splash.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="static"
+
+DEPEND=">=sys-libs/ncurses-5.2-r5
+ >=sys-devel/autoconf-2.5"
+PROVIDE="virtual/bootloader"
+
+src_unpack() {
+ has_m32 || die "your compiler seems to be unable to compile 32bit code. if you are on amd64, make sure you compile gcc with USE=multilib FEATURES=-sandbox"
+
+ unpack ${A}
+ cd ${S}
+
+ epatch ${WORKDIR}/${P}-splash.patch
+ #epatch ${FILESDIR}/${P}-gcc3.4.patch
+
+ # Trying to get rid of the need for the ugly menu.lst -> grub.conf symlink
+ #epatch ${FILESDIR}/${P}-grub.conf.patch
+
+ # This patchset is from SuSE -- hopefully fixes the acl symlink issue
+ # And should add some boot prettification
+ # epatch ${WORKDIR}/${PF}-gentoo.diff
+ # epatch ${FILESDIR}/${P}-test.patch
+}
+
+src_compile() {
+ ### i686-specific code in the boot loader is a bad idea; disabling to ensure
+ ### at least some compatibility if the hard drive is moved to an older or
+ ### incompatible system.
+ unset CFLAGS
+
+ filter-ldflags -pie
+ append-flags -DNDEBUG
+ [ `gcc-major-version` -eq 3 ] && append-flags -minline-all-stringops
+ use static && append-ldflags -static
+
+ has_pie && CC="${CC} `test_flag -fno-pic` `test_flag -nopie`"
+ has_ssp && CC="${CC} `test_flag -fno-stack-protector`"
+
+ gnuconfig_update
+
+ autoconf || die
+ aclocal || die
+ automake || die
+
+ # build the net-bootable grub first
+ CFLAGS="" \
+ econf \
+ --datadir=/usr/lib/grub \
+ --exec-prefix=/ \
+ --disable-auto-linux-mem-opt \
+ --enable-diskless \
+ --enable-{3c{5{03,07,09,29,95},90x},cs89x0,davicom,depca,eepro{,100}} \
+ --enable-{epic100,exos205,ni5210,lance,ne2100,ni{50,65}10,natsemi} \
+ --enable-{ne,ns8390,wd,otulip,rtl8139,sis900,sk-g16,smc9000,tiara} \
+ --enable-{tulip,via-rhine,w89c840} || die
+
+ emake w89c840_o_CFLAGS="-O" || die "making netboot stuff"
+
+ mv stage2/{nbgrub,pxegrub} ${S}
+ mv stage2/stage2 stage2/stage2.netboot
+
+ make clean || die
+
+ # now build the regular grub
+ CFLAGS="${CFLAGS}" \
+ econf \
+ --datadir=/usr/lib/grub \
+ --exec-prefix=/ \
+ --disable-auto-linux-mem-opt || die
+ emake || die "making regular stuff"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ exeinto /usr/lib/grub
+ doexe nbgrub pxegrub stage2/stage2 stage2/stage2.netboot
+
+ insinto /boot/grub
+ doins ${FILESDIR}/splash.xpm.gz
+ newins docs/menu.lst grub.conf.sample
+
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
+ newdoc docs/menu.lst grub.conf.sample
+}
+
+pkg_postinst() {
+ [ "$ROOT" != "/" ] && return 0
+
+ # change menu.lst to grub.conf
+ if [ ! -e /boot/grub/grub.conf -a -e /boot/grub/menu.lst ]
+ then
+ mv /boot/grub/menu.lst /boot/grub/grub.conf
+ ewarn
+ ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
+ ewarn
+ fi
+ einfo "Linking from new grub.conf name to menu.lst"
+ ln -s grub.conf /boot/grub/menu.lst
+
+ [ -e /boot/grub/stage2 ] && mv /boot/grub/stage2{,.old}
+
+ einfo "Copying files from /usr/lib/grub to /boot"
+ cp -p /usr/lib/grub/* /boot/grub
+ cp -p /lib/grub/*/* /boot/grub
+
+ [ -e /boot/grub/grub.conf ] \
+ && /usr/sbin/grub \
+ --batch \
+ --device-map=/boot/grub/device.map \
+ < /boot/grub/grub.conf > /dev/null 2>&1
+}
diff --git a/sys-boot/grub/metadata.xml b/sys-boot/grub/metadata.xml
index 96a2d586367d..bea8a124fab7 100644
--- a/sys-boot/grub/metadata.xml
+++ b/sys-boot/grub/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
+<maintainer>
+ <email>robmoss@gentoo.org</email>
+</maintainer>
</pkgmetadata>