summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn P. Davis <zhen@gentoo.org>2004-10-06 05:57:48 +0000
committerJohn P. Davis <zhen@gentoo.org>2004-10-06 05:57:48 +0000
commit5eeac317ddc25d42398e29457ab63456d579fd73 (patch)
treed0689de5fcd0d6e148c499bc5f50dd0a383309ae /sys-boot
parentminor fix (diff)
downloadhistorical-5eeac317ddc25d42398e29457ab63456d579fd73.tar.gz
historical-5eeac317ddc25d42398e29457ab63456d579fd73.tar.bz2
historical-5eeac317ddc25d42398e29457ab63456d579fd73.zip
code cleanup
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/netboot/ChangeLog8
-rw-r--r--sys-boot/netboot/Manifest4
-rw-r--r--sys-boot/netboot/netboot-0.9.8.ebuild18
3 files changed, 16 insertions, 14 deletions
diff --git a/sys-boot/netboot/ChangeLog b/sys-boot/netboot/ChangeLog
index 04c08143873d..db0cff203e35 100644
--- a/sys-boot/netboot/ChangeLog
+++ b/sys-boot/netboot/ChangeLog
@@ -1,3 +1,9 @@
# ChangeLog for sys-boot/netboot
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/ChangeLog,v 1.1 2004/10/06 05:40:12 zhen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/ChangeLog,v 1.2 2004/10/06 05:57:48 zhen Exp $
+
+*netboot-0.9.8 (06 Oct 2004)
+
+ 06 Oct 2004; John Davis <zhen@gentoo.org> netboot-0.9.8.ebuild:
+ cleaned up the code
+
diff --git a/sys-boot/netboot/Manifest b/sys-boot/netboot/Manifest
index 9bad64804fe8..0737655799ca 100644
--- a/sys-boot/netboot/Manifest
+++ b/sys-boot/netboot/Manifest
@@ -1,4 +1,4 @@
MD5 d86e5b5e47260e5a965eae2afe6d6d40 metadata.xml 159
-MD5 f61f16fc4c10b32c9b87a825ca5c6048 ChangeLog 202
-MD5 6ec198e17c80968df68934adf80044c1 netboot-0.9.8.ebuild 641
+MD5 37430839b3970aef48bf179a5afa24e3 ChangeLog 322
+MD5 1b827ab983ec791f32e891fc84e3874f netboot-0.9.8.ebuild 683
MD5 f7b31adec25510c7cc11490f8cf95e55 files/digest-netboot-0.9.8 65
diff --git a/sys-boot/netboot/netboot-0.9.8.ebuild b/sys-boot/netboot/netboot-0.9.8.ebuild
index 3d5415449d6e..5e09b312e2d1 100644
--- a/sys-boot/netboot/netboot-0.9.8.ebuild
+++ b/sys-boot/netboot/netboot-0.9.8.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/netboot-0.9.8.ebuild,v 1.1 2004/10/06 05:40:12 zhen Exp $
-
-inherit eutils
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/netboot/netboot-0.9.8.ebuild,v 1.2 2004/10/06 05:57:48 zhen Exp $
DESCRIPTION="x86 specific netbooting utility"
HOMEPAGE="http://netboot.sourceforge.net"
@@ -14,15 +12,13 @@ KEYWORDS="-* ~x86"
IUSE=""
DEPEND="sys-devel/autoconf"
-#RDEPEND=""
-
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
+RDEPEND=""
src_install() {
- einstall || die
+ # this method does not work thanks to a icky Makefile, so we use einstall instead
+ # DESTDIR="${D}" make install || die
+ einstall || die "einstall failed"
dodoc README version
- cp -a FlashCard ${D}/usr/share/doc/${P}
+ docinto FlashCard
+ dodoc FlashCard/*
}