summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-21 17:56:36 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-21 17:56:36 +0000
commit3df65d1e2441abe881c35376f916f68cd9023a9b (patch)
tree6ba971a5c0df52ea0c05ca5275c6d1f32d4e3ab6 /sys-boot
parentNew ebuild for gnu-efi with patches from Debian. Thanks to Matt Anderson in ... (diff)
downloadhistorical-3df65d1e2441abe881c35376f916f68cd9023a9b.tar.gz
historical-3df65d1e2441abe881c35376f916f68cd9023a9b.tar.bz2
historical-3df65d1e2441abe881c35376f916f68cd9023a9b.zip
New ebuild for gnu-efi with patches from Debian. Thanks to Matt Anderson in bug 38875
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/gnu-efi/Manifest3
-rw-r--r--sys-boot/gnu-efi/files/digest-gnu-efi-3.0a1
-rw-r--r--sys-boot/gnu-efi/files/gnu-efi-3.0a-lds.patch55
-rw-r--r--sys-boot/gnu-efi/gnu-efi-3.0a.ebuild35
4 files changed, 93 insertions, 1 deletions
diff --git a/sys-boot/gnu-efi/Manifest b/sys-boot/gnu-efi/Manifest
index 5be870d7e916..88e10f166e6c 100644
--- a/sys-boot/gnu-efi/Manifest
+++ b/sys-boot/gnu-efi/Manifest
@@ -1,3 +1,4 @@
-MD5 205874d79ba41c6150176102c2f8f873 gnu-efi-3.0a.ebuild 871
+MD5 ff7165d14081357d742b459d5e762384 gnu-efi-3.0a.ebuild 972
+MD5 82e60650f561ec8c112799203dcf71f3 ChangeLog 426
MD5 e87f254731b9fed618bbcb354e418d09 files/gnu-efi-3.0a-lds.patch 995
MD5 1eb72cb0bde1ae4bc61b4c9b4b6f5e27 files/digest-gnu-efi-3.0a 64
diff --git a/sys-boot/gnu-efi/files/digest-gnu-efi-3.0a b/sys-boot/gnu-efi/files/digest-gnu-efi-3.0a
new file mode 100644
index 000000000000..c0e9f5fd2a56
--- /dev/null
+++ b/sys-boot/gnu-efi/files/digest-gnu-efi-3.0a
@@ -0,0 +1 @@
+MD5 0f613e693cbc3f35ff1863ac23954baf gnu-efi-3.0a.tar.gz 119079
diff --git a/sys-boot/gnu-efi/files/gnu-efi-3.0a-lds.patch b/sys-boot/gnu-efi/files/gnu-efi-3.0a-lds.patch
new file mode 100644
index 000000000000..f16efdbcfcff
--- /dev/null
+++ b/sys-boot/gnu-efi/files/gnu-efi-3.0a-lds.patch
@@ -0,0 +1,55 @@
+--- gnu-efi-3.0a.orig/gnuefi/elf_ia32_efi.lds
++++ gnu-efi-3.0a/gnuefi/elf_ia32_efi.lds
+@@ -17,6 +17,7 @@
+ *(.rodata*)
+ *(.data)
+ *(.data1)
++ *(.data.*)
+ *(.sdata)
+ *(.got.plt)
+ *(.got)
+@@ -34,8 +35,13 @@
+ .rel :
+ {
+ *(.rel.data)
++ *(.rel.data.*)
+ *(.rel.got)
+ *(.rel.stab)
++ *(.data.rel.ro.local)
++ *(.data.rel.local)
++ *(.data.rel.ro)
++ *(.data.rel*)
+ }
+ . = ALIGN(4096);
+ .dynsym : { *(.dynsym) }
+@@ -46,4 +52,9 @@
+ {
+ *(.rel.reloc)
+ }
++ .ignored :
++ {
++ *(.eh_frame)
++ }
+ }
++
+--- gnu-efi-3.0a.orig/gnuefi/elf_ia64_efi.lds
++++ gnu-efi-3.0a/gnuefi/elf_ia64_efi.lds
+@@ -28,8 +28,7 @@
+ {
+ *(.rodata*)
+ *(.ctors)
+- *(.data)
+- *(.data1)
++ *(.data*)
+ *(.gnu.linkonce.d*)
+ *(.plabel) /* data whose relocs we want to ignore */
+ *(.IA_64.unwind)
+@@ -48,7 +47,7 @@
+ .rela :
+ {
+ *(.rela.text)
+- *(.rela.data)
++ *(.rela.data*)
+ *(.rela.sdata)
+ *(.rela.got)
+ *(.rela.gnu.linkonce.d*)
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild
new file mode 100644
index 000000000000..fec5b95f0ee4
--- /dev/null
+++ b/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/gnu-efi/gnu-efi-3.0a.ebuild,v 1.1 2004/01/21 17:56:28 agriffis Exp $
+
+DESCRIPTION="Library for build EFI Applications"
+SRC_URI="ftp://ftp.hpl.hp.com/pub/linux-ia64/gnu-efi-3.0a.tar.gz"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+
+KEYWORDS="~ia64 ~x86"
+SLOT="3"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="virtual/glibc" # don't think there's anything else
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die "failed to unpack"
+ epatch ${FILESDIR}/gnu-efi-3.0a-lds.patch || die "epatch failed"
+}
+
+src_compile() {
+ local iarch
+ case $ARCH in
+ ia64) iarch=ia64 ;;
+ x86) iarch=ia32 ;;
+ *) die "unknown architecture: $ARCH" ;;
+ esac
+ emake CC="${CC}" ARCH=${iarch} -j1 || die "emake failed"
+}
+
+src_install() {
+ make install INSTALLROOT=${D} || die "einstall failed"
+ dodoc README* ChangeLog
+}