summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-12-21 22:02:42 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-12-21 22:02:42 +0000
commit591db35a5509b983a6cb0c8765ed942b7f22036b (patch)
tree0e85b9508df9e5c488db341ad69b764652f23e9c /sys-auth/pam_pkcs11/pam_pkcs11-0.6.0-r1.ebuild
parentDon't prestrip files, and use -silent to make the build look nicer (diff)
downloadhistorical-591db35a5509b983a6cb0c8765ed942b7f22036b.tar.gz
historical-591db35a5509b983a6cb0c8765ed942b7f22036b.tar.bz2
historical-591db35a5509b983a6cb0c8765ed942b7f22036b.zip
Fix pcsc-lite flag, bug#202935, thanks to Roman Jõerand
Package-Manager: portage-2.1.4_rc10
Diffstat (limited to 'sys-auth/pam_pkcs11/pam_pkcs11-0.6.0-r1.ebuild')
-rw-r--r--sys-auth/pam_pkcs11/pam_pkcs11-0.6.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-auth/pam_pkcs11/pam_pkcs11-0.6.0-r1.ebuild b/sys-auth/pam_pkcs11/pam_pkcs11-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..0455bc380d3e
--- /dev/null
+++ b/sys-auth/pam_pkcs11/pam_pkcs11-0.6.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pkcs11/pam_pkcs11-0.6.0-r1.ebuild,v 1.1 2007/12/21 22:02:41 alonbl Exp $
+
+inherit eutils
+
+DESCRIPTION="PKCS11 Pam library"
+HOMEPAGE="http://www.opensc-project.org/pam_pkcs11"
+SRC_URI="http://www.opensc-project.org/files/pam_pkcs11/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="curl ldap pcsc-lite"
+
+DEPEND="
+ sys-libs/pam
+ curl? ( net-misc/curl )
+ ldap? ( net-nds/openldap )
+ pcsc-lite? ( sys-apps/pcsc-lite )
+ dev-libs/openssl"
+
+src_compile() {
+ econf \
+ $(use_with curl) \
+ $(use_with pcsc-lite) \
+ $(use_with ldap) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+
+ dodir /lib/security
+ dosym ../../usr/lib/security/pam_pkcs11.so /lib/security/
+
+ dodoc NEWS README
+}