summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-02 22:09:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-02 22:09:54 +0000
commit044667c897cda7ade76d256c817ac724680ef4f1 (patch)
tree26165cf9397fcf0f757aebfdafe14c17f561e52e /sys-auth/nss_ldap/nss_ldap-202.ebuild
parentManual Manifest commit. (diff)
downloadhistorical-044667c897cda7ade76d256c817ac724680ef4f1.tar.gz
historical-044667c897cda7ade76d256c817ac724680ef4f1.tar.bz2
historical-044667c897cda7ade76d256c817ac724680ef4f1.zip
Moved from net-libs/nss_ldap to sys-auth/nss_ldap.
Diffstat (limited to 'sys-auth/nss_ldap/nss_ldap-202.ebuild')
-rw-r--r--sys-auth/nss_ldap/nss_ldap-202.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-auth/nss_ldap/nss_ldap-202.ebuild b/sys-auth/nss_ldap/nss_ldap-202.ebuild
new file mode 100644
index 000000000000..ea16c520795f
--- /dev/null
+++ b/sys-auth/nss_ldap/nss_ldap-202.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss_ldap/nss_ldap-202.ebuild,v 1.1 2005/07/02 22:09:54 flameeyes Exp $
+
+inherit fixheadtails
+DESCRIPTION="NSS LDAP Module"
+HOMEPAGE="http://www.padl.com/OSS/nss_ldap.html"
+SRC_URI="ftp://ftp.padl.com/pub/${P}.tar.gz"
+
+DEPEND=">=net-nds/openldap-1.2.11"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="x86 sparc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ # fix head/tail stuff
+ ht_fix_file ${S}/Makefile.am ${S}/Makefile.in ${S}/depcomp ${S}/config.guess
+}
+
+src_compile() {
+
+ econf \
+ --enable-schema-mapping \
+ --enable-rfc2307bis \
+ --enable-extra-optimization || die
+
+ emake UNIX_CAN_BUILD_STATIC=0 \
+ OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+
+ dodir /usr/lib
+
+ make \
+ DESTDIR=${D} \
+ install || die
+
+ dosym /etc/openldap/ldap.conf /etc/ldap.conf
+
+ dodoc ldap.conf ANNOUNCE NEWS ChangeLog AUTHORS COPYING
+ dodoc CVSVersionInfo.txt README nsswitch.ldap
+}