summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-15 18:19:20 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-15 18:19:20 +0000
commite7ea509ba20565429094e2415a80e69223e3ca14 (patch)
treeb6d6ac211e6ec01ce25a6ac6a7e17022fbfe9272 /sys-apps
parentInitial import. (diff)
downloadhistorical-e7ea509ba20565429094e2415a80e69223e3ca14.tar.gz
historical-e7ea509ba20565429094e2415a80e69223e3ca14.tar.bz2
historical-e7ea509ba20565429094e2415a80e69223e3ca14.zip
local env var -> use flag
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/busybox/ChangeLog5
-rw-r--r--sys-apps/busybox/busybox-0.60.5-r1.ebuild8
-rw-r--r--sys-apps/tinylogin/ChangeLog5
-rw-r--r--sys-apps/tinylogin/tinylogin-1.4.ebuild9
4 files changed, 20 insertions, 7 deletions
diff --git a/sys-apps/busybox/ChangeLog b/sys-apps/busybox/ChangeLog
index 6f6b17556f0d..3857828760bc 100644
--- a/sys-apps/busybox/ChangeLog
+++ b/sys-apps/busybox/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-apps/busybox
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.13 2003/04/03 17:28:47 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/ChangeLog,v 1.14 2003/07/15 18:18:03 vapier Exp $
*busybox-0.60.3-r1 (03 Apr 2003)
@@ -9,6 +9,9 @@
*busybox-0.60.5-r1 (13 Jan 2003)
+ 15 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Change local env var to a local use flag.
+
13 Jan 2003; Nick Hadaway <raker@gentoo.org> busybox-0.60.5-r1.ebuild :
Added some logic for detection of uclibc which needs to be tested.
Please comment on bug #13517. 2 hours later: New local environment
diff --git a/sys-apps/busybox/busybox-0.60.5-r1.ebuild b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
index e9243042b113..7331149c70a4 100644
--- a/sys-apps/busybox/busybox-0.60.5-r1.ebuild
+++ b/sys-apps/busybox/busybox-0.60.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.5 2003/06/22 23:47:19 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/busybox/busybox-0.60.5-r1.ebuild,v 1.6 2003/07/15 18:18:03 vapier Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Utilities for rescue and embedded systems"
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.busybox.net"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 amd64"
-IUSE="static"
+IUSE="static uclibc"
DEPEND="virtual/glibc"
RDEPEND="!static? ${DEPEND}"
@@ -25,7 +25,7 @@ src_unpack() {
src_compile() {
local myconf
use static && myconf="${myconf} DOSTATIC=true"
- if [ "$LINK_LIBC" = "uclibc" ]; then
+ if [ `use uclibc` ]; then
myconf="${myconf} \
CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
USE_SYSTEM_PWD=false"
@@ -57,7 +57,7 @@ src_install() {
pkg_postinst() {
einfo ""
- einfo "Edit /usr/portage/sys-apps/busybox/files/Config.h and"
+ einfo "Edit /usr/portage/sys-apps/busybox/files/Config.h-${PV}-cd and"
einfo "re-emerge if you need to add/remove functionality in "
einfo "BusyBox."
einfo ""
diff --git a/sys-apps/tinylogin/ChangeLog b/sys-apps/tinylogin/ChangeLog
index 658b824b3805..45123c3337d1 100644
--- a/sys-apps/tinylogin/ChangeLog
+++ b/sys-apps/tinylogin/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for sys-apps/tinylogin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/ChangeLog,v 1.3 2003/07/07 20:12:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/ChangeLog,v 1.4 2003/07/15 18:19:20 vapier Exp $
*tinylogin-1.4 (09 Jul 2003)
+ 15 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Add local use flag uclibc.
+
09 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
Version bumpage.
diff --git a/sys-apps/tinylogin/tinylogin-1.4.ebuild b/sys-apps/tinylogin/tinylogin-1.4.ebuild
index 5167e690f8fc..820c472cecd6 100644
--- a/sys-apps/tinylogin/tinylogin-1.4.ebuild
+++ b/sys-apps/tinylogin/tinylogin-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/tinylogin-1.4.ebuild,v 1.1 2003/07/07 20:12:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/tinylogin/tinylogin-1.4.ebuild,v 1.2 2003/07/15 18:19:20 vapier Exp $
DESCRIPTION="worlds smallest login/passwd/getty/etc"
HOMEPAGE="http://tinylogin.busybox.net/"
@@ -9,12 +9,19 @@ SRC_URI="http://tinylogin.busybox.net/downloads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
+IUSE="uclibc"
DEPEND="virtual/glibc"
src_compile() {
local myconf=""
use static && myconf="${myconf} DOSTATIC=true"
+ if [ `use uclibc` ] ; then
+ myconf="${myconf} \
+ CC=/usr/i386-linux-uclibc/bin/i386-uclibc-gcc \
+ USE_SYSTEM_PWD=false"
+ unset CFLAGS
+ fi
emake ${myconf} || die
}