summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-25 05:12:31 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-25 05:12:31 +0000
commit2fe55a63b020f2802a9cf1abd66b6f23fb85bc7c (patch)
tree09f58876c8c6092f5b7121348f09558b8aa8cf5a /sys-apps
parentBump to gcc-4.1.0_rc2 (diff)
downloadhistorical-2fe55a63b020f2802a9cf1abd66b6f23fb85bc7c.tar.gz
historical-2fe55a63b020f2802a9cf1abd66b6f23fb85bc7c.tar.bz2
historical-2fe55a63b020f2802a9cf1abd66b6f23fb85bc7c.zip
disable splash module #124010
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/initng/files/digest-initng-0.5.43
-rw-r--r--sys-apps/initng/initng-0.5.4.ebuild35
-rw-r--r--sys-apps/initng/initng-9999.ebuild3
3 files changed, 39 insertions, 2 deletions
diff --git a/sys-apps/initng/files/digest-initng-0.5.4 b/sys-apps/initng/files/digest-initng-0.5.4
new file mode 100644
index 000000000000..b355ce3ab37c
--- /dev/null
+++ b/sys-apps/initng/files/digest-initng-0.5.4
@@ -0,0 +1,3 @@
+MD5 eeea6ef8afb76c292f4a36200e2905c6 initng-0.5.4.tar.bz2 1028470
+RMD160 ee88954e121e5675968ee558fc01f42a7e9ae35b initng-0.5.4.tar.bz2 1028470
+SHA256 935675e81929ba9efbbf91cb37f676c7ae42e83f7ab60f88c9ba6e33422b0c08 initng-0.5.4.tar.bz2 1028470
diff --git a/sys-apps/initng/initng-0.5.4.ebuild b/sys-apps/initng/initng-0.5.4.ebuild
new file mode 100644
index 000000000000..899adabb78fd
--- /dev/null
+++ b/sys-apps/initng/initng-0.5.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-0.5.4.ebuild,v 1.1 2006/02/25 05:12:31 vapier Exp $
+
+DESCRIPTION="A next generation init replacement"
+HOMEPAGE="http://initng.thinktux.net/"
+SRC_URI="http://initng.thinktux.net/download/v${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug"
+
+src_compile() {
+ econf \
+ --prefix=/ \
+ $(use_enable debug) \
+ --with-doc-dir=/usr/share/doc/${PF} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ # Dont need libtool linker scripts, so punt em
+ find "${D}" -name '*.la' -exec rm {} \;
+ # other packages install these
+ rm "${D}"/sbin/{{ifplugd,wpa_cli}.action} || die
+ dodoc README FAQ AUTHORS ChangeLog NEWS TEMPLATE_HEADER TODO
+}
+
+pkg_postinst() {
+ einfo "remember to add init=/sbin/initng in your grub or lilo config"
+ einfo "to use initng Happy testing."
+}
diff --git a/sys-apps/initng/initng-9999.ebuild b/sys-apps/initng/initng-9999.ebuild
index adf5a3d56c23..7580e666a77b 100644
--- a/sys-apps/initng/initng-9999.ebuild
+++ b/sys-apps/initng/initng-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.6 2006/02/24 00:51:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-9999.ebuild,v 1.7 2006/02/25 05:12:31 vapier Exp $
ESVN_REPO_URI="http://svn.initng.thinktux.net/initng/trunk"
ESVN_PROJECT="initng"
@@ -25,7 +25,6 @@ src_unpack() {
src_compile() {
econf \
--prefix=/ \
- --with-splash \
$(use_enable debug) \
--with-doc-dir=/usr/share/doc/${PF} \
|| die