summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-08-29 12:45:51 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-08-29 12:45:51 +0000
commit4a2fa157b9210a2a5c11d99f5b7bf70e79de293c (patch)
treecd484e4d027151940b6fa0b582815d3488d73730 /sys-apps/xmbmon
parentVersion bump. (diff)
downloadhistorical-4a2fa157b9210a2a5c11d99f5b7bf70e79de293c.tar.gz
historical-4a2fa157b9210a2a5c11d99f5b7bf70e79de293c.tar.bz2
historical-4a2fa157b9210a2a5c11d99f5b7bf70e79de293c.zip
Version bump.
Diffstat (limited to 'sys-apps/xmbmon')
-rw-r--r--sys-apps/xmbmon/Manifest4
-rw-r--r--sys-apps/xmbmon/files/digest-xmbmon-2.0.31
-rw-r--r--sys-apps/xmbmon/xmbmon-2.0.3.ebuild53
3 files changed, 56 insertions, 2 deletions
diff --git a/sys-apps/xmbmon/Manifest b/sys-apps/xmbmon/Manifest
index 4dba8e3d6552..cf65fcf00d48 100644
--- a/sys-apps/xmbmon/Manifest
+++ b/sys-apps/xmbmon/Manifest
@@ -1,5 +1,5 @@
-MD5 f9de2e9b5dcaabd0807b9cc5f12afd83 ChangeLog 558
-MD5 fa4773e08c1486c122a8ca23ab991172 xmbmon-2.0.3.ebuild 1286
+MD5 5171c0a4de20266480e2f00479fcc963 ChangeLog 558
+MD5 13c981ca71bd42a591978208fd78ae75 xmbmon-2.0.3.ebuild 1387
MD5 7583f08af8f044e542f9f68014efd88c xmbmon-2.0.1.ebuild 1229
MD5 0c84fd7edf198ccac16658e81a11848a files/digest-xmbmon-2.0.1 60
MD5 bcbf7a71b0097dda70c0ca258cf00c84 files/digest-xmbmon-2.0.3 61
diff --git a/sys-apps/xmbmon/files/digest-xmbmon-2.0.3 b/sys-apps/xmbmon/files/digest-xmbmon-2.0.3
new file mode 100644
index 000000000000..441021beef9e
--- /dev/null
+++ b/sys-apps/xmbmon/files/digest-xmbmon-2.0.3
@@ -0,0 +1 @@
+MD5 f84e48b8e433170358cec840020b2419 xmbmon203.tar.gz 113252
diff --git a/sys-apps/xmbmon/xmbmon-2.0.3.ebuild b/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
new file mode 100644
index 000000000000..08e01d472762
--- /dev/null
+++ b/sys-apps/xmbmon/xmbmon-2.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/xmbmon/xmbmon-2.0.3.ebuild,v 1.1 2003/08/29 12:45:43 plasmaroo Exp $
+
+MY_P="${PN}${PV//.}"
+DESCRIPTION="Mother Board Monitor Program for X Window System"
+HOMEPAGE="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/download.html"
+SRC_URI="http://www.nt.phys.kyushu-u.ac.jp/shimizu/download/${MY_P}.tar.gz"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE="X"
+
+DEPEND="virtual/glibc
+ X? ( virtual/x11 )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+
+ econf || die "Configure failed"
+ emake CFLAGS="$CFLAGS \$(INCLUDES) \$(DEFS)" mbmon || die "Make mbmon failed"
+ if use X; then
+ emake CFLAGSX="$CFLAGS \$(INCLUDES) \$(DEFS)" xmbmon || die "Make xmbmon failed"
+ fi
+}
+
+src_install() {
+
+ dosbin mbmon
+ fperms 4555 /usr/sbin/mbmon
+ fowners root.wheel /usr/sbin/mbmon
+
+ if use X; then
+ dosbin xmbmon
+ fperms 4555 /usr/sbin/xmbmon
+ fowners root.wheel /usr/sbin/xmbmon
+ fi
+
+ dodoc 00README*
+}
+
+pkg_postinst() {
+ echo
+ einfo "These programs access SMBus/ISA-IO ports without any kind"
+ einfo "of checking. It is, therefore, very dangerous and may cause"
+ einfo "a system-crash. Make sure you read 00README.txt,"
+ einfo "section 4, 'How to use!'"
+ echo
+ ewarn "Binaries are setuid root!"
+ echo
+}