summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-12 14:58:18 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-12 14:58:18 +0000
commit44a68bd6e43b18efc1e788497fca885db086cd19 (patch)
treeb2989c1cbc912a219aa8634f6b212e2dfeae1267 /sys-apps/which
parentVersion bump (diff)
downloadhistorical-44a68bd6e43b18efc1e788497fca885db086cd19.tar.gz
historical-44a68bd6e43b18efc1e788497fca885db086cd19.tar.bz2
historical-44a68bd6e43b18efc1e788497fca885db086cd19.zip
Version bump
Diffstat (limited to 'sys-apps/which')
-rw-r--r--sys-apps/which/Manifest4
-rw-r--r--sys-apps/which/files/digest-which-2.151
-rw-r--r--sys-apps/which/which-2.15.ebuild38
3 files changed, 41 insertions, 2 deletions
diff --git a/sys-apps/which/Manifest b/sys-apps/which/Manifest
index cd93d047539e..d01215afbc01 100644
--- a/sys-apps/which/Manifest
+++ b/sys-apps/which/Manifest
@@ -1,8 +1,8 @@
MD5 425b18b6400ea78be96c7e34c69b140a which-2.12-r2.ebuild 827
MD5 5f3fc8f245b209443a3ebce442be349d which-2.13.ebuild 824
-MD5 bbacaff472996cfb5f96002f87bd81e2 which-2.15.ebuild 854
+MD5 61c0625cb66855fea2d92b7e97cc7f13 which-2.15.ebuild 852
MD5 b87b97ac3873b14c038e929b7a109d03 which-2.14.ebuild 843
-MD5 8abe6062faf7d95cc88e607a18602759 ChangeLog 1040
+MD5 a77a4f515120acf37bfcc68144bb1957 ChangeLog 1155
MD5 67fe518b83b5c8527e479d2182dcfbf0 files/digest-which-2.12-r2 62
MD5 96aac684502b2a9affae1d965834dd21 files/which-gentoo.patch 340
MD5 f7d151187c984a77310a2118896c7d34 files/digest-which-2.13 62
diff --git a/sys-apps/which/files/digest-which-2.15 b/sys-apps/which/files/digest-which-2.15
new file mode 100644
index 000000000000..641f6b1603e6
--- /dev/null
+++ b/sys-apps/which/files/digest-which-2.15
@@ -0,0 +1 @@
+MD5 d749036d9be9132a00fc2360e61d92e5 which-2.15.tar.gz 125462
diff --git a/sys-apps/which/which-2.15.ebuild b/sys-apps/which/which-2.15.ebuild
new file mode 100644
index 000000000000..dedfb1afa915
--- /dev/null
+++ b/sys-apps/which/which-2.15.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/which/which-2.15.ebuild,v 1.1 2003/09/12 14:58:16 seemant Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Prints out location of specified executables that are in your path"
+HOMEPAGE="http://www.xs4all.nl/~carlo17/which/"
+SRC_URI="http://www.xs4all.nl/~carlo17/which/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+RDEPEND="virtual/glibc
+ sys-apps/texinfo"
+
+DEPEND="${RDEPEND}"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/which-gentoo.patch
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die
+ make || die
+}
+
+src_install() {
+ dobin which
+ doman which.1
+ doinfo which.info
+ dodoc AUTHORS COPYING EXAMPLES NEWS README*
+}