summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-10-02 14:43:50 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-10-02 14:43:50 +0000
commit81d0afb71f974cfba017271c8bd2d76bfcfa8dcd (patch)
tree7b0c9605bc57c7a42a3357ad51b7aa197965671f /sys-apps/subterfugue
parentFixes for libEMF and ming problems (diff)
downloadhistorical-81d0afb71f974cfba017271c8bd2d76bfcfa8dcd.tar.gz
historical-81d0afb71f974cfba017271c8bd2d76bfcfa8dcd.tar.bz2
historical-81d0afb71f974cfba017271c8bd2d76bfcfa8dcd.zip
fix compile problems for gcc3.3
Diffstat (limited to 'sys-apps/subterfugue')
-rw-r--r--sys-apps/subterfugue/ChangeLog8
-rw-r--r--sys-apps/subterfugue/Manifest8
-rw-r--r--sys-apps/subterfugue/files/digest-subterfugue-0.2-r13
-rw-r--r--sys-apps/subterfugue/files/subterfugue-0.2.1a-gcc33.patch16
-rw-r--r--sys-apps/subterfugue/metadata.xml9
-rw-r--r--sys-apps/subterfugue/subterfugue-0.2-r1.ebuild57
-rw-r--r--sys-apps/subterfugue/subterfugue-0.2.1a.ebuild4
7 files changed, 39 insertions, 66 deletions
diff --git a/sys-apps/subterfugue/ChangeLog b/sys-apps/subterfugue/ChangeLog
index 7b2b88e913f1..36b98ad8d8e1 100644
--- a/sys-apps/subterfugue/ChangeLog
+++ b/sys-apps/subterfugue/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/subterfugue
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/ChangeLog,v 1.6 2003/04/08 23:06:23 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/ChangeLog,v 1.7 2003/10/02 14:43:45 liquidx Exp $
+
+ 02 Oct 2003; Alastair Tse <liquidx@gentoo.org> metadata.xml,
+ subterfugue-0.2-r1.ebuild, subterfugue-0.2.1a.ebuild,
+ files/subterfugue-0.2.1a-gcc33.patch:
+ added gcc3.3 compile fixes. this package is most likely the end of the line as
+ the author has stopped maintaining it.
*subterfugue-0.2.1a (09 Apr 2003)
diff --git a/sys-apps/subterfugue/Manifest b/sys-apps/subterfugue/Manifest
index 0f2e2e776b5a..a811bb822071 100644
--- a/sys-apps/subterfugue/Manifest
+++ b/sys-apps/subterfugue/Manifest
@@ -1,6 +1,6 @@
-MD5 9fb1eef3953da860ee08445b6dab30b4 ChangeLog 1190
-MD5 44daa407665c768f1b49b4cacba207f6 subterfugue-0.2-r1.ebuild 1157
-MD5 54e8c2063c8a1435bbb6ce363a652dae subterfugue-0.2.1a.ebuild 1436
-MD5 5a06da450cc670aae0bab4df57ae7807 files/digest-subterfugue-0.2-r1 208
+MD5 973393a29ce87ec59653289cd6921851 ChangeLog 1472
+MD5 c74a0c869944b1be3b931288c2c78663 metadata.xml 298
+MD5 5724d0f8e29d2c0b4f35444a35212b40 subterfugue-0.2.1a.ebuild 1542
MD5 130cd3eff4e9c321f030293a0e0fe36b files/digest-subterfugue-0.2.1a 211
+MD5 256769a72fc0352e9c2539b7f320cbea files/subterfugue-0.2.1a-gcc33.patch 591
MD5 7e3351bf87121d72b46ae2af34b6df22 files/subterfugue-0.2.1a-setup.py 460
diff --git a/sys-apps/subterfugue/files/digest-subterfugue-0.2-r1 b/sys-apps/subterfugue/files/digest-subterfugue-0.2-r1
deleted file mode 100644
index 92239f9fa8ff..000000000000
--- a/sys-apps/subterfugue/files/digest-subterfugue-0.2-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 7e3351bf87121d72b46ae2af34b6df22 /files/subterfugue-0.2.1a-setup.py 460
-MD5 25636e0e04033574e9837ca0c48e66fa /subterfugue-0.2-r1.ebuild 1158
-MD5 4dd19fb028769432269e19480c4aea2c subterfugue-0.2.tgz 73918
diff --git a/sys-apps/subterfugue/files/subterfugue-0.2.1a-gcc33.patch b/sys-apps/subterfugue/files/subterfugue-0.2.1a-gcc33.patch
new file mode 100644
index 000000000000..ebc850b2bd8f
--- /dev/null
+++ b/sys-apps/subterfugue/files/subterfugue-0.2.1a-gcc33.patch
@@ -0,0 +1,16 @@
+--- ptracemodule.c 2001-11-26 04:24:30.000000000 +0000
++++ /tmp/ptracemodule.c 2003-10-02 15:28:17.173323016 +0100
+@@ -292,9 +292,10 @@
+ #ifdef PTRACE_SETOPTIONS
+
+ static char ptrace_settracesysgood__doc__[] =
+-"settracesysgood(pid) -> None\n\
+-Set the TRACESYSGOOD flag for this child. This causes the high (0x80) bit to
+- be set on system call stops.";
++"settracesysgood(pid) -> None\n" \
++"Set the TRACESYSGOOD flag for this child." \
++"This causes the high (0x80) bit to" \
++" be set on system call stops.";
+
+ static PyObject *
+ ptrace_settracesysgood(PyObject *self, PyObject *args)
diff --git a/sys-apps/subterfugue/metadata.xml b/sys-apps/subterfugue/metadata.xml
new file mode 100644
index 000000000000..481118976f0f
--- /dev/null
+++ b/sys-apps/subterfugue/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer>
+ <email>liquidx@gentoo.org</email>
+ <description>Currently maintainerless. Take over if you wish.</description>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild b/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
deleted file mode 100644
index 4273881ff4c0..000000000000
--- a/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild,v 1.16 2003/09/07 01:02:56 msterret Exp $
-
-IUSE="gtk"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="strace meets expect"
-SRC_URI="mirror://sourceforge/subterfugue/${P}.tgz"
-HOMEPAGE="http://www.subterfugue.org/"
-KEYWORDS="x86 amd64 -ppc"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND=">=dev-lang/python-2.0
- gtk? ( =x11-libs/gtk+-1.2* )"
-
-src_unpack() {
- PYVER=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
-
- unpack ${A}
-
- cd ${S}
-
- cp Makefile Makefile.orig
- sed "s/python1.5/python${PYVER}/" < Makefile.orig > Makefile
-}
-
-src_compile() {
- # breaks down with emake
- make || die
-
- cp dsf dsf.orig
- sed -e "s:SUBTERFUGUE_ROOT=.*:SUBTERFUGUE_ROOT=/usr/share/subterfuge/:" \
- < dsf.orig > sf
-}
-
-src_install() {
- into /usr
-
- dobin sf
-
- dodoc COPYING CREDITS GNU-entry INSTALL INTERNALS NEWS README TODO
-
- doman doc/sf.1
-
- SH=/usr/share/subterfuge
-
- exeinto ${SH}
- doexe *.{py,pyc}
-
- exeinto ${SH}/tricks
- doexe tricks/*.{py,pyc}
-
- exeinto ${SH}/modules
- doexe modules/*.so
-}
diff --git a/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild b/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild
index 43b02c778fa1..cdcd35869634 100644
--- a/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild
+++ b/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild,v 1.3 2003/09/07 01:02:58 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild,v 1.4 2003/10/02 14:43:45 liquidx Exp $
inherit distutils
@@ -25,6 +25,8 @@ src_unpack() {
# custom gentoo setup.py to get around <=python-2.1 requirement
# - <liquidx@gentoo.org>
cp ${FILESDIR}/${P}-setup.py ${S}/setup.py || die "copying custom setup.py failed"
+ # patch for gcc33 - liquidx@gentoo.org
+ EPATCH_OPTS="-d ${S}/modules" epatch ${FILESDIR}/${P}-gcc33.patch
}
src_compile() {