summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-04-08 23:04:23 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-04-08 23:04:23 +0000
commit4c8671fa89a75129f203fb6552a384c8a98e2177 (patch)
tree605910c0d5ed6369bcda55871a11d3ac6ce060e7 /sys-apps/subterfugue
parentfixes for python2.2 (diff)
downloadhistorical-4c8671fa89a75129f203fb6552a384c8a98e2177.tar.gz
historical-4c8671fa89a75129f203fb6552a384c8a98e2177.tar.bz2
historical-4c8671fa89a75129f203fb6552a384c8a98e2177.zip
fixes for python2.2
Diffstat (limited to 'sys-apps/subterfugue')
-rw-r--r--sys-apps/subterfugue/files/digest-subterfugue-0.2-r12
-rw-r--r--sys-apps/subterfugue/files/digest-subterfugue-0.2.1a2
-rw-r--r--sys-apps/subterfugue/files/subterfugue-0.2.1a-setup.py10
-rw-r--r--sys-apps/subterfugue/subterfugue-0.2-r1.ebuild6
-rw-r--r--sys-apps/subterfugue/subterfugue-0.2.1a.ebuild56
5 files changed, 73 insertions, 3 deletions
diff --git a/sys-apps/subterfugue/files/digest-subterfugue-0.2-r1 b/sys-apps/subterfugue/files/digest-subterfugue-0.2-r1
index 8b66ce9d99bc..92239f9fa8ff 100644
--- a/sys-apps/subterfugue/files/digest-subterfugue-0.2-r1
+++ b/sys-apps/subterfugue/files/digest-subterfugue-0.2-r1
@@ -1 +1,3 @@
+MD5 7e3351bf87121d72b46ae2af34b6df22 /files/subterfugue-0.2.1a-setup.py 460
+MD5 25636e0e04033574e9837ca0c48e66fa /subterfugue-0.2-r1.ebuild 1158
MD5 4dd19fb028769432269e19480c4aea2c subterfugue-0.2.tgz 73918
diff --git a/sys-apps/subterfugue/files/digest-subterfugue-0.2.1a b/sys-apps/subterfugue/files/digest-subterfugue-0.2.1a
index e36fb8b61958..ebb00be8dd29 100644
--- a/sys-apps/subterfugue/files/digest-subterfugue-0.2.1a
+++ b/sys-apps/subterfugue/files/digest-subterfugue-0.2.1a
@@ -1,3 +1,3 @@
MD5 7e3351bf87121d72b46ae2af34b6df22 /files/subterfugue-0.2.1a-setup.py 460
-MD5 8d62642d3e3e689ebe763be762a7a66e /subterfugue-0.2.1a.ebuild 1437
+MD5 d4a1fb8ff7b26910629608a8c0fcdef7 /subterfugue-0.2.1a.ebuild 1437
MD5 e55cbdc6fc532f1f49bfb6ecfc5e5ad0 subterfugue-0.2.1a.tgz 77845
diff --git a/sys-apps/subterfugue/files/subterfugue-0.2.1a-setup.py b/sys-apps/subterfugue/files/subterfugue-0.2.1a-setup.py
new file mode 100644
index 000000000000..e11c7fa16b11
--- /dev/null
+++ b/sys-apps/subterfugue/files/subterfugue-0.2.1a-setup.py
@@ -0,0 +1,10 @@
+from distutils.core import setup, Extension
+
+ptracemodule = Extension("ptrace", sources = ['modules/ptracemodule.c'])
+linuxmodule = Extension("linux", sources = ['modules/linuxmodule.c'])
+svr4module = Extension("svr4", sources = ['modules/svr4module.c'])
+_subterfuguemodule = Extension("_subterfugue", sources= ['modules/_subterfuguemodule.c'])
+
+setup (name = 'ptrace',
+ ext_modules = [ptracemodule, linuxmodule, svr4module, _subterfuguemodule])
+
diff --git a/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild b/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
index d443fd25eb7f..bad691323791 100644
--- a/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
+++ b/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild,v 1.13 2003/02/13 16:15:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2-r1.ebuild,v 1.14 2003/04/08 23:04:05 liquidx Exp $
IUSE="gtk"
@@ -16,12 +16,14 @@ DEPEND=">=dev-lang/python-2.0
gtk? ( =x11-libs/gtk+-1.2* )"
src_unpack() {
+ PYVER=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
+
unpack ${A}
cd ${S}
cp Makefile Makefile.orig
- sed "s/python1.5/python2.0/" < Makefile.orig > Makefile
+ sed "s/python1.5/python${PYVER}/" < Makefile.orig > Makefile
}
src_compile() {
diff --git a/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild b/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild
new file mode 100644
index 000000000000..ee2cbcae44c3
--- /dev/null
+++ b/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/subterfugue/subterfugue-0.2.1a.ebuild,v 1.1 2003/04/08 23:04:05 liquidx Exp $
+
+inherit distutils
+
+IUSE="gtk"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="strace meets expect"
+SRC_URI="mirror://sourceforge/subterfugue/${P}.tgz"
+HOMEPAGE="http://www.subterfugue.org/"
+KEYWORDS="~x86 -ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.0
+ gtk? ( =x11-libs/gtk+-1.2*
+ =dev-python/pygtk-0.6* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # custom gentoo setup.py to get around <=python-2.1 requirement
+ # - <liquidx@gentoo.org>
+ cp ${FILESDIR}/${P}-setup.py ${S}/setup.py || die "copying custom setup.py failed"
+}
+
+src_compile() {
+ # we use distutils to build python extensions (*.so) ONLY
+ distutils_src_compile
+ # manually python bytecode compile *.py
+ make sf dsf compilepy || die "error compiling python modules"
+
+ # remove trace of buildroot
+ cp dsf dsf.orig
+ sed -e "s:SUBTERFUGUE_ROOT=.*:SUBTERFUGUE_ROOT=/usr/lib/subterfugue/:" \
+ < dsf.orig > sf
+}
+
+src_install() {
+ # installs python extensions (*.so)
+ mydoc="GNU-entry INTERNALS"
+ distutils_src_install
+
+ # installs python scripts (*.py?)
+ insinto /usr/lib/subterfugue
+ doins *.py *.py[co]
+ insinto /usr/lib/subterfugue/tricks
+ doins tricks/*.py tricks/*.py[co]
+
+ # install binary and manpage
+ dobin sf
+ doman doc/sf.1
+}