summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-07-28 23:22:41 +0000
committerChris White <chriswhite@gentoo.org>2005-07-28 23:22:41 +0000
commitf293d32bfffdcde0129bc4462126e9d3084db2f0 (patch)
treed75ff36d6db0dd6d961c7923b6cdb76201cca0b6 /sys-apps/rlocate/rlocate-0.3.2.ebuild
parentAdapted the last old ebuild. (diff)
downloadhistorical-f293d32bfffdcde0129bc4462126e9d3084db2f0.tar.gz
historical-f293d32bfffdcde0129bc4462126e9d3084db2f0.tar.bz2
historical-f293d32bfffdcde0129bc4462126e9d3084db2f0.zip
Version bump. Upstream bug fixes mainly. Released to work with kernel 2.6.13.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-apps/rlocate/rlocate-0.3.2.ebuild')
-rw-r--r--sys-apps/rlocate/rlocate-0.3.2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-apps/rlocate/rlocate-0.3.2.ebuild b/sys-apps/rlocate/rlocate-0.3.2.ebuild
new file mode 100644
index 000000000000..b210dae92dc9
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.3.2.ebuild,v 1.1 2005/07/28 23:22:41 chriswhite Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^RLOCATE_GRP/s:=.*:=locate:' \
+ -e 's/rlocate-module//g' \
+ Makefile.in || die "sed group"
+ rm -f rlocate-scripts/Makefile
+ sed -i \
+ -e '/groupadd/d' \
+ -e '/chown/s/root:$(rlocate)/root:locate/g' \
+ Makefile.in rlocate-scripts/Makefile.in
+ sed -i \
+ -e '/DRLOCATE_GRP/s:$(rlocate):locate:' \
+ rlocate-daemon/Makefile.in
+}
+
+src_compile() {
+ econf --enable-sandboxed --with-kernel=${KV_DIR} || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}