summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2005-01-08 03:13:06 +0000
committerChris PeBenito <pebenito@gentoo.org>2005-01-08 03:13:06 +0000
commit08f556c51e0adaf98d13766117444778c6643d37 (patch)
treeeb9aa2e4c65aa96a2ee50da520ef051b9d3adb54 /sys-apps/policycoreutils
parentNew upstream release. Mark 1.18 stable. (diff)
downloadhistorical-08f556c51e0adaf98d13766117444778c6643d37.tar.gz
historical-08f556c51e0adaf98d13766117444778c6643d37.tar.bz2
historical-08f556c51e0adaf98d13766117444778c6643d37.zip
New upstream release. Mark 1.18-r1 stable.
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/ChangeLog8
-rw-r--r--sys-apps/policycoreutils/files/digest-policycoreutils-1.202
-rw-r--r--sys-apps/policycoreutils/policycoreutils-1.18-r1.ebuild4
-rw-r--r--sys-apps/policycoreutils/policycoreutils-1.20.ebuild125
4 files changed, 136 insertions, 3 deletions
diff --git a/sys-apps/policycoreutils/ChangeLog b/sys-apps/policycoreutils/ChangeLog
index b25cd33c1659..75246624bfc7 100644
--- a/sys-apps/policycoreutils/ChangeLog
+++ b/sys-apps/policycoreutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/policycoreutils
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.38 2005/01/04 01:11:35 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/ChangeLog,v 1.39 2005/01/08 03:13:06 pebenito Exp $
+
+*policycoreutils-1.20 (07 Jan 2005)
+
+ 07 Jan 2005; Chris PeBenito <pebenito@gentoo.org>
+ policycoreutils-1.18-r1.ebuild, +policycoreutils-1.20.ebuild:
+ New upstream release. Mark 1.18-r1 stable.
*policycoreutils-1.18-r1 (03 Jan 2005)
diff --git a/sys-apps/policycoreutils/files/digest-policycoreutils-1.20 b/sys-apps/policycoreutils/files/digest-policycoreutils-1.20
new file mode 100644
index 000000000000..43a1c369ba47
--- /dev/null
+++ b/sys-apps/policycoreutils/files/digest-policycoreutils-1.20
@@ -0,0 +1,2 @@
+MD5 21c7265641ef35278aa935afe255447a policycoreutils-1.20.tgz 47062
+MD5 e63b6dc5665520e51c88c08dcf2c71aa policycoreutils-extra-1.11.tar.bz2 10052
diff --git a/sys-apps/policycoreutils/policycoreutils-1.18-r1.ebuild b/sys-apps/policycoreutils/policycoreutils-1.18-r1.ebuild
index 100c150e5a8f..69895ebc5aa3 100644
--- a/sys-apps/policycoreutils/policycoreutils-1.18-r1.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-1.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.18-r1.ebuild,v 1.1 2005/01/04 01:11:35 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.18-r1.ebuild,v 1.2 2005/01/08 03:13:06 pebenito Exp $
IUSE="build nls pam"
@@ -15,7 +15,7 @@ SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz
mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="x86 ppc sparc amd64"
RDEPEND=">=sys-libs/libselinux-${PV}
!build? ( pam? ( sys-libs/pam ) >=sys-libs/libsepol-${SEPOL_VER} )
diff --git a/sys-apps/policycoreutils/policycoreutils-1.20.ebuild b/sys-apps/policycoreutils/policycoreutils-1.20.ebuild
new file mode 100644
index 000000000000..4a847ccfdc7c
--- /dev/null
+++ b/sys-apps/policycoreutils/policycoreutils-1.20.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/policycoreutils/policycoreutils-1.20.ebuild,v 1.1 2005/01/08 03:13:06 pebenito Exp $
+
+IUSE="build nls pam"
+
+inherit eutils
+
+EXTRAS_VER="1.11"
+SEPOL_VER="1.2"
+
+DESCRIPTION="SELinux core utilities"
+HOMEPAGE="http://www.nsa.gov/selinux"
+SRC_URI="http://www.nsa.gov/selinux/archives/${P}.tgz
+ mirror://gentoo/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+RDEPEND=">=sys-libs/libselinux-${PV}
+ !build? ( pam? ( sys-libs/pam ) >=sys-libs/libsepol-${SEPOL_VER} )
+ build? ( sys-apps/baselayout )"
+
+DEPEND="${RDEPEND}
+ !build? ( nls? ( sys-devel/gettext ) )"
+
+S2=${WORKDIR}/policycoreutils-extra
+
+throw_pam_warning() {
+ # this is an extremely important message that needs to be seen
+ # thus it being shown at the beginning and end of the ebuild
+
+ if ! useq pam; then
+ eerror "PAM is disabled. This is not a supported config for"
+ eerror "general use. Disabling PAM decreases security with"
+ eerror "respect to SELinux protection of authentication."
+ eerror "It also requires policy changes."
+ ebeep 4
+ epause 4
+ fi
+}
+
+pkg_setup() {
+ throw_pam_warning
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # fixfiles is extremely dangerous
+ sed -i -e '/^all/s/fixfiles//' ${S}/scripts/Makefile \
+ || die "fixfiles sed 1 failed"
+ sed -i -e '/fixfiles/d' ${S}/scripts/Makefile \
+ || die "fixfiles sed 2 failed"
+
+ if ! useq pam; then
+ # disable pam
+ sed -i -e s/-lpam/-lcrypt/ -e s/-lpam_misc// -e s/-DUSE_PAM// \
+ ${S}/run_init/Makefile || die "PAM sed 1 failed"
+ sed -i -e s/-lpam/-lcrypt/ -e s/-lpam_misc// -e s/-DUSE_PAM// \
+ ${S}/newrole/Makefile || die "PAM sed 2 failed"
+ sed -i -e s/-lpam/-lcrypt/ -e s/-lpam_misc// -e s/-DUSE_PAM// \
+ ${S2}/src/Makefile || die "PAM sed 3 failed"
+ fi
+
+ if ! useq nls; then
+ # disable locale stuff
+ sed -i -e s/-DUSE_NLS// ${S}/run_init/Makefile \
+ || die "NLS sed 1 failed"
+ sed -i -e s/-DUSE_NLS// ${S}/newrole/Makefile \
+ || die "NLS sed 2 failed"
+ sed -i -e s/-DUSE_NLS// ${S}/load_policy/Makefile \
+ || die "NLS sed 3 failed"
+ sed -i -e 's/ po //' ${S}/Makefile \
+ || die "NLS sed 4 failed"
+ fi
+
+ # fix up to accept Gentoo CFLAGS
+ local SUBDIRS="`cd ${S} && find -type d | cut -d/ -f2`"
+ for i in ${SUBDIRS}; do
+ sed -i -e "s:-Wall:-Wall ${CFLAGS}:g" ${S}/${i}/Makefile \
+ || die "${i} Makefile CFLAGS fix failed."
+ done
+}
+
+src_compile() {
+ if useq build; then
+ einfo "Compiling setfiles"
+ emake -C ${S}/setfiles || die
+ else
+ einfo "Compiling policycoreutils"
+ emake -C ${S} || die
+ einfo "Compiling policycoreutils-extra"
+ emake -C ${S2} || die
+ fi
+}
+
+src_install() {
+ if useq build; then
+ dosbin ${S}/setfiles/setfiles
+ else
+ einfo "Installing policycoreutils"
+ make DESTDIR="${D}" -C ${S} install || die
+ einfo "Installing policycoreutils-extra"
+ make DESTDIR="${D}" -C ${S2} install || die
+ fi
+
+ useq pam || rm -fR ${D}/etc/pam.d
+}
+
+pkg_postinst() {
+ if useq build; then
+ # need to ensure these
+ mkdir -p ${ROOT}/selinux
+ touch ${ROOT}/selinux/.keep
+ mkdir -p ${ROOT}/sys
+ touch ${ROOT}/sys/.keep
+ mkdir -p ${ROOT}/dev/pts
+ touch ${ROOT}/dev/pts/.keep
+ chmod 0666 ${ROOT}/dev/{ptmx,tty}
+ fi
+
+ throw_pam_warning
+}