summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2002-06-04 03:15:05 +0000
committerMark Guertin <gerk@gentoo.org>2002-06-04 03:15:05 +0000
commitbf9c0df5c0711e804274f323b0fc38f4a36ce2ea (patch)
tree205cde247d75d3256604ade366e06e880a7521e5 /sys-apps/pbbuttonsd
parentUpdated to r2 ebuild, added init scripts and adjusted missing options in ebuild (diff)
downloadhistorical-bf9c0df5c0711e804274f323b0fc38f4a36ce2ea.tar.gz
historical-bf9c0df5c0711e804274f323b0fc38f4a36ce2ea.tar.bz2
historical-bf9c0df5c0711e804274f323b0fc38f4a36ce2ea.zip
added files for r2 ebuild
Diffstat (limited to 'sys-apps/pbbuttonsd')
-rw-r--r--sys-apps/pbbuttonsd/files/pbbuttonsd.rc519
-rw-r--r--sys-apps/pbbuttonsd/pbbuttonsd-0.4.9-r2.ebuild29
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-apps/pbbuttonsd/files/pbbuttonsd.rc5 b/sys-apps/pbbuttonsd/files/pbbuttonsd.rc5
new file mode 100644
index 000000000000..357711f5ec9d
--- /dev/null
+++ b/sys-apps/pbbuttonsd/files/pbbuttonsd.rc5
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pbbuttonsd/files/pbbuttonsd.rc5,v 1.1 2002/06/04 03:15:05 gerk Exp $
+
+
+start() {
+ ebegin "Starting pbbuttonsd"
+ start-stop-daemon --start --quiet --pidfile /var/run/pbbuttons.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pbbuttonsd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/pbbuttonsd.pid
+ eend $?
+}
+
+
diff --git a/sys-apps/pbbuttonsd/pbbuttonsd-0.4.9-r2.ebuild b/sys-apps/pbbuttonsd/pbbuttonsd-0.4.9-r2.ebuild
new file mode 100644
index 000000000000..ae71b018c24f
--- /dev/null
+++ b/sys-apps/pbbuttonsd/pbbuttonsd-0.4.9-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mark Guertin <gerk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/pbbuttonsd/pbbuttonsd-0.4.9-r2.ebuild,v 1.1 2002/06/04 03:15:05 gerk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PBButtons is a PPC-only program to map special Powerbook/iBook keys in Linux"
+SRC_URI="http://www.cymes.de/members/joker/projects/pbbuttons/tar/${P}.tar.gz"
+HOMEPAGE="http://www.cymes.de/members/joker/projects/pbbuttons/pbbuttons.html"
+DEPEND="virtual/glibc"
+RDEPEND=""
+SLOT=0
+LICENSE=GPL
+
+src_compile() {
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc || die "sorry, ppc-only package"
+ make || die "sorry, failed to compile pbbuttons"
+}
+
+src_install() {
+
+ make sysconfdir=${D}/etc DESTDIR=${D} install || die "failed to install"
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pbbuttonsd.rc5 pbbuttonsd
+ dodoc README COPYING
+
+}