summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-12-20 15:44:26 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-12-20 15:44:26 +0000
commit413acf9c0a95390aaf75832cc3337e6668e040f7 (patch)
tree9acb26b3a43aa6d2fb5e3d932c3866cd22ecb028 /sys-apps/lshw/lshw-02.00b.ebuild
parentNew version (diff)
downloadhistorical-413acf9c0a95390aaf75832cc3337e6668e040f7.tar.gz
historical-413acf9c0a95390aaf75832cc3337e6668e040f7.tar.bz2
historical-413acf9c0a95390aaf75832cc3337e6668e040f7.zip
Verison bumped. Removed old versions.
Diffstat (limited to 'sys-apps/lshw/lshw-02.00b.ebuild')
-rw-r--r--sys-apps/lshw/lshw-02.00b.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/lshw/lshw-02.00b.ebuild b/sys-apps/lshw/lshw-02.00b.ebuild
new file mode 100644
index 000000000000..4d09312e4d66
--- /dev/null
+++ b/sys-apps/lshw/lshw-02.00b.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/lshw/lshw-02.00b.ebuild,v 1.1 2004/12/20 15:44:26 matsuu Exp $
+
+inherit flag-o-matic
+
+MAJ_PV=${PV:0:5}
+MIN_PVE=${PV:5:7}
+MIN_PV=${MIN_PVE/b/B}
+
+MY_P="$PN-$MIN_PV.$MAJ_PV"
+DESCRIPTION="Hardware Lister"
+HOMEPAGE="http://ezix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ezix/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE="gtk2"
+
+DEPEND="virtual/libc
+ gtk2? ( >=x11-libs/gtk+-2 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # cpuid.cc uses inline asm and can not be linked when
+ # position independent code is desired.
+ filter-flags -fPIC
+ sed -i -e "/^CXXFLAGS/s/-Os/${CXXFLAGS}/" src/{gui/,core/,}/Makefile || die
+ emake || die
+ if use gtk2; then
+ emake gui || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if use gtk2; then
+ make DESTDIR=${D} install-gui || die
+ fi
+
+ dodoc TODO docs/proc_usb_info.txt
+}